View Full Version : Brushes around platform dissapear when testing?

09-07-2003, 11:36 PM
Hey well i got my elevators to finally work but the walls i made around it dissapear when i go to test it out. The glass door i made to get into the elevator is the only thing that has stayed. Why is this happening and how can i fix it. if i want to build a room that the elevator goes through to get to next floor will it do the same thing. Help me pls:confused: :confused: :confused:

09-10-2003, 05:47 PM
I've never heard of this happening. Hmmm... come on, experienced and wise JO people!! Answer this guy's question!

09-11-2003, 12:44 AM
Yeah i never heard of this either but i fixed it. What i did was make everything around it func_door but i gave it a targetname so only a switch would activate it. I did not make a switch so nothing would screw up. When i tested the map it was all there and i had no problems. Talk about dumb luck! Well this happened to me everytime i made an elevator so i did the same thing. Hopefully if anyone has this happen to them the will now know what to do;)

Druid Bremen
09-11-2003, 03:34 AM
OMG! Nice idea lol.

09-11-2003, 12:47 PM
oh yeah, one time i had a func_glass, and i didnt want it to be glass anymore, so i took out the func_glass line, and it disapeared in-game. It has to be a worldspawn, or something like that...

09-11-2003, 06:26 PM
I don't understand what your problem is. Is there another way you can explain it?

Pictures always help too. :D

09-12-2003, 04:20 PM
to "eldritch" my problem with my elevators before was that brushes that were close to the elevator were disappearing. I had made a room where the elevator would sit adn then the room would extend upwards towards the second floor. When i went to test this out for the first time... the room was gone
and there was a big hole on the second floor. the only brush that didnt disappear was a func_button glass brush which was the door to get into the elevator. I decided after trial and error that if i made the room around elevator all func_(door or button etc.) that it might stay since the glass door had stayed. This was all by chance so i tried and it work but i had to make the func brushes a target name so only a switch would move it. I didnt make a switch cause i didnt want the room to move lol. so it worked out and now i dont have to worry about it. :D

09-14-2003, 04:05 PM
Um...this is really a less-than-half solution. You see, now that you've made the room into ENTITIES, and not BRUSHES, there won't be any struct/vis blocking brushes there any more. This is a bad idea...and it sounds like you were starting with a VIS issue in the first place. You 'solved' it by making the VIS process not apply to the brushes in question (since ents don't block VIS), but this is bad, since it could cause problem for you down the road where too much of the map is draw at once (or worse, you could have one big leak where there used to be struct brushes and now there's a func_door.

Take a look around the forums to find hints on when and where to use detail brushes, structural brushes, hint brushes, and areaportals. Hopefully, after twiddling with that stuff and recompiling, the problem will go away.

@Matt-Liell: if you have a brushed-based entity that you don't want to be an entity any more, right-click and select "ungroup entity" instead of messing with classname keys.

09-14-2003, 04:51 PM
well i have been looking for a while to why my brushes disapeared but i could not find any help. If i ungroup those brushes they will disappear again. My map is now done and into pk3 form and i had no problems compiling it took about 3 min to compile thats not to bad is it?

Well ill keep looking and if i find the reason i will fix it thanks for the input:)