PDA

View Full Version : Frustration Bug ---- common Microsoft Mouse Problem


NightFallMyriad
09-19-2003, 06:07 AM
****PLEASE DO NOT MOVE THIS THREAD****

I use a Microsoft IntelliMouse Optical which has two side buttons for back/forward web browsing. Jedi Outcast and Jedi Academy recognize these buttons as MOUSE4 and MOUSE5. I find it very intuitive to bind them as push and pull respectively because it takes away from the buttons on my left hand.

And then 1.04 f---ed everything up.

For whatever reason, whenever I try to use these buttons for push and pull, I get the unwanted side effect of my saber throwing itself. At it's worst, sometimes my infrared goggles will come on, which always resulted in a death in SP or MP.

Yeah, I hated the assfighting and the DFA spamwhores and all the other things that each patch ruined about the game, but what really did JK2 in for me was this bug. I couldn't even enjoy SP because of it. So as I was downloading the JA demo, I was praying to myself "Please let them have fixed this bug!"

But I was let down.

The bug still exists for some bizarre reason (although it's incarnation is not as strong as with the goggles) and it completely prevents me from playing the game in a manner to which I'm accustomed.

My only solice appears to be the saberstaff, which cannot be thrown. I can wield it perfectly with my keys bound the way they are (except when I'm gripped and accidentally switch to the single blade stance).

Now, I have tried just about everything I can think of to remedy myself of this bug. I have tried unbinding all my keys, and changing things in Windows and all that. My drivers are all fully up to date and there is still NO reason why this should still be happening.

I have posted similar threads countless times in the "Technical" forum, to no avail. My threads either go unanswered or are met with "Yeah, I have the same problem too. Can't help you though."

If LucasArts or Raven are reading this, then get off your asses and fix this goddamned bug!

Any help would be much appreciated because I would really like to be able to push people without having to throw my saber. Please don't restrict me to the saberstaff.

ASk
09-19-2003, 06:30 AM
I believe it's a bug with drivers, and yes, it happens to me as well.

Although in my case, I have those bound for Grip and Drain, so a saber throw is always nice after these :)

NightFallMyriad
09-20-2003, 07:40 AM
Why don't the game makers do something about it then? Just about every other game released in the last year or two supports extra mouse buttons, and I'll be damned if I just let them go to waste!

I know for a fact that it can't be the drivers because I never used to have the problem before 1.04 was released. Vanilla JO as shipped works fine with these buttons. There is something wrong with post 1.02 and JA and it needs to be addressed seriously.

I am very frustrated with this bug. It really throws a wrench in the whole series for me.

ebelleudy
09-20-2003, 08:31 AM
I just checked... I use 1.04 and have no problem with my mouse (the same you use)... neither in JA... all 5 buttons work like a charm independantly...

ebelleudy

Kurgan
09-20-2003, 09:00 AM
I had this exact same problem.

Here is the simple fix.


Go into your Mouse setup program (in the task by usually) and go to where it lets you remap the buttons.

Change the buttons you're having problems with to PageUp and PageDown.

Now go into JA or JK2 and change the functions you were having problems with to PageUp and PageDown.

Now that they match, when you play everything should be fine again.

Now when you want to go back to web browsing, you'll have to go into your Mouse setup program again and change it to "defaults' (click on button and it's done). To play JK2 or JA, repeat the setup process (but you'll never need to mess with the games again because you can just save the cfg file and set it to autoexec.

It sucks, but it's not a problem with the game, it's with the M$ setup program!

ASk
09-20-2003, 09:54 AM
To be more exact, MOUSE4 (Back) is referred to as 'Alt' (and Alt throws your saber), MOUSE5 is I believe referred to as 'Ctrl', but I may be wrong.

ebelleudy
09-20-2003, 10:12 AM
I'm NOT using the provided software at all. I use Windows XP driver (recognizes the mouse perfectly on installation) and let everything in the initial state... no button re-mapping or anything. It works in browsing (back, forward...) AND in JO/JA perfectly.

ebelleudy

megatron
10-10-2003, 05:51 PM
I use the intellimouse optical and version 4.1 of the driver software. I bind delete to left thumb button and tab to the opposite one after a reinstall. Then all my games are set up to use these keys. I don't use the buttons outside of games. I suppose pageup and pagedn are a better choice bearing in mind how far they are from the movement keys.

I tried version 5 of the software as soon as I saw it on warp2search.com news page. It was a let down since the option to map to delete and tab were gone. I was slighly miffed and didn't bother to check what buttons were available and reinstalled version 4.1. The mouse came with a driver cd containing version 4.0.:deathii:

Dave Starkiller
10-10-2003, 06:11 PM
I had this Problem too(very annoying!!)
it was ok just with push/pull but it started playing up after i tryed to add some other force to the wheel button

I had to reinstall JK, to get rid of it

I found if I only assign the push/pull it was ok

JA has been ok, keeping to this rule

Kurgan
10-10-2003, 08:21 PM
Okay, I grabbed some snapshots of my Intellimouse software to show you what I'm talking about, hope this helps:

(Default settings)
http://strategy.jediknightii.net/Before.jpg

(Fixed JK2/JA settings, note that I had to go in game and change the buttons to match the new settings in the mouse software)
http://strategy.jediknightii.net/After.jpg

Iblis Reborn
10-10-2003, 10:39 PM
ive been doing what kurgan just showed for years now
it works really well but there seems to be a very slight delay when i use the thumb buttons but its nothing i cant live with

it really pisses me off when i forget to change them before i get in game though...seeying as though you cant task out so you have to close it :\

RSloan76
10-10-2003, 11:34 PM
Yeah I've had the same problem, and I've mapped the buttons similar to what Kurgan did, but the problem is that I am also playing Halo PC, and it kinda screws up my mappings, plus I really like to use those two buttons when web-browsing for back and forward. I don't want to have to enter the mouse setup every time I fire up a game, or when I'm surfing. Oh well.

Rumor
10-10-2003, 11:55 PM
i've had the same problem, but only after i formatted a couple months ago. before i had mouse4 as weapon 1 and mouse5 as grip. so now in jk2 when i use grip i have to keep it held down until i either go into a ptk, or when i let go after a gk.

i did notice that it changed when i moved ti from my ps2 port to the usb port, tho i haven't changed it back because i'm lazy and i forget :P (and i dont' restart my computer much more than once a week.)

FK | unnamed
10-11-2003, 05:55 AM
I use an explorer optical and I also use the thumb buttons.

I just (like Kurgan said) re map the thumb keys to CTRL, and then the games I play read that key as CTRL.

You can also (in the newer versions of the software) make "application specific profiles".

Like if you want Windows to read the thumb key as "back" but want JA to read it as "CTRL".



That said, either there is a problem with JA and this software, or it is a game related problem.


I bind my "altattack" to mouse3.

In jk2 I did the same.


For whatever reason, "altattack" in JA, more specifically saber throw and staff kicks, just stop working for periods of up to a full minute.

I will stand there in an empty map, look at the ground and throw the saber.



Works fine, it comes back in my hand.


I try again, nothing.


Or like if I have a staff and try to do a kick, sometimes it simply will not work, even if I am offline in my own server and just standing there in an empty map.

I mash the hell out of the key and some times it takes up to a full minute to throw it again (or do a kick if I have a staff).

I have tried re mapping my "altattack" to other keys like I did with the thumb button (but still on the mouse3, I remapped through the MS software) but I still get this problem on occasions.

It seems the only time I don't get this problem is when I leave it on the default bind of mouse2.

That ^ is really not an option for me though, I've used mouse2 as my forward key for about 7 years now in every FPS I have ever played.




/edit

it's not the mouse or software, it's JA (in regards to my problem).

I made a simple test script that has a "+altattack" line in it and bound it to my F key.

When pressed the guy is supposed to jump and toss the saber about a second later.

The script will not execute the "+altattack" part every now and then (about 10% of the time).

and yes I know how to script quite well, (the script works 100% of the time when I replace the altattack with anything else).

Kurgan
10-11-2003, 11:41 AM
That sucks... be sure and email that to Raven (Mike Gummelt and James Monroe) and post it in the Bugs thread.

I don't see that bug myself, but I rarely use saber throw to be honest, so I'll probably notice it like you said since our setups are so close.

I'll check the new software though, sounds like I'm in need of an update! ; )