PDA

View Full Version : SP Dismemberment and Battle Scars


Archonon
09-19-2003, 10:22 PM
I believe I read somewhere that to enable full dismemberment in SP I had to write g_sabermorerealistic 1 or something like that but when I did it says it is write protected, how can I edit this for full dismemberment?

One of the very first mods I had or JO was an SP dismemberment mod but I don't know if it would work here. Anyone know how to edit dismemberment? And if I do it would I have to star SP over as JO usually did whenever you changed something/

Also, has anyone had the battle scars from saber attacks appear very less frequent and disappear much faster than the demo? Battle scars barely appear in my SP game, I don't know if it was something I changed in the graphics section or what (I put everything in highest settings) but in the very small instances the scars appear they vanish really quickly. Unlike the demo where they were extremely visible and lasted a good amount of time. Anyone have any ideas how to prolong the scars?

Thanks for any help.

Zard
09-19-2003, 10:33 PM
I think it was g_saberrealisticcombat 3 that gave full hack-ation but it has been a long time.....

Ryo Ohki
09-19-2003, 10:38 PM
with cheats active

g_saberRealisticCombat 2

Unlike JO setting it at 1 won't do anything

g_dismemberProbabilities 100


I couldn't find the moreRealistic command :confused: that was in the demo even with cheats active so I'm assuming they have it hidden

Archonon
09-19-2003, 10:42 PM
Yes in JO it was g_saberrealisticcombat # but that doesn't work in JA, I tried it and it didn't do anything.

when i input g_sabermorerealistic it says default set to 0 when I retyped it to 1 it says copy protected and I couldn't change it :(.

BS87
09-19-2003, 10:49 PM
type "helpusobi 1" in the console then try.

JarJarBinks
09-19-2003, 10:54 PM
Originally posted by BS87
type "helpusobi 1" in the console then try.

That dosen't work.

Archonon
09-19-2003, 11:02 PM
You mean activate cheats before putting in the dismemberment command?

I can activate cheats by writing "devmap" or "devmapall"

But so far I've found 3 different commands that supposedly activate SP dismemberment.

"g_saberrealisticcombat" - JO old command which did nothing for me

"g_sabermorerealistic" - Which says default 0 and is copy protected so I can't change.

"g_dismemberment" - Which I haven't tried.

I'll give another try after activating cheats and if none work I'll put the Enyak Mutilate mod and see if it has any effect in JA.

Tsunami231
09-20-2003, 12:11 AM
i changed g_dismemberment 1-100 it did nothing =(

Rassick
09-20-2003, 12:43 AM
This thread has your answers. http://www.lucasforums.com/showthread.php?s=&threadid=111853

IronFryman
09-20-2003, 02:45 AM
It should work, just type in helpusobi 1, then g_Saberealisticcombat 2. I have it binded so that everytime i start up, i can have it. Its just strong enough to dismember people, but not to easy that i just cant walk into people. But it doesnt work on the beta, or so i hear.

Wes Janson
09-20-2003, 03:04 AM
This still doesn't explain the frequency of saber (and blaster) marks on models. They hapen FAR less frequently in the real game than they did in the demo. I hardly even see them anymore...

Grrrr....

Kurgan
09-20-2003, 05:01 AM
I think the scarring command is something like g_g2marks 16 (or maybe cg_g2marks 16).

Try that. I should double check that in the cmdlist/cvarlist...

Archonon
09-20-2003, 05:16 AM
The saberrealisticcombat line does nothing believe me I've tried it numerous times.

What does work is the g_sabermorerealistic 1-3 but it is copy protected, so you can write it into the JAconfig file with 2 other lines mentioned in another thread and load a map from the console and it will work. But if you shut off the game and turn it back on it is overwritten even if you had it in the JAconfig file and can't change it back through the console.

Thanks for the scar line Kurgan, I'll test it tomorrow after class.

lankyframe
09-20-2003, 05:24 AM
i got the dismember thing to work i just got game and all i did is put these three comands into the ja.cfg file in ur base folder

seta g_dismember 100
seta g_dismemberprobabilities 1 or set to ur liking
seta g_sabermorerealistic 3 or to liking again

all those have to go into ur cfg file if u want to open it just open it in ur notepad it lets u see all the rite fonts in stead of the blocks

Archonon
09-20-2003, 05:28 AM
Yes I did that too but after I turned off the game and turned it back on it didn't work anymore. Like the game had reverted back to what it had before I had put those lines in the JAconfig.cfg.

If there's a way to have the game keep those settings without going back then I have a solution to my problems :)

lankyframe
09-20-2003, 05:29 AM
all i did whose those things it dont change back for me i have retail version do u have dismember ON in the options??



Dont forget to put on the devmapall thing and then type save "insertfilename" in the console that should do it

Archonon
09-20-2003, 05:36 AM
Yes I have dismemberment on in the options and yep it's also the retail version.

I just checked my JAconfig file and it had reverted my changes, they appear now as:

seta g_dismember 1
seta g_dismemberprobabilities 1 (that's the same as I set it)
seta g_sabermorerealistic 0

I don't know why it changed the file back to this. What is the file name I have to save from the console? Maybe that's what's missing and that's why it eliminates my changes.

lankyframe
09-20-2003, 05:38 AM
name it ne thing u want then just type "save ex:Will" in console with out qoutes

Archonon
09-20-2003, 06:22 AM
Okay so I tested it a bit and here are my results.

I reopened the cfg and set everything back to dismemberment options:
seta g_dismember 100
seta g_dismemberprobabilities 1
seta g_sabermorerealistic 2

then I turned on the game, loaded the last level I was on, put in devmapall and saved it through the console as dismembermod.

I noticed that while the settings for the game were as I put them; g_sabermorerealistic was set to 2 it still indicated that default is 0 while before I loaded the game both were set to 2.

I exited the game and turned it back on 3 times. The first time I restarted the game everything was fine. When I checked the file it still had the settings I had put.

But the second and third test failed. I reloaded twice the save game made when I renamed it and though it still had the g_dismember 100 the G-sabermorerealistic was again 0. Every time I changed it back to 2 it appeared as before: the setting is running 2 but default is 0 and as soon as I exited and restarted the game setting would completely revert back to 0. So unless I change g_sabermorerealistic to 2 every time before I restart the game it doesn't seem to work.

Thanks for the help.

Crow_Nest
09-20-2003, 07:09 AM
"g_dismemberment" - Which I haven't tried.

Tried it, does nothing.:(

Kurgan
09-20-2003, 07:53 AM
Hey guys, check this out, here's an alternate method to getting dismemberment (SP) to work in the full version.

Okay, first find the jasp.exe and create a shortcut to it on your desktop.

Now right click on the shortcut and click on properties. Now in the box it should look something like this:

Target: C:\games\JediAcademy\GameData\jasp.exe

(it'll be different, but you see that it points to the directory where your game is installed)

Now edit the line and make it look like this:

C:\games\JediAcademy\GameData\jasp.exe +set g_sabermorerealistic 2 +devmapall +load quick +set g_sabermorerealistic 2

Then hit apply/okay and you're set.

Now here is what it does:

The "devmapall" part turns on cheats (and clears the cache to save memory).

g_sabermorerealistic is write protected, but if you run it from the command line the game will just set it to that value at the beginning.

The "load quick" part will load whatever game you have saved in your QuickSave slot. In fact, it will launch the game directly from the shortcut (you won't have to watch the intro screens or wait for the menu to pop up). So just use your QuickSave (mine is F7, but whatever your's is) and take a spot where you want to begin with dismemberment on.

Now as to the value you put for sabermorerealistic:


g_sabermorerealistic 1 seems to (I'm guessing) just be increased damage (but dismemberment is very very rare).

g_sabermorerealistic 2 is full dismemberment (with almost every hit). But idle saber does no damage to NPC's.

g_sabermorerealistic 3 is the "idle saber cuts you up into teeny tiny bits" mode which is more like the classic "saberrealisticcombat" from JK2.

Ostra
09-20-2003, 11:29 AM
hey Kurgan, thanks but i had to change it for me.

In target (on win XP at least) you need quotes in the actual location to load the jasp.exe

so for me it needed to look like.


"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jasp.exe" +set g_sabermorerealistic 2 +devmapall +load quick +set g_sabermorerealistic 2


otherwise without the quotes it wouldnt even let me save it again.

JEDI OUTCAST
09-20-2003, 11:32 AM
g_saberrealisticcombat worked for me. :D

Agen
09-20-2003, 02:38 PM
Originally posted by IronFryman
It should work, just type in helpusobi 1, then g_Saberealisticcombat 2. I have it binded so that everytime i start up, i can have it. Its just strong enough to dismember people, but not to easy that i just cant walk into people. But it doesnt work on the beta, or so i hear.
That works perfectly, they don't fall apart when you touch em but you can still dismember pretty easily - nearest to perfection imo :)

Crow_Nest
09-20-2003, 03:00 PM
Hey thanks!:)

Tsunami231
09-20-2003, 03:21 PM
the shortcut commands works ;) tobad it take about 10+ kill before it realy start to kick in but it better then no dismemberment thanks

Kurgan
09-20-2003, 08:34 PM
How are you guys using saberrealisticcombat (the JK2 command)? I thought that one did nothing in JA?

The new command in JA is sabermorerealistic

Set to 3, it's identical to the effect of saberrealisticcombat in JK2.

Set to 2, and it's like multiplayer dismemberment. Set to 1 and it's really rare (more like the regular SP game).


Per my method, it should NOT take several kills to "kick in" it should work right off the bat. You sure you're doing it correctly?

Tsunami231
09-20-2003, 10:02 PM
yea i doing it correctly expect i have it as 9 that and i change the dismemberment to 9 but i fiqure out if i just throw the saber at first thing i see it slice em up like mad so it don't really bother me so long as the limbs fly ;) plus i think raven/lucasart write portected that command on purpose i think after the first patch it wont be write protected

Krause
09-20-2003, 10:08 PM
Is there anyway to revert back to the default config besides reinstalling? I have mixed and matched so many commands and now none of the dismemberment options work anymore.

Rassick
09-20-2003, 10:10 PM
Kurgan,

For me it takes a few kills to "kick in" but then it works fine. However, when I tried your method of adding those lines to the shortcut...well, it didn't seem to work, and it brought the game to the menu normally, it didn't automatically quickload like you said it would. :confused:

Kurgan
09-20-2003, 10:13 PM
First go in game and into setup, and turn "Model Dismemberment" back on.

To reset them do this:

g_sabermorerealistic 0 (or remove the + commands from your shortcut)

g_dismember 0 (turns off MP dismemberment on your server)
cg_dismember 0 (turns off MP dismemberment on your client)

That should change your dismemberment options back to the default that shipped with the game.

If not, just delete all the entries showing dismember in your cfg file and the turn Model Dismemberment back on in the in-game setup menu.

Archonon
09-20-2003, 11:30 PM
Well I have no idea how saberrealisticcombat does anything, I've tried it 10 times and nothing changes.

g_sabermorerealistic though does work but that damn write protection is a real b!tch. I even made my JAconfig a read only file with g_sabermorealistic 2 and when I turn the game on it sets it back to 0 even though it says can't write JAconfig when any level loads.

This really sucks, I mean why the hell is this crap write protected? Every dismemberment has appeared in the movies anyways, when I select dismemberment on it should be on all the way not that stupid arm and hand thing.

Has anyone found out anyway to break the protection thing? I tried to look for an npc.cfg to make an updated Enyak mutilate mod but I can't find it in any of the assests.pk3s.

Kurgan, thanks for the heads up, if everything continues to fail I'll try that new shortcut sounds like the most promising solution. And I tried the burn marks also,
I set cg_g2Marks to 16 but it has no effect

There is a seta cg_saberEntMarks "1" which might work if changed to 16, I'll check next time I play.

Kurgan
09-21-2003, 12:06 AM
cg_saberEntMarks "1"

You may be on to something there, I will try it next time I play.
Thanks!

ChangKhan[RAVEN]
09-21-2003, 01:28 AM
If g_saberrealisticcombat does anything for you, you're either playing Jedi Outcast (*not* Jedi Academy) or you're playing an old, illegal warez version of the game and have admitted as much to all of us on the LucasForums messageboard!

:)

Wesman
09-21-2003, 01:37 AM
^^^ HHAHA!! busted! :rofl: :newbie:

Tsunami231
09-21-2003, 01:53 AM
they speak ;) would you like to tell us why g_sabermorerealistic is write protected or do you want to keep that a secret ?

Samus
09-21-2003, 10:58 AM
Yes, please tell us how to enable dismemberment properly! It's the essence of the game!

Crow_Nest
09-21-2003, 11:00 AM
Ok now i'm kinda confused, maybe i should stop viewing this thread....

SaTsuJiN
09-21-2003, 12:36 PM
Anyone know what seta g_saberRestrictForce does?


oh and for some reason g_sabermorerealistic isnt even in my jaconfig O_o why is that?