PDA

View Full Version : I'm stuck in year 3.


ERC
10-05-2003, 10:12 AM
I'll go right on the problem. After Meche's been locked up and I've destroyed the crushers and all that, I can't seem to get down to the soil again. According to the walkthrough (which I considered I had to check since I couldn't see any solution to the problem), I'm supposed to reverse to conveyer belt so the chain can hook up to Glottis' ship. I simply can't get down to the switch, and that's where I'm stuck. Has anyone else experienced this? Please answer me. I don't want to quit the game at this point, cause it really kicks butt.

/peace out

Sanspoof
10-05-2003, 10:26 AM
Ugh. The conveyor belt. The WORST bug in Year 3 EVER!!! You just have to keep forcing yourself down. You'll get there eventually.

Welcome to the forums :D

dricysir
10-06-2003, 02:07 AM
I'll agree with that. I just had to keep on trying, it took a damn long time too. Annoying, keep at it though and you'll eventually get down to the switch.

SortEngel
10-07-2003, 02:22 PM
I just recently decided to dig Grim Fandango up from the depths of my game collection and finally round it (for some reason I never did back when I bought it), and ended up at this exact same problem myself. Here's what I did.

I downloaded the CPU Killer program (http://www.cpukiller.com/) and set my CPU to run at 300MHz (I could probably have set it higher, but I figured what the heck). Starting the game and loading my savegame took forever, but when I got there I was able to get off the conveyor just like I assume is the intention. I can't remember if I had it running up or down when I got to this point, but I don't think it really matters.

Hope this helps - I've just started on Year 4, hope you will too ;)

ERC
10-07-2003, 06:38 PM
Gee, thanks guys. I'm really grateful that you answered with such short notice. I had a feeling that the forum wouldn't be ruled by bureaucracy like the rest of the damned soceity - and by golly I was right! I'll try out that tip you gave me instantly, SortEngel.
Thanks again. Peace! / Erik Persson, Karlstad, Sweden.

bluereef
07-03-2004, 02:59 PM
Since I'm having the same conveyor belt problem, I wonder if my system is running too fast as well (2.4 GHz w/512 MB RAM).

ERC, did you use the cpu killer and did it solve the problem?

I've never heard of cpu killer before....

Thanks!

lookoutbelow
07-05-2004, 10:22 AM
hmmm, I never had that problem and I'm running the game on a 2,8 GHz PC, strange.

Springchicken
07-06-2004, 03:34 PM
This problem has had me tearing my nostril hair out for the last few hours, so I thought I'd have a look on a forum before giving up and using the Grim Fandango disk as a frisbee. :D

Glad to see I'm not just a retarded simpleton. And it's nice to see people helping those in need readily. Wanted to register just to say that.

By the way, I'm playing through all LucasArts's adventures for the first time, now I know what I've been missing for the last decade! Got Sam & Max, Day of the Tentacle and the first two Monkey Island games left to buy and conquer after this. :)

lookoutbelow
08-29-2004, 05:41 AM
I've completed GF a couple of times, and never had this problem.

Now I'm trying to complete the game again and I downloaded the patch and the new launcher and now I can't get down that thing.

Is it because one of these?

john s b
09-01-2004, 05:45 AM
Hi,I had the same problem but solved it using CPUKiller - thanks SortEngel. i reduced the CPU speed by 60% and bingo, it worked. I found that it also solved the system crash at the beginning of year 4 when Glottis falls off the wall. I had to reboot the system after saving the game though, in each case.

Regards