PDA

View Full Version : Tutorial: Importing Vehicles into JA


Duncan_10158
10-25-2003, 06:13 PM
Here is the tutorial i wrote, its on how to bring a vehicle model in Jedi Academy. it has probably lots of faults, wrong written, or things left out. could you take a look at it. if you know any problems you came across, i could add it in the toubleshooting.

Here is the link:
http://io.meskinaw.net/vehicle_importing_tutorial_for_ja.html

let me know what needs to be corrected or added.
Duncan_10158

Manquesa
10-25-2003, 06:28 PM
Ahh yesss!!!! Your timing is impeccable. This is just what I need. Thank you, thank you, thank you.

tFighterPilot
10-25-2003, 06:56 PM
Thanks ducnan! :D

Chairwalker
10-25-2003, 08:38 PM
Awesome tutorial, lots of info and pics.

But, im not sure if you really need dummies at all.
I managed to import vehicles with only a mesh_root dummy, and i think that its possible to import without that one too.

Also, the scale and origin settings in carcass arent neccesary either, scaling and moving the model in max should work fine aswell.

Duncan_10158
10-25-2003, 11:40 PM
ok, troubleshooting point one found.

Scouttrooper, if i remember right, the cubic scale key error is about the windows language setting. while exporting a model out of 3ds Max you have to be in English(US) language setting. change it and try it in assimilate again.


about the plugins, they are in the two SDK releases by raven, here are the links to both. you dont need to install the SDK's, just open them with WinZip and extract the plugings.
http://www.jk2files.com/file.info?ID=2433
http://www.jk2files.com/file.info?ID=2888

Manquesa
10-26-2003, 03:06 AM
I can't compile in Assimilate. I keep getting an error message that says "Process returned error:1"

The compile window pops up and closes real quick but i've been able to make out that is says "no such file or path" and for some reason it's looking for

blah/blah/blah.... /gamedata/base/models/players/awing/files/lucasarts/star.car

though it should be looking for

blah/blah/blah.... /gamedata/base/models/players/awing/model.car

Manquesa
10-26-2003, 04:23 AM
Okay, now i've decided to make things simpler, so I made a folder called "base" at the root of my hard drive.

So I got c:\base (which contains assimilate and carcass
\models\players\awing (contains root.xsi)


Now I get further in the compile but am getting a new but similar error. Here's how I got my prefernces set up:

http://f1.pg.photos.yahoo.com/ph/manquesa/vwp?.dir=/awing&.dnm=SP32-20031026-001034.jpg&.view=t

And here's the compile window, where it stops at:

http://f1.pg.photos.yahoo.com/ph/manquesa/vwp?.dir=/awing&.dnm=SP32-20031026-000715.jpg&.src=ph&.view=t&.hires=t



I don't understand why it keeps screwing up the paths

Duncan_10158
10-26-2003, 07:01 AM
Manquesa, that happens when you dont correct the path. read step 14, you have to delete the >c:/base<. you have to do that step every time you add a file into assimilate.

seting up assimilate right is very importent, it must be placed in the same structure like i wrote in step 10.

tFighterPilot
10-26-2003, 12:24 PM
So... Do I need the dummies or not, and if I only need the mesh_root, do I need to connect the skeleton to it as well?

Duncan_10158
10-26-2003, 12:59 PM
All models from raven have these dummies, i have them in the vehicles i brought in game and it worked. perhaps they are not needed, perhaps it will cause a crash later in game without them, i dont know, havent tested it without. But if you want to save the 90 seconds you need to create or import the dummies, then go ahead.

tFighterPilot
10-26-2003, 01:10 PM
Talking about importing, I can't import the xsi's that came with the modeling tools, it gives me some error message.

I made the tags by making a triangle using lines, extrecting it, converting it to editable mesh, and deleting the 4 unneeded poligons(sides and bottom)

Duncan_10158
10-26-2003, 01:35 PM
imyourfather, i suppose you aretalking about the >jedi academy model and animation< pack by raven? you want to import the XSI vehicle model, then you need the dotXSI plugin for 3ds Max (as i wrote in the tutorial). the old plugin from raven doesnt work for that. you can get that plugin from here:
http://sourceforge.net/projects/dotxsi4max/

you have to download th one for your 3ds Max version.

tFighterPilot
10-26-2003, 01:51 PM
The file is only for export.

Duncan_10158
10-26-2003, 03:11 PM
sorry wrong link, this one is for import,
http://www.softimage.com/download/xsi/converters/max/default.htm

you may need to register to get it.

btw, do you think it would be a good idea to add these plugins directly to the tutorial, so you can d/l them all from the tutorial?

tFighterPilot
10-26-2003, 03:32 PM
thx

tFighterPilot
10-27-2003, 04:06 PM
New try, new error *sigh*

Unable to open output file "c:/base//base/models/players/sfighter/sfighter.frame
s"!

Manquesa
10-27-2003, 04:23 PM
that's the same that happened to me when I posted my error a few posts above. You need to make sure you delete the "c:\base" part of the path at the part right before you compile, where you check the box "Makes it's own skeleton", after you check that box the path appears in the box below, that's the path you need to edit.

tFighterPilot
10-27-2003, 04:25 PM
I see the problem, I deleted c:/ but forgot to delete base

thx

tFighterPilot
10-27-2003, 05:25 PM
Ok, I finally made it work ingame, and in the proper size, 0.25 made it tiny, so I changed it to 5(which made it rather gigantic) I would've change it again, but that would mean doing a lot of stuff again, so meh.

tFighterPilot
10-27-2003, 08:05 PM
My guess is that you just need to weight the bones to the model, and link them to the skeleton root. There's a tauntaun, a wampa and a rancor models provided with the Models And Animations thingy that raven provided.

tFighterPilot
10-28-2003, 01:47 PM
I advertised this tutorial in gaming forums (not all of the guys there are n00bs :p )

http://www.gamingforums.com/showthread.php?t=95256

Manquesa
10-30-2003, 05:30 AM
Thanks again for the tutorial, it really helped me a lot. Although, the tut is only for non-animated models. I need to know now how to animate the landing gear at take off. This is for my Sith Terminator model (well, for the Awing too) . So far I tried to just apply bones to the landing gear, I included all that in the hiearchy and then I added the skin modifer to weight it and then I animated the landing gear to fold up into the ship. Then I try and compile in assimilate but I keep getting an error saying that the .XSI import failed. Of course all of this I just guessed at how to do as there is no tut yet for doing animated vehicles that i'm aware of.
Anyway, if someone could please give me a brief explanation at least, i'd appreciate it. Thanks

Duncan_10158
10-31-2003, 08:52 AM
Manquesa, the animation is quite as you wrote it. create a skeleton for the landing gear attaching to the pelvis (not pelvisend). change the skin modifier so the landing gear is weithted to the bones you just created for that. then animate a
sequence like we did it for the pelvisend. then export and use exactly the same settings like for the nonanimated vehicles.

i dont know what could have been wrong on what you did. i am planig on making a tutorial on animated vehicels, but have not yet started to work on it. i hope this short hint helps you.

LightNinja
11-01-2003, 10:42 PM
Hi Duncan, nice tutorial, i've done this ship (not many detailed and simple) to practice:
http://f1.pg.photos.yahoo.com/ph/danadn2000/vwp?.dir=/JKA&.dnm=ship.jpg&.view=t
but look, look the problem and look the settings (it puts EN(english US)):
http://f1.pg.photos.yahoo.com/ph/danadn2000/vwp?.dir=/JKA&.dnm=error.jpg
What can i do? could i send ya the model in .max and u could export to glm? :confused:

71M
11-03-2003, 06:03 AM
Originally posted by Manquesa
Thanks again for the tutorial, it really helped me a lot. Although, the tut is only for non-animated models. I need to know now how to animate the landing gear at take off. This is for my Sith Terminator model (well, for the Awing too) .

Hmm, Manquesa, I have a suggestion that may work but I'm not fully sure if it will. It's worth a look into at the very least.
The KOTOR_Flight School map came with 3 new vehicles that were modeled by it's creator, and I decided to do a bit of looking into it's PK3 file.

In the vehicle directories, I found that most of them had the "x-wing.gla" file in them. My guess is the creator imported the bones from the x-wing model, and then rigged his models with the bones that were made to control the gears going up/down for the x-wing, exported the model and then followed the same procedure used when you normally are attaching the animations to a player model.

Perhaps if you tried that, you might get the same/similar results.

Give it a try. ;)

-TiM

Duncan_10158
12-14-2003, 11:15 AM
lots of people are asking for help on thier vehicles. so here is the tutorial thread on to again.

I hope there are any more questions on this tutorial or vehicles modeling in general, let me know if there are something unclear.

Pahricida
12-19-2003, 04:45 PM
I guess this is the right place to post this:D


First off I can't activate the ANIMATE Button cause somehow it's locked ...

when trying to compile I get this Error:

http://mitglied.lycos.de/ganjahuntah/error.gif

Manquesa
12-20-2003, 01:53 AM
Whoah! "Amazingly Bad" huh, that's pretty messed up. What version of max are you using. I use 3ds max 5, and for me there is no animate buttom but instead an autokey button.

(I hope you're not trying to use gmax, it won't work)

Pahricida
12-20-2003, 01:57 PM
Max 5.1 including Service Pack 1...

but my problem has been solved ...

I just didn't add the small animation.

But now theres another Problem...

Funny thing I just added one model_root and there is no accidental copy of it so I'm like :confused: again...

http://mitglied.lycos.de/ganjahuntah/error2.JPG

-]Holoman[-
04-17-2004, 12:02 PM
Sry for bring this Topik up, but Ive found you Tutorial an work on some MP vehicle...
Now, Ill assimilate the xsi file.. but his Error comes :


Carcass (GLA/GLM compiler) v2.1. (C) Raven Software 1998-2003.
Written by Gil Gribb, Ste Cork, James Monroe, Mike Crowns


-------- C:\Base\models\players\pod\model.car --------
( Build trigger: "c:\base\models\players\pod\model.glm" missing )
entering c:\base\models\players\pod\model.car
(90 degree skewing OFF)
Scaling: 3.000000
Loading XSI models/players/pod/root.xsi @ 0,Header # frames = 31, but I read in
1!! Amazingly bad! -Tell me (Ste)

( Press any Key ... )

tFighterPilot
04-17-2004, 01:07 PM
Did you animate the pelvisend?

-]Holoman[-
04-17-2004, 02:01 PM
yes, Ive moved it a little bit... but Im not sure because It Max 5 not Max 4 .. and the animate button was not there... Also the assimilate say :

...frames = 31, but I read in
1!! ...

tFighterPilot
04-18-2004, 02:45 PM
Originally posted by -]Holoman[-
yes, Ive moved it a little bit... but Im not sure because It Max 5 not Max 4 .. and the animate button was not there... Also the assimilate say :

...frames = 31, but I read in
1!! ... I too use max 5, the auto key button is identical to the animate button.

In assimilate, click on the little + next to the GLA icon, and double click the xsi

There you will need to change something in the number of frames.

-]Holoman[-
04-18-2004, 03:32 PM
Ah thx .. it works ... Ive used the wrong Key

^^ Now its a new error :


Carcass (GLA/GLM compiler) v2.1. (C) Raven Software 1998-2003.
Written by Gil Gribb, Ste Cork, James Monroe, Mike Crowns


-------- C:\Base\models\players\pod\model.car --------
( Build trigger: "c:\base\models\players\pod\model.glm" missing )
entering c:\base\models\players\pod\model.car
( Reading 0.03MB CARPET file )
0%
(90 degree skewing OFF)
CARPET: XSI models/players/pod/root.xsi @ 0, 31 frames
Grabbed 1 files with 31 frames
Processing 'c:/base/models/players/pod/root.XSI'
Processing meshes, LOD 0
Processing meshes, LOD 1
(Mesh empty, so total LODs = 1)
Generating model.glm ...
( Generating/compressing bone matrices (1/2)... OK )
Writing model.glm ... Writing MDX/GLM model file...
( skin-write inhibited )
Unable to open output file "c:/base/c:/base/models/players/pod/pod.frames"!

( Press any Key ... )

tFighterPilot
04-18-2004, 05:28 PM
Ok, that's easy, you forgot to delete c:/base from the gla properties

Duncan_10158
04-18-2004, 06:51 PM
tFighterPilot seems to be right, i hope that solves your problem -]Holoman[-.

But i would like to suggest something. in the errors you posted, i read you named your vehicle >pod<. it would be better to give the vehicle, and also the folder structure, a bit more specific name. you probably will not release your vehicle as >pod< but as >somebodys_pod< or something like that. its much easier for the community if the folder names are the same as the vehicle name, it just causes less confusion. you can also add your personal suffix as i suggested in the tutorial, its importnet to do this on the folder names.

-]Holoman[-
04-19-2004, 01:56 PM
Youre right, but tihs is only a testmodel.
I wouldnt publish this model for JA.
Im thinking about a few other models, witch I Publish .. but now I will learn to bring Vehicles ingame .. ..
But thx @ all at this time .. Ill be back soon ^^

Edit :

All seams to be good :) all works .. but the positon most to be revise...

But can someone help me with my second problem ? two Threats down ... thx :D

Big thx @ all for you help

tFighterPilot
04-19-2004, 02:49 PM
You can change the X Y and Z of the models in assimilate

-]Holoman[-
04-19-2004, 03:32 PM
And .. can I hint the player ? so that Ive only the Vehicle ? .. by a Pod it doesnt comes good, If the player locks around.