PDA

View Full Version : Getting Your Server listed


gotcha8903
10-28-2003, 01:36 AM
I can't get QTracker to list my server. I am using the win32 ded server program and these are the settings for the shortcut to the server:

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +exec server.cfg +set net_port 29071 +set rconpassword mypassword

I have the QTUplink program set to the default query port which is 47624, and it is not showing my server as running. Should I set this to 29071?



Also, In my server.cfg file I have added the following lines:

seta sv_master1 "masterjk3.ravensoft.com"
seta sv_master2 "masterjk3.ravensoft.com"
seta sv_master3 "63.146.124.53"
seta sv_master4 "204.97.248.90"
seta sv_master5 "clanservers.net"
seta sv_master6 "master0.gamespy.com"

The problem with this is I cant see it with gamespy either. Also, in server console when is says "sending heartbeat" it does not send it to gamespy, just the ones through clanservers.net.

I am also on a router and have enabled it to send anything incoming or outgoing through the ports of 29060-29062 and 29070-29081. My firewall is also set to allow JA to use the internet in both directions.



I hope this is enough information to help fix my problem because I can't think of anything that would be wrong.


Thanks in advance,
Master Carter

Andy867
10-28-2003, 01:49 AM
Is this a linksys router, if so, you need to go to the BIOS screen and under the Advanced tab, there is an option called BLOCK WAN REQUEST that is currently ENABLED... DISABLE It... This should fix your problem... Also, you really just need to open ports 29071-29099 That leaves ya room on 29070 to join your own game...

and the shortcut option should actually look like this

"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jampDed.exe" +exec server.cfg +set net_port 29071 +set dedicated 2

*no need for the RCON since you are not using remote connection administration since it is local... and plus the rconpassword is stored in the server.cfg file already*

gotcha8903
10-28-2003, 02:32 AM
thanks for the reply, it is a linksys router and I disabled the WAN request thing. Unfortunately it still is not showing up on QTracker or gamespy(I didnt expect it to). Is there anything else I need to change?

Andy867
10-28-2003, 03:36 AM
For the forwarding ports, do you have them pointing towards your Computers IP, which would be like 192.168.1.101 or something? and make sure to apply any change you make before going to another screen

Amidala from Chop Shop
10-28-2003, 04:26 AM
Actually, this is very simple. Qtracker lists servers that you connect to over the Internet. But you are not connecting over the Internet, it sounds like the server is running on the same computer as your client (not so good) or on another computer on a LAN (much better). So while you can't see it in Qtracker, other people who would connect over the Internet probably can see it. Tell us the name and\or IP address of your server and we'll tell you if it's visible in Qtracker. That is assuming you have opened the ports on your router or port forwarded the appropriate ports. Just because it's not in your Qtracker doesn't mean others can't see it in theirs.

My Qtracker has two subcategories under Jedi Academy: Internet Games and LAN Games. My local server is under LAN Games. I don't remember if I added it manually using Servers, New, then entering the IP address.

gotcha8903
10-28-2003, 07:36 PM
thanks, ill try those too when I get home tonight. The thing that was confusing with QTracker was the program made it seem like I had to have the QTUplink program running for my game to show up on QTracker.

-Master Carter

Andy867
10-28-2003, 09:20 PM
Hey Amidala, is that you in your avatar, or just some avatar you found. Gotcha, you could always try The All-Seeing Eye, which will list your server. Its lists mine all the time, plus All Seeing eye tends to show more users than QTracker.

gotcha8903
10-29-2003, 12:02 AM
Sweetness! just treid it out online and it is working lag-free(well for 2 people anyways). Thanks for your help guys\girls!

-thanks again,
Master Carter