PDA

View Full Version : Some questions


NeXaR_QroN
11-05-2003, 04:10 PM
Well I will ask you all a few questions. If anyone can help....

1. I placed a water brush in my map, and when I enter it, the lightsaber stays on. Why?

2. Should I use areaportals in doors that comunicate the "open world" with a room with windows?

3. Anyone knows what type of things have a jedi in his room? I'm trying to decorate a jedi room but I have no idea of what I am suposed to put in there.

4. How works the ladder brush? I tried to use it but I can't make it work.

Thanks in advance

WadeV1589
11-05-2003, 10:42 PM
1. Water doesn't turn sabers off
2. No
3. No doubt very little but I'm not a SW film fan.
4. The idea is to make it as wide as a player (so 32x32) and as high as you want them to climb. Place it near a ladder texture so it appears like they're climbing the wall and not just thin air (good for secrets tho!)

NeXaR_QroN
11-06-2003, 05:18 PM
Thank you a lot but I have a new question: I have placed some ship models in my map. The millenium falcon, x-wing and tie fighters appears to be correct, but i tried the z-95 and the raven's claw and they appear in black with only certain parts textured. Can you tell me why?

PS: In JO, water turned sabers off if I remember correctly.

wedge2211
11-06-2003, 08:14 PM
Not in MP, it didn't.

Jedi Luke
11-06-2003, 11:09 PM
PS: In JO, water turned sabers off if I remember correctly.

Yes you are correct. This was dependant on the thickness of the water brush. If say it was two units thick, and the water level was above Kyle's waist level, the saber would stay on. However If the brush was thicker down to Kyle's feat and just under his head, the saber will automatically turn off (due to the game engine design).

have placed some ship models in my map. The millenium falcon, x-wing and tie fighters appears to be correct, but i tried the z-95 and the raven's claw and they appear in black with only certain parts textured. Can you tell me why?

Do they appear black in game when the map has been compiled or do they appear black in Radiant? At this time, the only thing i can suggest is to make sure you are using the correct .md3 value for the misc_model entity.

Lil Killa
11-07-2003, 01:44 AM
Originally posted by NeXaR_QroN
Thank you a lot but I have a new question: I have placed some ship models in my map. The millenium falcon, x-wing and tie fighters appears to be correct, but i tried the z-95 and the raven's claw and they appear in black with only certain parts textured. Can you tell me why?




The same problem was in JO.. It has something to do with how the model was created or something like that that doesn't alow the model to be properly lit.

Greymon
11-07-2003, 06:27 AM
I asked the same question about blacked-out model surfaces on another forum. A Raven designer answered:

This because some of the misc_models were set as misc_model_statics and the MP code does not have the functionality of the single player code. You must place models strictly as models in MP and do not try to use misc_model_statics or misc_model_breakables. They can be used and tweaked to work right, but the code is just not optimized to handle them as well as in SP

I then asked about the same black surfaces occuring in singleplayer on misc_models. Quoth the Raven:

Well, there are models that have shaders built for misc_model_statics. If you use a model as a misc_model and are still getting nasty black faces with q3map2, then try changing the misc_model into a misc_model_static. You can do the reverse as well. To change it into a misc_model_static just open up the model's entity window and add "_static" to the misc_model line. The purpose of a misc_model_static is simply to reduce .bsp size.

NeXaR_QroN
11-10-2003, 03:09 PM
OK thanks for the information. I will tell you all when I have completed the map. I want the opinion of more experimented mappers about it.