PDA

View Full Version : Ancient version of direct x


Mannysil
11-14-2003, 09:49 PM
I brought down the console on the start up and noticed this message:Ancient version of Direct x- this wil slow fps?I know i have the latest drivers and direct x 9 even though i'm using a geforce4 4400ti card.

operagh0st
11-15-2003, 12:08 AM
I've been getting the same error since I installed the 1.01 patch, however I think it's more likely connected to the fact that I have (or have had) various video & audio codecs installed that might be screwing with the DirectX audio runtime. I've also re-installed DirectX9a since I first saw that error, but it didn't go away. My game still runs fine, though.

Master William
11-15-2003, 12:10 AM
I always experience that. I had it since 1.0. I don't know what is wrong, I do have the latest DirectX drivers.

Mannysil
11-15-2003, 12:10 AM
Yeah i just reinstalled it again also but the message is still there.

operagh0st
11-15-2003, 01:41 AM
Originally posted by Master William
I always experience that. I had it since 1.0. I don't know what is wrong, I do have the latest DirectX drivers.

If you've been getting it even since v1.0, then it must be interference from some other DirectShow/DirectAudio drivers loaded on your system. For me, I think it was the Nemo Codec Pack; largely available in the media-sharing communities. I'm pretty sure that's what did it to me, cause I know my DVD and TV Capture Card were ok with Dx9 and JA. If I can figure out how to un-register those drivers and get Dx9 installed right again, I'll post it to this thread.

shukrallah
11-15-2003, 01:58 AM
Yeah, i had that in JK2, JA Demo, and JA... i think my sounds load up slower, and thats why your FPS may fall... Heh, and i never cared about sound cards