PDA

View Full Version : Problem: Dismemberment NEVER WORKS except ON ME


Kurgan
12-13-2003, 07:18 AM
Anybody else have this problem?

Ever since I installed the 1.01 patch, I cannot get dismemberment in SP to work, EVER, except on my player (when enemies hit me with sabers they cut off my head or torso).

I can't cut up enemies no matter what settings I use.

With or without OJP 4.

Any ideas what I might be doing wrong?

g_dismemberment "3"
g_dismember "3"
g_dismemberprobabilities "100"
g_saberMoreRealistic "2"

Model Dismemberment ON

saberrealism (OJP 4 basic): Realistic Dismemberment


Yet I can spawn stormtroopers all day, they die with one hit, but they just fall over.. no body parts cut off. I get hit once by the enemy, I get a body part cut off every time.

The thing is, dismemberment works fine in MP, and in 1.0 I had no problems using full dismemberment in SP. But ever since the patch, nothing....

Very frustrating...

razorace
12-13-2003, 10:33 AM
Gees, Kurgan, you broke it. Maybe you should try reinstalling. Also, have you checked to see if cg_dismember is a cvar in SP?

Kurgan
12-14-2003, 02:59 AM
I guess I did, somehow...


cg_dismember doesn't appear to do anything at all in SP, only MP.

Samuel Dravis
12-14-2003, 03:34 AM
Can you play meleemod with dismemberment?

Kurgan
12-14-2003, 09:06 AM
Last time I checked, yes, I could play melee mod in SP with dismemberment, but I haven't tried lately.

I'll do that tomorrow and makes sure it still is...

Samuel Dravis
12-14-2003, 05:34 PM
If it does, try executing the scripts it has in the meleemod folder when you start the game. There may be something you missed.

Kurgan
12-17-2003, 07:22 AM
I checked Melee Mod 1.0 (with Meleemod fix) and it definately allows dismemberment (including torso cuts, so I assume it's everything).

I run Melee Mod from a batch file in my Gamedata directory, so I'm going to use the same method for trying to get regular SP dismemberment to work. Perhaps the fact that it's a batch file and not a program shortcut makes a difference?

Anyway, wish me luck...

Kurgan
12-19-2003, 02:58 AM
Okay, well I tried using a batch file, and no dice, dismemberment still doesn't work consistently in SP.

Sigh...

I guess my only other thing to try is to remove ALL MODS completely and try it just using the normal game with the shortcut method.


Or, last of all, uninstall and reinstall everything, reapply the patch and try that. ; p

Samuel Dravis
12-19-2003, 03:03 PM
Have you tried using that one mod that edits dismember probabilities for all the SP NPCs? I saw it on pcgamemods.com. Maybe that will help.

razorace
12-19-2003, 06:31 PM
That isn't nessicary, his game should work without it. My bet is that Kurgan's cfg file(s) is doing something weird.

Samuel Dravis
12-19-2003, 06:38 PM
Ok, ok Razor. Kurgan, why don't you post all of the scripts you're running when you start the game.

Kurgan
12-20-2003, 02:48 PM
Yeah, I've tried the starfiredismemberment, mutilate, and now OJP 4 basic.


Just last night I uninstalled JA and then reinstalled and reapplied the patch (kept my old saves and cfg's).

This time I'm going to delete my old cfg's and start from scratch to see if that makes any difference ; p

Kurgan
12-22-2003, 10:04 PM
Well, I tried not loading any autoexec.cfg's or jaconfig.cfg and it's still (assuming I'm not missing something here) not showing the dismemberment (except on me, not enemies, except very very rarely after a long long battle with tons of npc's I've spawned).

I also checked the jamp config and jampserver configs and made sure there were no references to the SP dismemberment commands just in case, but they're clean.


Stumped... (no pun intended, sorry) ; p

Samuel Dravis
12-23-2003, 02:31 AM
Well, I guess you're screwed then. :D

Did you...

Take all mods out of /base.
Take all scripts out of /base (including JA configs).
Start the game by the executable.
Set dismemberment with the menu item.
Test it in some basejka map (spawn some stormies).

Tell us if it works reasonably often then.

Emon
12-25-2003, 01:33 AM
It is painfully obvious; you simply do not possess the same skills as your Sith enemies, week Jedi.

Lei Hng Wei
02-26-2004, 12:03 AM
Whenever it loads it resets saberrealism to Normal so I gotta kick it up every time, and it doesn't seem to work for MP at all. :-(

razorace
02-26-2004, 02:58 AM
Yeah, that's due to the way the cvar is set up for SP. It simply doesn't save it.

Kurgan
02-29-2004, 08:13 PM
I think I may have come across the latest wrinkle in this thing.


To all you people who claim that SP dismemberment works perfectly for you, please try the following and tell me if it still does.


1) Get to the part in SP where you go to the "Dark Side" and start fighting Jedi & Cultists on Korriban.

2) Quicksave your game.

3) Exit JA then quickload.

PS: Make sure you have the 1.01 patch installed for all of this.


For me, this is the part where Dismemberment utterly fails for me and only works on the player (except once in a rare blue moon when it suddenly starts working again for a few enemies then stops).

Kurgan
02-29-2004, 08:14 PM
PPS: The Scripts I'm running are using the shortcut method in Win2kpro (was using Win98SE before):

(in the shortcut):

C:\games\JediAcademy\GameData\jasp.exe +seta g_sabermorerealistic 2 +helpusobi 1 +load quick +set g_sabermorerealistic 2 sets g_sabermorerealistic 10