View Full Version : Jedi Academy dedicated server not relaying to ravensoft master server list

12-21-2003, 07:00 AM
I've been working on this for about two weeks now. I have a Efficient Speedstream 5200 adsl router hooked to two machines through a hub (modem goes to hub, hub goes to two computers). The one I use is computer ip. The other is On the other machine, I run a dedicated server (v1.01) for Jedi Academy using the Jedi Academy Reloaded script (http://www.thejediacademy.net). In my shortcut to the dedicated server on that machine, I have +set net_port 29071, +set fs_game reload, and +exec server.cfg. Now, I can run my server on that machine, and It works (and runs), but to see it on this .199 pc, I go to Local games instead of Internet game and see the game as there.

The problem is, this server isn't being broadcasted on the masterjk3.ravensoft.com server list. I can tell users my public ip address along with the port and they can add it as a favorite server, see it, and join it. But, the server just isnt showing up on the master internet server list. I also tried adding +set dedicated 2 to the shortcut, but no difference.

In my modem settings I forward the internet ports 29071, 29070, 28060, 28061, 28062, and 28070-28081 UDPs to the computer (along with some Directlobby 7 ports). People can connect to the game, so I don't think its a port problem.

here is my server.cfg file

I was working with a guy that tried to help me solve this problem. We tried several methods, including adding seta net_ip (my public ip) and seta net_port 29071 to the server.cfg file, none of them seem to work (actually no one could see the game when it was set to this). I changed it back to the defaults (net_ip "localhost" and net_port "29070"). Also deleted the jampserver.cfg file once or twice and restarted the server. No difference.

When I see the game under Local in multiplayer, I see the name of the server with (something I didn't add) [UDP] added to it.

Any assistance possible I will greatly appreciate, thanks!


Amidala from Chop Shop
12-21-2003, 03:33 PM
The [UDP] is normal when viewing a server locally.

This was the same problem that plagued us for 2 months until the patch came out. Are you using the dedicated server program (jampded.exe)? You must do two things to run it:

1. Apply the 1.01 patch to your server game insatallation first
2. Use the latest dedicated server program, version

You must also forward ports 29060-29062 inclusive.

12-21-2003, 04:01 PM
Really? That must be the problem... I thought I was using but now that I think about it... I will post results later.

12-21-2003, 04:34 PM
No, my Jedi Academy game and dedicated server is up-to-date. I also forwarded those ports, no difference. Still, the game is under LAN with [UDP] on it and not even in raven's master server list. I really think this is unsolvable, but thanks anyways.

11-30-2007, 11:39 AM
I have the exact same problem mate!
I'm tryint to start a dedicated server too and my server name has [UDP] in it on my local server list but for some reason I can't get anyone else to connect to my server. To them it looks like it's offline. Only local IP's from around my house can get onto it from the local list. Can someone help me please?

I'd greatly appreciate it. :) Thanks.

12-01-2007, 01:30 AM
Forward the ports in your firewall/router to the computer hosting the ded server..

01-04-2014, 09:27 PM
I have absolutely same problem. Server is working, friends can connect with IP, but it is not showing in server list. Still noone knows how to fix it?

03-13-2014, 02:18 PM
It's been too long, but is this where you put in:

seta sv_master2 ""
seta sv_master3 ""
seta sv_master4 ""
seta sv_master5

In your jampconfig.cfg file? I thought in 1.01 it automatically posted your internet game to the master lists, but maybe you have to put it in manually.

There are some server launching programs out there like Qtracker but I've never tried using them to actually launch a game instead of directly, or through the "unofficial" (official) ds distribution.

Hopefully you can get it to start polling the server lists which are still up last I checked...