PDA

View Full Version : Help w/alpha channels & shaders


Teancum
12-22-2003, 10:03 AM
I've been busy modifying the Alora2 skin to work with the default Twilek model, and I'm having trouble with shaders and my alpha channel. I created an alpha channel, but I didn't paint over the 'skin' portion of the model on the RGB. Well, I editid a .skin file and the players.shader, but color selection is a no-go, even though I edited them. Anyhow, here's the info I have:

.skin file

torsod,models/players/jedi_tf/torso_09.tga
l_handd,models/players/jedi_tf/torso_01_hands.tga
l_handd_cap_l_arm_off,models/players/stormtrooper/caps.tga
r_handd,models/players/jedi_tf/torso_01_hands.tga
r_handd_cap_r_arm_off,models/players/stormtrooper/caps.tga
l_handd_cuff,models/players/jedi_tf/torso_08_cuffs.tga
r_handd_cuff,models/players/jedi_tf/torso_08_cuffs.tga
torsod_lower,*off
l_armd,models/players/jedi_tf/torso_01_arms.tga
l_armd_cap_torso_off,models/players/stormtrooper/caps.tga
l_armd_cap_l_hand_off,models/players/stormtrooper/caps.tga
r_armd,models/players/jedi_tf/torso_01_arms.tga
r_armd_cap_torso_off,models/players/stormtrooper/caps.tga
r_armd_cap_r_hand_off,models/players/stormtrooper/caps.tga
torsod_cap_l_arm_off,models/players/stormtrooper/caps.tga
torsod_cap_r_arm_off,models/players/stormtrooper/caps.tga
torsod_skin,models/players/jedi_tf/torso_09.tga


and players.shader:

models/players/jedi_tf/torso_09
{
{
map models/players/jedi_tf/torso_09
blendFunc GL_ONE GL_ZERO
rgbGen lightingDiffuseEntity
}
{
map models/players/jedi_tf/torso_09
blendFunc GL_SRC_ALPHA GL_ONE_MINUS_SRC_ALPHA
rgbGen lightingDiffuse
}
}


The skin shows up, but the color selections don't work on it. But, it did work when I referenced the original .tga, torso_04.tga for the torsod_skin -- However, there's more skin showing, and that alpha will not be enough. I assume I'm just doing the alpha wrong. Can anyone help me?

razorace
12-23-2003, 01:00 PM
Just change the alpha. :) I don't see the problem in that.

Teancum
12-23-2003, 07:37 PM
I found the problem. It wasn't me at all. It's just that the parts of the Twi'lek skin tone that can be changed are in the model, not the .skin, texture or shader. I made some changes to the texture, and it worked. However, now my new icons look funny, but I'm looking into that.