PDA

View Full Version : OpenStore buggy?


andargor
01-07-2004, 12:46 PM
I'm trying to find a user-friendly way of choosing models and emotes for characters, and I was thinking of using the Aurora "store" functionality (the shopping interface, which I would dub "Andargor's Extradimensional Emporium" :) ).

I would then dump in there all the different model changing items, and perhaps Jawa's Jedi level up items and basically any other items. For example, there could be an item that allows party selection or return to Ebon Hawk at any point.

This could be called up using a shield item at anytime in the game. The way I'm testing it right now is my shield mod which basically calls something like this (the code is at home, so this is approximative and from memory):


object oStore = CreateObject(OBJECT_TYPE_STORE,"plc_plstccrat",GetLocation(GetFirstPC()));
CreateItemOnObject("G1_I_BELT001",oStore);
OpenStore(oStore,GetFirstPC(),0,100); // Sell at full price, buy free


Now this works fine, I activate the item, and the store screen pops up and the Baragwin Stealth Generator is in the store.

However, the price seems messed up. A very large number appears, almost as if the price is corrupted. Now, if I close the store, and open it again, sometimes everything looks correct, and if I do it again, it's screwed up again.

So I'm at a loss, being so close to having something really useful. Could it have something to do with the fact that I'm opening a blueprint instead of an instance? Should I actually create a dummy character (UTC) to hold the store, and invoke that?

Andargor