PDA

View Full Version : ScummVM Q+E test it for me


bgbennyboy
02-06-2004, 12:02 PM
Not having regular net access sucks multiple varieties of ass.

Attached is the wip version of the latest Q+E. You can now pause/resume the downloading of daily builds and if you right click on the titlebar you can check for an update of Q+E and update the game compatibilty glyphs.

Please test the new things for me. They *should* work but I cant test em properly 'ere :¬:

Check for update should say theres a new version available and list the changes, and updating the glyphs should make ft's glyph at 5%, try restoring the default glyphs too.

Many many thanks to the Huzster for the glyph update script, in the proper release it'll use his script to parse and update the glyphs.

Anyway someone try it, please, youknowyouwanto.

Alien426
02-06-2004, 03:20 PM
When I started "Daily Build" first, it downloaded the new version. Pause worked.

When I try to update now, the small window says "Connecting... remaining" and nothing else happens. I close it and a message box says "Error while downloading".

Huz
02-07-2004, 03:45 PM
Originally posted by Alien426
When I try to update now, the small window says "Connecting... remaining" and nothing else happens. I close it and a message box says "Error while downloading". Works for me every time. Maybe the site was just down when you tried.

However, if you 'Pause' and then close the download window, it tries to read the incomplete archive. Mmm. Then when you click Daily Build again, the button reads 'Resume' when it's already downloading. Mohhh! My small brain is confused!

I can't try the Update Glyphs bit because the Mojo DNS seems to have gone wonky again so it can't find the site. :~ It does say 'Downloading...' forever though - maybe you should make it time out eventually? I'm sure you're well aware of what it does without an internet connection so I won't bother testing that. :max:

guybrushthedwar
02-08-2004, 12:49 PM
I got three weird bugs (that might not be very clear my english being not as good as I'd like to :/)
- First Time I tried The Daily Build button, it connected, it began to download then stop for 20 minutes at "Remaining 5seconds" step... I close the downloading windows and Error while Downloading appeared.
- Second time I tried, the downloading bar was instantly "complete" but the window wouldn't close so I close it myself and get once more the " Error while Downloading" message
-I closed the program, deleted the partial download scummvmwin32 file and restart ScummVMQandEProject. I hit the Daily Build button and an error like " Floating error : attempt 0 division" occured. However a new scummvmwin32 file was created .. weird. So i tried again the Dayly Build buttn and it worked fine...
Since then all attempt to crash the prog (héhé) failed so I don't really understand were these bugs came from.

bgbennyboy
02-09-2004, 10:46 AM
Cheers lads. :)

Back to the e-drawing board methinks.

bgbennyboy
02-11-2004, 01:17 PM
In fact sod the drawing board, no-one really needs to pause the download anyway, modem users be dammed.

Joshi
02-12-2004, 10:56 AM
That's what we like to hear!

I'l test it when I get the time.

bgbennyboy
02-20-2004, 11:02 AM
Right.. someone please test this one for me.

I've changed the download system so now download managers like getright wont intercept the daily build or any other file that Q+E downloads.

Please test daily build, update glyphs, restore glyphs and check for update, all should work fine now. If its all fine then I can release it this weekend and get back to pretending to do some work.


Cheers lads.