PDA

View Full Version : Hmmm...I'm confused.


chay80
02-10-2004, 12:20 AM
OK, first off let me say that what I'm trying to achieve is to improve a few items that I can use just for Talchia's KOTOR Arena mod with lower level characters (under 10 specifically) so I can have some really long, frenzied battles. All the characters under 10 or so I'e taken in there tend to get slaughtered fairly quickly. So...

I've been tinkering with little used items (for me at least) in order to buff up my melee battle-related stats (str/dex/con) and/or damage resistance.

So I took an implant (I removed the feats required to use implants), added +10 str. So far, so good. The trouble comes when I try to add any other benefits to the item. The 2nd added User-defined Struct doesn't work, no matter if I try buffing attributes or adding damage resistance/immunity. I always get Bad StrRef for the second Struct in-game.

OK, for +10 Str I did this:
2 [User-defined Struct:0]= ...
ChanceAppear [BYTE] =100
CostTable [BYTE] =1
CostValue [WORD] =10
Param1 [BYTE] =255
Param1Value [BYTE] =0
PropertyName [WORD] =0
SubType [WORD] =0

Works great. Then when I try to add +10 dex or con like this:

ChanceAppear [BYTE] =100
CostTable [BYTE] =1
CostValue [WORD] =10
Param1 [BYTE] =255
Param1Value [BYTE] =0
PropertyName [WORD] =0
SubType [WORD] =1

...I get Bad StrRef +10

What am I missing?

(LOL I deliberately gave this kind of detail to avoid any of the usual response to newb modder and to show you exactly what I've tried)

Thanks in advance for any assistance.