PDA

View Full Version : Escape from Monkey Island in WINXP


ufo8mydog
04-02-2004, 07:47 AM
I cannot get Monkey Island 4 to work on my Windows XP.

When i click the Play Monkey 4 button, the computer plays a monkey sound. The screen then goes dark momentarily, and then the game closes with no further warning.

I have tried to run the game in the various compatability modes provided by Windows XP. This includes 640x480 resolution. I have also played around with the True Colour/High Colour settings. One interesting thing to note is that when I try and play the game in Open GL Mode, I get an actual error message before the game closed.

I have the latest nVidia video card drivers on my computer; the sound card is an Audigy, the video card is a gforce4 ti 4600. I have 1 gig of RAM.

I have also updated the game with the 1.1 patch, and reinstalled it just to make sure.

Any suggestions would be appreciated!

ufo8mydog
04-05-2004, 08:21 AM
An update to my situation...
I installed a clean version of Windows XP onto my computer, and tried to run EMI; the same problem occurred. I then formatted that hard disk and installed Windows Me on the system; the game worked perfectly!

I think i have narrowed the problem down to DirectX. EMI uses DirectX 7.0 to run. Windows Me has DirectX 7 installed initially. Windows XP on the other hand uses DirectX 8 or 9 out of the box.

Therefore, I would like to know if anyone has had any experience downgrading their version of DirectX to version 7, or perhaps running two different versions of DirectX in tandem.

Joni
04-06-2004, 10:18 AM
I have WinXPPro SP1a, DX9 with GF2 and newest Detonator drivers and EMI works fine. Only thing I could think is that GF4 drivers has some problems with EMI. Try different versions of Detonator drivers.