PDA

View Full Version : EFX: expensivePhysics flag causes a crash... (only in JA)


Scarlett
04-25-2004, 09:48 AM
Just wondering if anyone knows of a solution to this. If expensive physics are enabled for an effect it causes an in-game crash when it gets processed. This wasn't an issue at all in JKII, so maybe Raven broke something since then.. or maybe it's just expected to be setup differently now (and EffectsEd just wasn't updated).

Or is this somehow only an issue for me?

razorace
04-26-2004, 03:59 AM
I didn't even realize that you could use the expensive physics on effects.

Scarlett
04-26-2004, 09:45 AM
Well, it's nothing like Havok or anything.... ;)

But, basicly it just ensures that the particle actually collides with solid (like it's suppose to). Since without them, they tend to skip thru if it's velocity is high enough. Which really sucks in my case, my little weather system relies on the effects resources at the moment - so, my rain particles for example are skipping thru everything, passing rooftops into buildings and such, not to meantion that the raindrop impact effect doesn't spawn. Bleh.

I'm in the process right now of creating my own effect system though, using local entities rather then the engine-side stuff. I've been meaning to do that for a while anyway though - since there's all kinds of things i've been needing to do with the effects that Raven never setup for their EFX system. Also that means i can modify them in code if i need to (which i've really been needing to do).

razorace
04-26-2004, 10:08 AM
Ah. I know that Unique did some tracing stuff for his rain effects to fix that problem.

Wudan
04-26-2004, 02:23 PM
Check out the Q3F mod website (probably just www.q3f.com), they've opensourced their atmospheric effects system (snow and rain) it's all client side.

A slightly improved version is used in Enemy Territory.