PDA

View Full Version : I Need Help With MI4 PS2


gazza07
07-05-2004, 01:40 PM
Hey everyone,

im stuck on Escape From Monkey Island for the PS2, im at the part where u need Casaba to blow up the rock with the bronze hat underneath it, but whenever i get me Lil Guybrush n Lil LeChuck out, it automatically puts them away even though i ahve the correct rock.

am i doing something wrong?

Help.

Gaz

JawaJoey
07-06-2004, 02:29 AM
First, be sure you really have the right rock. Double check with the parrots, just be positive it's right. If it is, then maybe just restarting the game and/or your computer would help. If not, try reloading a recent save before then if yuou have one and try finding the rock over again.

I don't remember exactly, but it's possible that you have to use the puppets with the rock, not just use them. That could be it, but I'm not sure.

gazza07
07-07-2004, 12:33 PM
ive tried pretty much everything, and i still cant do it, tried restarting the PS2 and everything, tested the parrots over and over and ive defo got the right Rock.

any other tips?

Cheers

Gaz

Skinkie
07-08-2004, 01:10 AM
Just to clarify, you have one drunk parrot right? That's to make absolutely positive you're doing this right.

If you have the right one, all you should have to do is use the puppets on the rock. That's really all the helpful advice I can think of.

Joshi
07-09-2004, 10:51 AM
At a guess, I'd say that you've eithre played this game flawlessly before, or are using a walkthrough and missed out a bit (or the walkthrough was crap and didn't tell you all you needed to know)

Basically, make sure you've first gone back to jambalaya and looked at the statue. And I don't just mean look at it, i mean use the acion on guybrush for him to look at it and pass coment on it, you'd be surprised how many people don't do this and wonder why they're not progressing in ther game. the talk to the tourist, you should come up with a conversation which talks about the statue and what happened to to hat. then go back to Knuttin Atol and talk to Lafeet (or is it Lafoot, I haven't played in a while) abuot the hat (which you probably weren't able to do before without doing the stuff I just said) and he should tell you he's hidden it beneath one of the rocks but can't remember which. Then do the thing with the parrots (if you've already found it, just go back and ask them again) and it should work.

If all else fails, load a previous savegame, or start a new game.