PDA

View Full Version : MS Force Feedback 2: Buttons 7 & 8 not recognized


stevo
02-23-2001, 09:10 PM
Has anyone tried using a MS Sidewinder Force Feedback 2 joystick with Rogue Squadron? The game refuses to recognize buttons 7 & 8, but appears to function normally otherwise. RS apparently thinks there are only six buttons on the joystick, because when I press "Defaults" to reset the joystick mappings, RS maps buttons 1 through 6, but fails to map buttons 7 & 8. And, it won't let me manually map them either - it doesn't respond at all to buttons 7 or 8 when I attempt to map them to commands manually. Any ideas?

Relevant hardware/software:

Rogue Squadron, version 1.3 (from the ReadMe file)
MS Sidewinder Force Feedback 2 (just purchased this week)
Celeron II 566 overclocked to 876
Abit BH6, rev 1.0
128MB Micron SDRAM -8E
Voodoo 5 5500 AGP using 3Dfx 1.04.01 beta drivers

Redwing
02-25-2001, 04:09 AM
Sorry I can't answer your question, but try posting this in the Pilot's Lounge.

------------------
At last we will reveal ourselves to the Jedi.
At last we will have revenge.

stevo
02-25-2001, 04:41 AM
OK. I reposted in the Pilot's Lounge.

Gold Squadron Leader
02-27-2001, 01:50 PM
Below are the RS joystick button defaults, what functions are you trying to map to buttons 7 and 8?
The following text was extracted from LucasArts Technical Support for RS:

Joystick Support

Joysticks are fun. http://www.roguesquadron.net/forums/smile.gif We highly recommend using a joystick. Joystick buttons can be reassigned, but all joysticks (and gamepads) default to the following button assignments:


Button1: Fire Primary Weapon
Button2: Fire Secondary Weapon
Button3: Thrust
Button4: Brake
Button5: Special Action (S-foils, etc)
Button6: Link Weapons
Button7: Roll
Button8: Cycle Camera Views
Button9: Right Brake
Button10: Left Brake

Z-axis: Thrust/Brake
To disable joystick control of your craft while flying, press Ctrl-J. To re-enable joystick control, press Ctrl-J again. Joystick control will automatically be restored when the level ends, in any manner.

If you are having problems controlling your craft while flying with a Joystick. Check the fine-tune control knobs on your joystick. Make sure they are centered. If the problem persists, re-calibrate your joystick, either through the Launcher (Hardware Configuration button) or through the Windows Control Panel.

Also, when using a joystick, make sure you're not accidentally bumping or moving the mouse while playing Although the craft will auto-center itself if this is done, it can be very disorienting, and make the craft difficult to fly. One solution is to disable mouse support by pressing Ctrl-M while in-flight.




------------------
Ties are flies, swat'em!

stevo
02-27-2001, 05:07 PM
Thanks for the reply. I tried to map buttons 7 & 8 to any command (I just about tried them all), but RS simply doesn't respond to either of these buttons. It apparently thinks there are only six buttons on the joystick. I've since tried the joystick with X-Wing Collector's Series, and it appears to recognize all eight buttons properly. One thing that I failed to mention in my original post was that I have DirectX 8.0a installed, so I'm going to revert back to 7.0a and maybe RS will work better with that.

Moff_Kioet
02-27-2001, 05:25 PM
hey, i think i had the same problem once. have you tried setting up your joystick with 'cutstomize joystick' in the control panel under gaming devices??? oh, the hat switches unfortunately can't be changed to anything else besides viewing (is this true???)

stevo
02-27-2001, 06:42 PM
Are you talking about creating a Sidewinder "profile"? Since RS allows you to remap the game commands to the joystick buttons, I didn't think it was necessary to create a Sidewinder "profile". However, if since RS refuses to let me map buttons 7 & 8 within the Joystick panel of the game, I might be able to map these two buttons to RS keyboard commands instead using a profile. I'll give it a try.

Rogue Renegade
02-27-2001, 09:36 PM
No, you CAN map the Hat POV buttons! I use my "hat" to control 1. Special Function, 2. Laser Sync, 3. Roll Over, and 4. Cycle camera view.

The problem with your 7th & 8th buttons is probably in the joystick itself. I have another joystick that seems to have 6 buttons, but is really just 4. 2 of the buttons are repeats on the other side.

If you KNOW this is not the case, then double check your joystick setup in Windows. If a 6 button setup is clicked, then you will not be able to use the other buttons.

For what it is worth, my Thrustmaster Top Gun has 4 buttons and a 4-way hat. I have 8 functions programed. Also I too use DirectX 8.0.

------------------
"I am the Alpha and the Omega," says the Lord God, "who is and who was and who is to come, the Almighty." (Rev. 1:8)

[This message has been edited by Rogue Renegade (edited February 27, 2001).]

Moff_Kioet
02-27-2001, 11:40 PM
awesome!!! i guess there's hope for me afterall! :P I have a Saitek Cyborg 2000 joystick, and it's very much like the one you got rogue. i've mapped the hat buttons for the game TIE Fighter with it. i guess i'll put the left and right hat to be brake left and right for the speeder

the top one can be used for switching weapons or laser sync, and the bottom one can be used for special. http://www.roguesquadron.net/forums/biggrin.gif

Rogue Renegade
02-28-2001, 04:26 AM
Great! I like controlling everything I need with the joystick! In the heat of battle, it can really suck to have to try and find a key on the keyboard.

stevo
02-28-2001, 06:58 PM
Rogue -

All eight buttons on the MS Force Feedback 2 are distinct buttons - they should all function independently. And, in fact, they do function properly in the Game Controllers applet of the Control Panel. Because of this, I believe the problem lies with RS, not the joystick configuration or the joystick itself. Furthermore, X-Wing Collector Series recognizes and responds to all eight buttons, so this reinforces my belief that RS is the problem. I will do some more testing with other games just to be sure.