PDA

View Full Version : Game won't start


Dante
02-15-2001, 07:23 PM
I get the can't initize HAL error, however the game worked previously on my voodoo 2 with Direct X 7 drivers. I now have a voodoo 5 card, and Direct X 8.0a, and the latest drivers from 3dfx. Can anyone offer any insight? This was all on the same computer too, just with those two upgrades.

Gold Squadron Leader
02-15-2001, 08:05 PM
Here's a couple of things to try:

1) Uninstall RS and re-install it.
or
2) Find out how to go back to DirectX 7.0 drivers, I have 7.0a and it works fine. I don't trust 8.0 or 8.0a.
or
3) Contact LucasArts support for suggestions.

------------------
Ties are flies, swat'em!

Dante
02-16-2001, 12:53 AM
Well, the 8.0 version is required for some newer games I own...this maybe a matter of Rogue Squadron being too outdated to run on 8.0....hell Jedi Knight works...

Gold Squadron Leader
02-16-2001, 01:09 PM
In that case, try options 1 then 3. I don't have a need for DirectX 8 so I haven't upgraded yet. I'm not saying RS will not work with DirectX 8, but don't know anybody with that combination. If you need it for other games, then of course don't go backwards. I am holding off on going to later version of DirectX until I need it. If it's not broken, why fix it, right?

------------------
Ties are flies, swat'em!

Rogue9
02-19-2001, 03:48 AM
Try dircetx 7.0, 8.0 has some bugs yet to be wrked out.

------------------
Leader of 3 Flight

Mwahaha Mwahaha Mwahahahahaha...

Rogue Renegade
02-19-2001, 09:29 PM
I have DirectX 8 and have no problems. I think your problem may be with the VooDoo card. Doesn't the RS patch fix that problem?

Rogue9's Assasin Droid
02-19-2001, 11:46 PM
different systems react differently to the directx upgrade.

stevo
03-01-2001, 05:42 PM
I was getting the HAL error too using the latest x3Dfx drivers posted on the x3Dfx site with my Voodoo 5 5500 AGP. I reverted back to the official 3Dfx WHQL 1.04 drivers, and the game runs but will crash back to the Win98 desktop intermittently. I also have DirectX 8.0a installed. I may end up reverting back to DirectX 7.0a, if all else fails. Maybe that will finally stop the crashes.