PDA

View Full Version : Something wrong with DirectX?


Crow_Nest
08-10-2004, 01:27 AM
After i installed DX 9.0c i get this:

http://crownest.poonpipi.com/images/dxdiag.jpg

They said its old and could cause problems, when i play games like Max Payne 2 and even Counter Strike 1.6. I get lots of framedrops in some places. I already got the offical forceware 61.77 from Nvidia which has support for DirectX 9.0c and OpenGL 1.5. Already reinstalled DX 9.0c but i still get the same error.

Whats wrong? Is this serious?

Sivy
08-10-2004, 05:38 AM
did you install directX before your video card drivers?

everytime you install new video card drivers you should also reinstall directX otherwise some of the video driver files will overwrite some of the directX files with older files.

in other words... reinstall the video cards drivers and then reinstall directX (in that order) that should fix the problem.

Astrotoy7
08-10-2004, 06:14 AM
Originally posted by Siv
did you install directX before your video card drivers?

everytime you install new video card drivers you should also reinstall directX otherwise some of the video driver files will overwrite some of the directX files with older files.

in other words... reinstall the video cards drivers and then reinstall directX (in that order) that should fix the problem.

Yes, this I found out after similar dilemmas....do as the Sivski says Crow ! I notice once again that you are talking about framerates..
*sigh* :p

mtfbwya

edlib
08-10-2004, 07:00 AM
I just checked my DXDIAG and I have the same exact files that you have the issue with (same version number, date, and size) but with "No Problems Found"

Strange.

I'm not sure I would worry that much about it unless you are seeing serious performance issues that you can directly attribute to these files.
I had something similar once before: DIRECTX kept reporting phantom errors, even though everything was completely up-to-date and seemed to be running just fine.

I guess my next step would be to totally wipe the vid-card drivers clean and reinstall them,.. or to do a system-restore back to before installing DX9c.

Astrotoy7
08-10-2004, 07:36 AM
Originally posted by edlib
I just checked my DXDIAG and I have the same exact files that you have the issue with (same version number, date, and size) but with "No Problems Found"

Strange.

I'm not sure I would worry that much about it unless you are seeing serious performance issues that you can directly attribute to these files.
I had something similar once before: DIRECTX kept reporting phantom errors, even though everything was completely up-to-date and seemed to be running just fine.

I guess my next step would be to totally wipe the vid-card drivers clean and reinstall them,.. or to do a system-restore back to before installing DX9c.

he he he Dx 9.0c reminds me of the original JA patch(1.01 ?), which caused more hassles than it fixed :D

mtfbwya

Crow_Nest
08-10-2004, 09:44 AM
Originally posted by Siv
in other words... reinstall the video cards drivers and then reinstall directX (in that order) that should fix the problem.

Done that still get the same errors, oh and sometimes i get this

http://crownest.poonpipi.com/images/dxdiag1.jpg