PDA

View Full Version : This is driving me freaking nuts...


Tesla
09-04-2004, 05:15 PM
Right, i've just made my nice gold skin for the Katarn saber hilt, i set up the .skin file correctly with the right surfaces for skin to show up on the model....

So to be sure i check it in MD3view and try to import the skin to see if it will show up in-game and i get this error :-

Unable to find model to apply skin "C:\LucasArts\Jedi
Academy\Base\models\weapons2\saber\gold.skin" to!

So what the hell can i do to get this working ?

I can send you my pk3 i have made, which didn't work because in game it just displayed the base Katarn textures. :(

I've replaced the default ones as a test and checked them out in MD3view and they display fine, but the skin file isn't working...

I've mailed someone @ Raven to see if he'll see what the problem is, but if someone here wants to have a go, please contact me Here (tesla@xtremegamesinc.com)

Psyk0Sith
09-04-2004, 10:04 PM
use the correct path:


"base\models\weapons2\saber\gold.skin"

get rid of lucasarts\jedi academy.

Tesla
09-05-2004, 05:48 AM
How do you mean ?
Set up the paths in the program or something else ?

Psyk0Sith
09-05-2004, 07:48 AM
in the .skin file and the pk3 dir structure.

Tesla
09-05-2004, 03:03 PM
Nope still no change, same error keeps coming up.
My tools dir is in the GameData folder, is that the problem...

You wanna have a look at whats wrong ?

Psyk0Sith
09-06-2004, 06:35 AM
Yeah sure, but i think you should try this first:

1.Make sure your .skin file has the same name as your .md3 file

Let's say i make a saber called psyko.md3, the .skin file will be named psyko.skin and contain the name of the model followed by the texture path like this:

saber_w,models/weapons2/psyko/saber.jpg

2.saber_w is the default name given to your hilt in 3d max (or put the name you used instead).

place the .skin and texture in the model's path, in this case:
models/weapons2/psyko/saber.jpg

3.Load the model into md3view and import the skin (go to file then import skin), then write a .glm with the new skin applied.

my e-mail is psykopat@geocities.com

Tesla
09-07-2004, 03:52 AM
Yep that method worked great, the skin applys its self fine ! :D
And the md3 written to glm was fine, im just gonna test it in game with the .sab im gonna write.

Anyway in which i can write a shader for specular shiney effects of some kind, like a saber_spec.jpg , like the base Katarn saber has ?

Psyk0Sith
09-07-2004, 02:37 PM
Write a .shader file:

Just check raven's .shaders to get started, that's what i usually do.

Tesla
09-08-2004, 05:29 AM
Well the hilt works, and so does the shader. :)

But the blade seems to be emmiting a bit to high, i used Convert to .glm (With 90% skimming) added for JA. (Or whatever it said and spelled)

If i use the other method, i have an upside down hilt with most of the blade in the hilt model it's self.

Click Here To See,the blade error (http://tesla.xtremegamesinc.com/jka/shot0016.jpg)

Any ideas on how to fix this, or does it simple require a recompile as a .glm ?

Psyk0Sith
09-08-2004, 02:59 PM
Usually it's because your "tag_flash" isnt placed properly but i could be wrong.

So just go back to your 3d software and move it down a bit.

Oh and good job! :cool:

keshire
09-08-2004, 08:09 PM
The tag_blade is too high. I usually bring it donw so it starts just inside the actual model. Use md3view and show origins to see where the tag is located at and pointed at.

keshire
09-08-2004, 08:12 PM
Also, the spec files are for specularity. Which is related to high much light is reflected off certain areas. The lighter the area on the texture the more light is reflected. Another fun thing is too use 3ds max and gmax to do bump mapping on the texture. As well as using the free true grit plug in for 3ds max to do realistic dirt and grime effects.

Tesla
09-09-2004, 07:10 PM
Thanks guys. :)

Btw, Pysk0 i emailed you, check your inbox soon. ;)

Tesla
09-13-2004, 06:33 AM
Im really new to modelling programs, and i tried lowering the tag but something went wrong and the blade ended up to the very left of the hilt lol. :p

So could anyone with experience in a modelling program lower the tag, could you offer your help please. :)

My Email (tesla@xtremegamesinc.com)

Tesla
09-23-2004, 06:09 AM
Well, after trial and many errors i finally got it fixed and its working fine. :D

http://www.pcgamemods.com/7587/