PDA

View Full Version : JA Plus Mod confusion...


Joetheeskimo
09-21-2004, 11:57 AM
About half of the servers on JA these days require JA+, so I decided to go get it. When I went to pcgamemods.com, though, and got to the J's....there are about five JA+'s! WTF? :confused: Which one do I need?! So I downloaded the least confusing one - JA+ for win/mac. Then I open up the Readme and instead of saying "extract to base" or something, it goes on about client plugins and configure this and configure that and rename this and it takes ten steps to install it! I don't want to run a server with it, I just want to be able to play on JA+ - enabled servers!
Maybe I'm just lazy, but why can't it be one download in which you only have to extract to you base folder? Can some one please help me out?

Also, is there a seperate MOD for RBG sabers, or is it only available in JA+?

Thanks for your help.

Slider744
09-21-2004, 02:28 PM
///////////////////////////////////////////////////////////////////////////
How to install?
///////////////////////////////////////////////////////////////////////////

- it is very simple, you just have to
Delete all client side files ( .pk3, .cfg ..cgamex86.dll, uix86.dll.)of the old plugin versions in your gamedata/japlus folder
put all new files ( .pk3, .cfg , ....)provided with this mod in your gamedata/japlus folder


is there 10 steps to rename that or that?
it is quite simple can be found at top of the readme

just read those 2 points

iamtrip
09-21-2004, 03:15 PM
JA mod is rpg friendly.
By nature, it can't be difficult to install.

Kurgan
09-22-2004, 12:26 AM
It's called "Version hell" my friend.

It's when a mod maker creates and releases version after version, usually either because he can't stop adding new features or doesn't do adequate testing (meaning new versions have to continually be uploaded to sites to replace bugged versions).

While most of us have no argument against mod makers improving their "products" and removing bugs, the trouble is that this saturates the mod scene with new versions, creating confusion, leading to servers that are running different versions and people who can't join those servers because they have the wrong versions installed.

The problem is compounded when many websites continue to serve the old versions of the mod alongside the new ones. Oftentimes they either don't let you remove the old outdated ones or they simply can't keep up with the releases by the mod-maker.

This isn't simply something that's happened to JA+, but to many other mods out there for many other games.

It can be minimized by more patient testing and private beta testing, but not completely avoided, unless a mod is never updated.

Slider744
09-22-2004, 01:55 AM
in the case of joetheeskimo5

this is moore the lazyness that is the cause of the problem

there is just 2 version currently of the client plugin on pcgamemods and they are both associated with a unique version number...

then if he had read just the about 10 frist line of the readme he should have read how to isntall the mod ..

it is writen in very big letters....

Now concerning JA+ update, the new versions are more due to new features or improved features than bug correction...
there is not a lot of bugs in jA+ because i spend a lot of time in beta test...
for example the 2.2 verison is coming after 3 months of beta test after the 2.1.....
sure you could say that the FIX section of the readme in 2.2 is big, but they concerns mainly basejka bugs that were hard to fix and that took a lot of time...

then JA+ is not confused in the sense where i told to all wensite to remove old version since a long time...

THen for the "i can't join the server because i don't have the lastest version",, this is completly wrong with JA+ as it is totally server sided and can be pluginable at client side....
you are not obligated to download the lastest plugin...
it is just better

but if you don't want it is up to you

Kurgan
09-22-2004, 02:29 AM
Too bad there isn't a way for you to make the mod "auto check for updates" or something. ; )

Most people that download JA+ probably don't even realize you keep updating it and making new versions. They just download it once and think that's it. After all, most mods aren't updated at all, or only once in a great while or one quick update at release (to fix some bug).

Unless they are checking PCgamemods or your site every day how are they going to know to download new versions? Just check ASE sometimes and you'll see the problem...

Slider744
09-22-2004, 04:13 AM
i already thought about this problem

so i implemented in the server part something that tell to the users if their is a new version available...

but this is not perfect because i didn't want the server to make extra connection bandwidth use to connect to another centralized server that contains the last version number available...

so for the moment , the last compiled server version contains also the last avaible plugin version number and tell to the client if there is a new plugin available....

this is a temporary solution

soon i will make a windows installer for JA+ that will give the possibilities to check for new available version...
it will not be the server that will connect to the centralized server that contains the version number but the client..

razorace
09-22-2004, 08:31 AM
Also, is there a seperate MOD for RBG sabers, or is it only available in JA+?

Actually, most other code mods have RBG sabers. I know that OJP, Movie Battles 2, and AotCTC also have RBG sabers.

Nalukai
09-22-2004, 08:31 AM
who cares anyway JA+ ruined the true free for all experience and now you are seeing more and more servers hosting it on duel servers... its a disease i tell ya- a disease based on abuse whether it be the admins abusing it or the clients abusing it JA+ is the devil of the JK series.

Joetheeskimo
09-22-2004, 12:50 PM
Eh....this thread is pointless because I've decided do settle with ForceMod. Aaaah......Forcemod....so wonderful. :)