PDA

View Full Version : Cursor drifts while in menus screen!!!!


LoQ
09-22-2004, 01:24 PM
Does anyone else have this problem? While in all of the menu and configure screens, my cursor won't stop drifting until it gets to the top of the screen. Now I know it is joystick/rudder related. But I know it actually isn't my Joystick/rudders. When i unplug my joystick it still drifts. When I unplug my rudders it still drifts. The only way for me to stop this is by unpluging both. Which is something I DON'T want to do because I would like to use my joystick, etc in game.

I have calibrated both, too many times to count and still the same prob. They are perfectly calibrated and I DON'T have this problem in any other game! I have also gone out and downloaded the latest Saitek Joystick drivers.

I have a saitek X45 Joystick/throttle combo, and ch rudders. Both are USB.

Can anyone help me? This is very annoying and it makes it impossible to configure, join games, or navigate around in the menu screen.

Any help would be appreciated. Thanks guys!!!

Dregur
09-22-2004, 01:46 PM
I'm having the same type of problem, except that I don't have a joystick installed on my system. What type of mouse do you have? I'm using a Logitech Mx500.

I know it's not the Mouseware drivers, because I uninstalled them and used basic MS drivers, and it still had the drifting.

I'm gonna uninstall the Wingmen drivers I have and see if that fixes it.

-The Grinman :D

ReturnFire
09-22-2004, 01:49 PM
For the Mx500 make sure you use the USB port instead of the PS/2 port. Theres problems with the MX mice in other games like UT2k4.

LoQ
09-22-2004, 02:00 PM
I have the Logitech MX700. Which is the cordless version of the 500. And I am running it through the PS/2 port. So it is suggested that I run it in the usb port? Interesting. Is this a common problem with logitech?

Anyway I will give it a shot when I get home. Hopefully it will work. Thanks for the help guys. If you all have any more suggestions, lpease keep them coming in case the PS/2 port thing ends up being a dead end!!!:cheers:

ReturnFire
09-22-2004, 02:08 PM
On the MX700 make sure you base unit for the wireless portion isn't near, your tower, monitor, or speakers. Just about anything can interfere with the signal sadly. I have the 700 as well. As far as I know the 700 only supports the PS/2 for the mouse(mine atleast) signal problems though can mess with it. Also the 700 is a lot more sensitive to surfaces and dust in the lense area than the 500 is.

LoQ
09-22-2004, 02:13 PM
My MX700 actually supports both PS/2 and USB via an adapter. Like I said earlier, when I have the joystick AND rudders unplugged the problem no longer exists. So the more I am thinking about it the less optimistic I am about the problem being with the PS2/USB port. But I will try anything!!!

Dregur
09-22-2004, 02:15 PM
Originally posted by ReturnFire
For the Mx500 make sure you use the USB port instead of the PS/2 port. Theres problems with the MX mice in other games like UT2k4.

Yup, that fixed the drifting mouse problem, thanks!

-The Grinman :D

LoQ
09-22-2004, 04:44 PM
I just got home and plugged my mouse into the USB port and no change. THe cursor still drifted to the top. Of course when I removed my perfectly calibrated joystick and rudders, the drifting stopped.

So my problem still exists. Any help or suggestions would be much appreciated.

Is there anyone else out using Saitek X45 Joystick/throttle combo? If so are you experiencing the same problem?

Tehro
09-23-2004, 06:27 PM
I'm having the same problem, with an optical ps/2 mouse. Should I just get a usb adapter or something?

Tehro
09-23-2004, 06:43 PM
Scratch that, we tested my roommate's usb mouse, and I still had the same problem (he does not have that problem when playing). Please help!

MadJeff
09-24-2004, 09:43 AM
I'm getting the same thing here. I'm running a MS Wheel Mouse Optical plugged into the USB port. I run a CH Products joystick/throttle/rudder pedals but they are not currently plugged in.

It only seems to drift at the menus (Main, in-game options, etc) but not while in-game. I upgraded to the latest MS Intellimouse drivers dated 8/16/04. Nothing seems to fix it, and it's getting really frustrating trying to hit the menu choices while the dang cursor is sliding up and to the left. ;)

LoQ
09-24-2004, 09:47 AM
Yeah while in the actual game it seems fine, but try connecting to a specific server while fighting your cursor from moving! It's more of a challenge than playing the actual game!!!

MadJeff
09-24-2004, 04:15 PM
Guys, think I figured out a fix, at least for me. I didn't have my joystick plugged in, but still had the problem. I then went in on a lark and removed the joystick driver completely and I no longer have the issue. Of course, I can't play any of my flight sims now until I reinstall it ;) but it seemed to fix the issue. Try it and see what happens.

LoQ
09-25-2004, 10:34 AM
Unfortunatly it still doesn't change the fact that i would like to be able to use my joystick in the game but can't (Just like the game was designed). So my original problem still exists.

Being that my problem was slightly different than yours, I am glad that you are at least able to play now;)

One day I would like to be able to use my joystick for what it was designed for in this game

TheSarge
09-28-2004, 06:55 AM
In the same boat LoQ...joystick plugged in or not (Saitek Evo), wheel plugged in or not (Logitech momo)....still get cursor drift

Not going to uninstall drivers for either to play this game, and reinstall to play every other game I have...

Newest drivers on both

MadJeff
09-28-2004, 06:27 PM
I agree guys, it's unacceptable to me as well, I was just stating what I found when I did a little troubleshooting. As I do mostly flight sims, I'm not going to accept this as a fix either. It's a moot point as I bought this so my son and I could play a little LAN head to head, but I've yet to get the damn thing to even connect via the LAN, forget about online. What a disappointment this one's been... :(

SeljukTurk
09-29-2004, 09:48 AM
Character Moving Without Input
------------------------------
Your mouse pointer and/or player character may move in the game
without any user input when you have a joystick on your system.
If this occurs, check the throttle on the controller to assure
that it is at the center position. You may also want to make
sure the game controller is set up properly in Windows. Please
check the troubleshooting guide for more information on
correcting this issue.

LoQ
09-29-2004, 10:06 AM
thanks but unfortunatly I already tried that a while back. This seems to be an issue that is exclusive to this game because I have never had this issue before.

Hopefully that solution will help others who have similar problems