PDA

View Full Version : need shader error fixed please


The Raitenks
09-26-2004, 09:48 AM
hi folks

i'm currently making a kyp durron skin and wnated to apply a shader to the torso and boots using alpha channels, to make the arms and feets look like shiny leather. the only problem is, that he won't apply the shader to the right regions of the textures, so that all the torso as well as all the boots and hips are affected by it.

this is the shader

models/players/kyp_durron/torso
{
q3map_nolightmap
{
map models/players/kyp_durron/torso
rgbGen lightingDiffuse
}
{
map gfx/effects/chr_white_add_mild
blendFunc GL_SRC_ALPHA GL_ONE
depthFunc equal
detail
tcGen environment
}
}

models/players/kyp_durron/boots_hips
{
q3map_nolightmap
{
map models/players/kyp_durron/boots_hips
rgbGen lightingDiffuse
}
{
map gfx/effects/chr_white_add_mild
blendFunc GL_SRC_ALPHA GL_ONE
depthFunc equal
detail
tcGen environment
}
}


can anyone help me out? if the shader would be correct, i can email the entire pk3, if something with the alpha channels is messed up.


-thanks a bunch in advance, rai

90SK
09-26-2004, 02:54 PM
I saw a lot of gfx stuff in there, yet what you said what you wanted was a shine. I suggest looking around for a shiny shader and then changing all the paths. It looks like your shader has a technical problem that would be easier not to fix.

The Raitenks
09-26-2004, 03:00 PM
i'm sorry, but i don't think so. the shader i wrote (using this helpful yet complicated manual:http://www.heppler.com/shader/shader/section6.htm#6 and searching in assets) works, it works just fine and looks like i wanted it to look. i figured by now, the only problem is the alpha channels on my .tga images. i never used alpha channels yet though i'm an moderatly experienced texture artist, so i never encountered bugs like this.

i'd really appreciate someone more familiar with the q3 enigine could look into my file.


-rai

The Raitenks
09-28-2004, 07:49 AM
okay, i know for sure now where the problem's: it's definately my alpha channel. can someone tell me excatly how to define a to-be-shadered region in the texture using alpha channels? because in all the other maps i looked in, that where supposed to be shadered, the alpha part made them sorta transparent when you activate all the channels at the same time. in my image, it is just solid white and black.

help, anyone?