PDA

View Full Version : Need help Compiling with Kotor Tool


MysticTeal96
12-04-2004, 12:10 PM
Okay either I am missing something or just retarded,
I have the latest version of KOTOR Tool, I made several .nss files and used them with the Project Manager, but when I try and "build project" it tells me that there is an error with the scripts.
Now I know it isn't my scripting because I tried .nss files for mods I know that work and it still give me the error
"Error while compiling blahblah.nss" or something like this. What am I doing wrong? Help anybody!?!
:confused:

Darth333
12-04-2004, 02:28 PM
What script are you trying to compile exactly? Could you paste it here?

MysticTeal96
12-04-2004, 02:48 PM
Sorry it is the code from the recruit an NPC in less than 10 steps...
I think this is it.

void main()
{
RemoveAvailableNPC(7);
AddAvailableNPCByTemplate(7, "p_tariga");
ClearAllActions();
DelayCommand(1.5,ShowPartySelectionGUI());
}


I also tried the Telka Zil "recruit_telka.nss" and that gave me the same error.
I did my homework and read the read me and the help section of Kotor tool, but didn't find any help there.
:mad: Frustration:mad:

Where is the "Desperate Cry for Help Button" on this thing?!?!

tk102
12-04-2004, 02:52 PM
Compiles just fine using nwnnsscomp.exe.

Darth333
12-04-2004, 03:11 PM
I tried it using Kotor tool and it works too :confused:
Do you have Fred's version of nwnnsscomp.exe in the same folder as Kotor tool?

MysticTeal96
12-04-2004, 03:19 PM
Darth333 are you using the latest Kotor Tool Version? (silly question I am sure you are)
I will try re-downloading and/or reinstalling and see what happens. Thanks for the help.

MysticTeal96
12-05-2004, 09:27 AM
Okay so I checked and I do have nwnnsscomp.exe in the same folder as Kotor Tool. I also started over on the script and tried to build the project but it still didn't work. I think this is a newb mistake I am making as it is my first time using script. So I will list what I am doing step by step and maybe someone can tell me where I am going wrong.
1. Type the script in notebook and save as .nss extension.
2. Open Kotor Tool.
3. Open new project.
4. Drag .nss file into override folder.
5. Go to tools -> Build Project.
6. Then I get an error.

I know the script is good, I just copied and pasted it from the tutorial and changed what it told me. So it must be the way I am trying to compile it. Sorry for the Noobness, anyone that compiles with Kotor Tool please...a little help???

Darth333
12-05-2004, 10:20 AM
What error do you get exaclty?
And are you sure that you are not saving as blabla.nss.txt instead of blabla.nss? Check the properties of your file or go into My Computer>tools>folder options>view and uncheck "Hide extensions for known file types"

tk102
12-05-2004, 10:36 AM
You can also pull curtain away and use nwnnsscomp.exe directly. The support base for it is larger (currently).

Fred Tetra
12-05-2004, 11:11 AM
I you can email me your project's .ktp file and the .nss files all in a zip archive, I'll gladly take a look at it for you.

In the future, please direct questions involving Kotor Tool to the appropriate thread, so I'm sure to see them ASAP. Also, as I'm sure the moderators would agree, more folks benefit from seeing your problem resolved under the right "heading" (so to speak) as opposed to have to hunt through several threads for an answer, since we don't have the search feature any longer. :)

MysticTeal96
12-05-2004, 03:34 PM
Sorry about the confusion, I originally thought it was the script but when everyone tried it out for me then I realized it was..er...well me. I got it working, but now I have other problems. Such is the life of a modder... I am learning.
:rolleyes:

Fred Tetra
12-05-2004, 04:07 PM
Happens to the best of us! :)

Good Luck!

StormTrooper789
12-08-2004, 05:22 PM
Originally posted by Fred Tetra
...since we don't have the search feature any longer. :)
Well technically, we partially have a search feature. You can search a person's posts. It will take awhile to find. Man, it will feel like Grandpa's falling down the stairs. :D :D

ChAiNz.2da
12-08-2004, 05:29 PM
Originally posted by StormTrooper789
Well technically, we partially have a search feature. You can search a person's posts. It will take awhile to find. Man, it will feel like Grandpa's falling down the stairs. :D :D

The search feature has been re-enabled :D JOY!

:::EDIT:::
I saw your post before it went *poof* (???). You're my new hero tk102
;) :clap2: :thmbup1: