View Full Version : graphics crash every 10-15 minutes

Darth Omegacron
12-08-2004, 08:17 AM
I am in need of a little tech support. My copy of KoTOR crashes every 10 to 15 minutes. Sometimes it lasts longer, but not usually. It can happen at any time, on any screen, even if I haven't touched it for 10 minutes (like if I run to the bathroom or something). What happens is that the entire screen goes nuts - like a blur almost using three or four colors.

When it happens, the sound continues playing for about a minute and then stops. I am unable to end task on it - I have to restart the whole system.

Here are the system stats:

AMD Athlon 1200+
648 MB RAM
Nvidia GeForce FX 5200 w/128MB RAM
Windows 2000 SP4
DirectX 9.0b

I've got the latest updates for Windows, the latest drivers for my video card, and the latest BIOS for my motherboard.

I've tried reinstalling DirectX, reinstalling the game, reinstalling my video drivers, forcing software sound, disabling sound, changing my display options, changing the refresh rate and resolution of the game, disabling all video functions of the game (anti-aliasing, etc).

Nothing seems to help.

I'm at the end of my rope. Unfortunately, I can't take a screenshot of the error either. I'll see if I can post a digital camera picture later.

Any help would be greatly appreciated. I made it to the Star Forge system before this started happening, and it's really annoying, especially since I'd like to replay the game.


12-08-2004, 01:31 PM
Originally posted by Darth Omegacron
Here are the system stats:

AMD Athlon 1200+
648 MB RAM
Nvidia GeForce FX 5200 w/128MB RAM
Windows 2000 SP4
DirectX 9.0b

I'm confused by your amount of RAM. What chip(s) configuration do you have? (multiples of 64 don't come out to 648). Does your computer share memory with an internal video card that possibly hasn't been disabled? (any internal shared memory will 'likely' cause such an error)

I've got the latest updates for Windows, the latest drivers for my video card, and the latest BIOS for my motherboard.

Nvidia released a WHQL (Micro$oft certified) version 66.93 driver in November. Is this the one you have? I know the previous version released that wasn't certified gave me all kinds of odd random errors. PLUS, it works with DirectX version 9.0c (I noticed you have version B)

Darth Omegacron
12-08-2004, 01:41 PM
Oops, you're right - I goofed on the memory. I have 640 -- a 512 stick and a 128.

The video drivers are the November release (downloaded last week).

There is integrated video, but it's disabled. I'm still using the integrated sound, but I wouldn't think that could cause something like this. Then again, who knows?

12-08-2004, 01:58 PM
Originally posted by Darth Omegacron
There is integrated video, but it's disabled. I'm still using the integrated sound, but I wouldn't think that could cause something like this. Then again, who knows?

I believe you're right about the integrated sound card, but again...who knows ;) I haven't heard of a problem 'yet' however.

Maybe try DirectX 9.0c? I know dabbling with it makes the strongest willed person quiver...but since the new Nvidia driver was made specifically to address that version..it might help. I've had no problems on my system.

Also, I've seen here on the forums that if you have an Instant Messager of some sort (AIM, Yahoo, MSN) this will cause all sorts of funkiness if you happen to be IM'ed while you're playing. Plus since most have flashing ads and stuff, there's no telling if it's sending/downloading ad oriented info even when you have it minimized.

Darth Omegacron
12-08-2004, 03:29 PM
Well, I don't have any IMs going, but I'll try DirectX 9.0c tonight and see if it helps.

At least it doesn't take long to find out if something works... :crybaby:

Darth Omegacron
12-08-2004, 07:10 PM
Well, so much for that. Installed DirectX 9.0c, rebooted, and still no luck. About 10 minutes into testing my mod, it went ka-blooie again.

BTW, this started happening before any mods, so I know that's not it either.

Anyway, it's late here, so ah-dee-ohz for tonight.

Darth Omegacron
12-09-2004, 10:11 AM
You know, just for the record, I'd like to say that the support area of LucasArts' site really... well, it could really use some improvement.

If anyone from LucasArts comes to this forum, please put a bug in someone's ear. It's really hard to find an answer on that site.

It's bad enough an awesome game like KoTOR was rushed out buggy, but it's really bad when you can't even find decent tech support for the bugs.

*Whew* :: picks up his soap box and walks off ::

12-09-2004, 10:43 AM
err...this site is not Lucas Arts' official site ;) Although we maintain good relations with Lucasarts, we're just a fan site.

I wish I could help you with your problem but it's the first time I hear this :confused:

Darth Omegacron
12-09-2004, 11:37 AM
Oh, I know this is just a fan site, but sometimes those company types slum it and check out what the fans are saying.

Personally, in my experience, other fans are way more helpful than the people who get paid to support games anyway. :p

EDIT: I'd like to add that the above comment isn't necessarily fair to tech support people. I am one, and I should know better -- after all, there are some good tech support centers out there. It just seems in my experience that game companies in general don't employ them.

EDIT: As a side note, I had a reply from a LucasArts tech support rep this morning. Considering I emailed them Friday night, I think that's a pretty decent response time.

12-10-2004, 09:37 AM
just out of curiousity, are you running the firewall that came with service pack 2??? if you are, disable it. for some really odd reason, it has problems with kotor.

also, integrated sound has no effect on the game. i can tell you this because i use integrated sound for the game. ;)

umm, have you run any kind of anti-spyware programs on your computer recently?? if you haven't, then i highly recommend that you do so since spyware will really eat up both your memory and the clock cycles on your processor (which is fairly slow already). if you don't have an anti-spyware program on your computer, i highly recommend ad-aware personal from www.lavasoft.com.

hope this helps. :D

Darth Omegacron
12-10-2004, 05:46 PM
No, I'm not running the firewall, but I do have one. I've turned it off, though, so it's not even loaded as a process. Still no show.

Also, I've used two different spyware programs including Ad-Aware, with no results. As far as I can tell, I'm cleaner than a whistle.

Here's that picture I promised:


12-10-2004, 07:20 PM
Here's a few 'suggested' BIOS settings. Any of these look familiar?

Assign IRQ to VGA Enabled
VGA Palet Snooping Disabled
PCI Latency Timer 128
Video BIOS Shadowing Disabled
Video RAM Shadowing Disabled
USWC Options Disabled
PnP O/S Installed Enabled
Video BIOS Cacheable Disabled
Video RAM Cacheable Disabled
AGP Graphics Aperture 64MB (or half of your total system memory)

some other things the 'techy' forums I visit are saying to check to see if your video card's fan is running/dirty and that you have proper ventilation for heat buildup.
Of course, it could also be a faulty power supply as well (especially if you've got MANY fans, or peripheral plugged up in it)

I'm not even going to dive into the CPU voltage idea someone had...that's too risky and I don't think that's your problem.

One thing. Does this just happen when playing KotOR, or is it with all games/3d apps?

Darth Omegacron
12-11-2004, 04:16 PM
The only game I have problems with is KoTOR. And here's another mystery to add to the pile -- I played for nearly three hours last night before it crashed. Then, today, my wife played from around noon until about 5PM, and she said it only crashed on her twice. But, of course, when I started playing around 6PM, it crashed 20 minutes into it.

Is it possible one of the cheat codes is causing it? The only code I used today is "infiniteuses" and "turbo", but I used both of those liberally for two weeks before the crashing began.

If I made any changes last night, I sure can't think of what they were.

Also, I finally broke down and emailed LucasArts tech support about the problem and included the DxDiag report and everything. We'll see what they come up with, but I'm pretty sure it's all stuff I've already tried. I support Microsoft products for a living, so I'm pretty used to troubleshooting crashes. :D

The only other change I can think of that happened around the time this started is that I began the game using a friend's CD, then decided I wanted my own and bought the game. It can't be something like a serial number problem, though, 'cuz I've completely reinstalled the game from my own CDs with no change.

I'll get this licked somehow - it's just a matter of time. I'd like to thank everyone that's helped so far. The fan community is one of the things that makes games like KoTOR so much fun to play.

12-12-2004, 06:06 PM
out of curiousity, what graphics settings are you running kotor at???

Darth Omegacron
12-13-2004, 07:03 AM
I've tried various ones, but I'm currently using 800x600, 60. I've tried the other resolutions and refresh rates, but it happens on all of them.

One of the first things I thought of was that if the refresh rate of the adapter or monitor matches the game, the game might be crashing when the hardware refreshes. No luck there, though.

Besides, if I go higher than 1024x768 (my screen resolution), the game gets really laggy.

*** Also, as mentioned in my EDIT above, I had a reply from LucasArts Tech Support waiting for me this morning. Since I emailed them Friday at 9:30 PM, I think that's a pretty good response time. Maybe it's just Yoda's online Help Desk that needs work. :p

UPDATE: Now the game is jumping to the main menu whenever my wife enters the Rakata village for the second time on the Star Forge planet, and she has to restart. This issue was addressed by SoloCoyote in the following thread:


but the issue wasn't resolved and I can't email SoloCoyote to find out if he ever fixed it. My wife is mad now, so this has become a priority.:rolleyes:

12-16-2004, 05:53 AM
well, you seem to be getting much more intuitive help now (from LA). that should be helpful. good luck to ya, and i hope everything works out ok. :D

Darth Omegacron
12-27-2004, 07:57 AM
UPDATE: My wife was able to resolve her issue by going back several saved games and playing back to that point. She got through and was able to beat the game. Woo-hoo!

As far as the other issue, though -- it's actually gotten worse. The game now crashes about every 5 minutes and is basically unplayable (at least to any practical degree).

I've completely uninstalled it, rebooted, then reinstalled it from scratch. Same problem. I can play other games without any problem, so it's definitely KoTOR related.

I'm starting to think the issue is related to the CDs. Even though it happens in both my CD and CD-RW drive, the issue didn't start until I purchased my own copy of the game (I originally installed and played a friend's copy).

LucasArts tech support has been very helpful, but it's apparent that they haven't seen this issue before.

I'm about at my wit's end with this thing, but I'm still confident we'll get it resolved eventually. When we finally do, I'll post the resolution here for everyone. Thanks again.

Darth Omegacron
01-25-2005, 08:44 AM
Guess what? The issue is now occurring on another game as well - Thief 3: Deadly Shadows.

Both games worked fine before the issue with KotOR started, so I don't know could be causing it.

It's only those two games, so it's not like my video card's getting too hot or anything.

All I can figure is that maybe those two games use some feature of the card that causes the problem and other games don't.?

Anyway - it doesn't look like it's a KotOR problem. End of thread I guess.

Darth Omegacron
07-29-2005, 12:46 PM
Sorry to drag up such an old thread, but I finally have the resolution for this issue.

It turns out the card was overheating and it was my fault. At some point previous to this issue starting, I had opened the computer for maintenance and unplugged the power plug on my video card. I forgot to put it back on and ran the computer for some time that way.

Even though I plugged the card back in at a later date, it had apparently burned out the fan because it no longer comes on. To make matters worse, the system has no fans or airflow whatsoever.

This issue was a stupid one that could have been easily prevented with a couple of $3 80mm fans and a spot check before closing the system back up.

Unfortunately, the card now crashes on any graphics-intensive game. Even though it still works very well with older games, it is useless for high-end gaming.

Again, sorry for bringing the thread back up, but hopefully someone else can learn from my mistake. I know I have.

Now that I have a new 256MB card, I can finally go buy TSL and check it out.

Thanks for all the help.