View Full Version : Trouble Editing with GFF Editor

01-03-2005, 08:17 AM
Anyone familiar with editing .git files with a GFF Editor? If so help a brotha out. I am following along with the "In-depth Module and dialoge creation tutorial" and I get to the point where I go to use the Robius GFF (the one the author used is no longer available) and I get a "wrong header error" when I try to open the .git file. What am I doing wrong?

01-03-2005, 08:31 AM
I think I've gotten the same error, but with items. It worked out by getting the item again with Kotor Tool. I think the same might help with git.s, but I use for git. editing the NwNEditor

01-03-2005, 08:59 AM
The de facto GFF editor can be downloaded from here:

Remember that when you edit .git files, the CameraList will be corrupted. The workaround is to use CamEdit to preserve the CameraList by exporting, then re-importing it back when you're done editing the git.

Darth333 mentions this here in this thread and even goes so far as to mitigate my public embarassment by writing a readme for the app. :)

01-03-2005, 09:06 AM
Check the Type field and Field ID for each entry as explained in this post: http://www.lucasforums.com/showthread.php?s=&postid=1571939#post1571939

If you used the copy/paste function, you likely lost this information.

01-04-2005, 05:34 AM
Thanks everyone. I have also tried the De Facto editor as Tk calls it. And I using the other GFF editor it can't even locate the files when I go File->Open.
Am I not extracting these files right? I've never had a problem with any uti's or utc's.

Darth333 your information is great......if I could only get to the point that I could use it. *Newbness*

01-04-2005, 05:56 AM
If you have kotor tool make sure it is setup to read unsupported GFF files as text. If it is see if anything looks wrong in there like it might be corupted. Also you can pm me with your email and I can send you a copy of NWNeditor which opens erf files and then you can edit the GFF on the other tab.

01-04-2005, 07:06 AM
I have also tried the De Facto editor as Tk calls it. And I using the other GFF editor it can't even locate the files when I go File->Open

The GFF editor looks for *.gff files when you use its File: Open menu. You can simply type a * in the File Name and press Enter so that you can view all file types.

What I do: Right-click the file you'd like to open from Windows Explorer and choose Open With... and then select GFFEditor.exe and select the checkbox "Always Use This Program To Open These Files". Then you can just double click those files and GFFEditor will open them automatically.

01-04-2005, 11:32 AM
Thanks everyone, I'll try Tk's method of viewing the files. And Darkender I did check the "open unsupported file as text", it looked okay. Thanks again :)