PDA

View Full Version : Siege Destroyer/2 + OJP compatability (broken)


Kurgan
01-27-2005, 08:44 PM
Here's my report on the apparently broken compatability between OJP Basic (beta 7) and Siege Destroyer.

---------------------------------
Siege Destroyer 2:

Turbolasers don't damage rebel ships! I even did a slow flyby of the turbolasers in my Y-Wing and they never did any damage. The shots just bounced off! Didn't even dent my shields...

During the ending "cutscene," everyone runs forward (instead of walking forward) which I guess looks cool, but it's not how it was originally. Likewise Threepio merely slides along (walking animation missing).

Also, the reflective floor texture in the Rebel hangar is missing (leaving the default white-on-black grid instead).

Finally, the music track for the map, "music/asteroids.mp3" doesn't play, and gives an error message in the console.


Now I'll be the first to admit, perhaps I did something wrong.

Here is how to ran the mod:

1) Ran dedicated server with OJP Basic Beta 7 (as I normally do) in SIEGE mode, and switched to mp/siege_destroyer2

2) Ran the OJP+Asteroids pk3's in a mod directory and joined.

Here are the exact pk3's I'm running in basejka:


Server:
ojp_basic_007b1.pk3

(and, from Asteroids Mod:)
a-wing.pk3
lambdashuttle.pk3
tie-advanced.pk3
tie-bomber.pk3
tie-fighter.pk3
tie-interceptor.pk3
vwp_overrides.pk3
x-wing.pk3
y-wing.pk3
z-95.pk3

With: siege_destroyer2.pk3 in /base folder.


Client:
same

Here are the pk3's from Asteroids Mod that I am NOT running:

-asteroids.pk3 (told it wasn't needed because of the code in OJP)
-veh_dlls.pk3 (ditto)
-tie-bomber2.pk3 (removed to save space, since it's a cheat)
-yt-1300.pk3 (ditto)


Update: Adding back in veh_dlls.pk3 fixes the turbolaser damage thing, but the rest of the problems still stand.

------------------------------------
Siege Destroyer

Here the map runs pretty much like it's supposed to (as far as I can tell) as if you were just running it in basejka (without the Asteroids Mod enhancements) however, sadly, the "Turbolasers do no damage to ships" thing crops up again...



Any suggestions?

razorace
01-27-2005, 09:08 PM
hmmm, that's not good. I didn't realize that there was a cutscene at the end of the round. Probably a problem with the CoOp code, which is having problems with the run/walking as well.

The turret damage problem is definitely a bug. I'll look into it next if you think it's a priorty.

As for the texture problem, it must be a missing file. Same with the music problem.

Kurgan
01-31-2005, 06:13 PM
Yeah, the turret thing basically makes Destroyer unplayable. Half the challenge of the map is that the turrets don't just sit there and let themselves be destroyed...

The other missing stuff just reduces the atmosphere of the map.

Kurgan
02-18-2005, 12:59 PM
Thanks for fixing this!

Obviously there are still problems with Asteroids/Destroyer2, but Destroyer itself plays great with the one tiny goof, of the ending cutscene when the Imperials win (everybody "runs" instead of walks, and Threepio just floats along, looking goofy).

razorace
02-18-2005, 01:07 PM
There's problems with Asteroids/Destroyer2?!

Kurgan
02-19-2005, 08:22 PM
Yup, and I mean running it through OJP.

(Destroyer 2)

-There's the missing floor texture in the Rebel Hangar.

-The missing music file.

-The Imperial victory cutscene having the characters run instead of walk.

razorace
02-19-2005, 10:20 PM
Well, the texture and music problem is due to some wierd packaging issue.

The run/walk thing is my fault. I'll have to fix it.