PDA

View Full Version : Brightness problem


TheJkWhoSaysNi
02-16-2005, 07:04 AM
Whenever I exit KotOR2 my desktop will be incredibly bright. Usually games will reset it. KotOR2 does not.

Any ideas how to fix it? Rebooting windows appears to be the only way to get the brightness back how it was.


I'm running WinXP SP2 with a Radeon 9800 pro if it helps.

Leviathan
02-16-2005, 07:22 AM
When you're on the Windows's desktop, launch SW : KotOR II and then, close it using appropriate buttons... :rolleyes:

TheJkWhoSaysNi
02-16-2005, 07:29 AM
Nope :(

Whenever I exit from Kotor2 the desktop is much brighter than it was. I *could* set the in-game brightness so it's the same as the desktop but that makes it too dark.

Kiwegapa
02-16-2005, 02:44 PM
The gamma issue is a known one. It seems to mostly affect ATI users but not all of them. I don't know of a proper fix yet, but I've contacted the head of ATI's driver department and he's looking into issues with the game.

Leviathan
02-17-2005, 05:52 AM
Open the Windows's Task Manager ([CTRL]+[ALT]+[DEL]), then the "Processes" mitre and try to find some "suspect" processes, like "swkotor2.exe". If it's the case, select the correct line and press the "Finish process" button.

markussun
02-21-2005, 10:10 PM
TheJkWhoSaysNi,

when that happens to me (with a few games) I simply open my nVidia Display Properties Control Panel, and it automatically resets the gamma settings I previously configured (acts like an initialisation).

Since you have an ATI card, I don't know if the same procedure would work for you, but it's worth a try.

j3di_sean
03-07-2005, 11:33 PM
Same problem here.

I'm using a Ati Card. What i'll do is open the catalyst menu. Change the settings a little and bring it back to your original setting. The purpose is to enable the "apply" button.

Press "Apply" and your desktop brightness should be back to normal.

Hope it helps

Flamehart
03-26-2005, 10:01 AM
I'm having a similar problem.. I try to raise the brightness settings in KOTOR2 and the ingame screen becomes much brighter, like I need it to be, however, it does not save that setting, and usually between intermissions, loading screens, or alt-tabbing, itll go to my "desktop setting" and be extremely dark. I can't get it to save itself at the high brightness settings and is making it frustrating to play.

stingerhs
03-26-2005, 11:16 AM
there's a line in the swkotor2.ini file that controls the brightness. try adjusting that and see if it helps. :)

Flamehart
03-26-2005, 02:04 PM
Did, like usual the game starts up using desktop setting. If I move the brightness bar the game will brighten up, but during cinematics or during alt tabbing, and loading screens sometimes, it goes back to desktop brightness (really dark). I've tried raising the brightness and such by going to my desktop, right click, properties, then going to advanced and changing the Color setting for my ATI Radeon 9500 Pro, but it doesnt seem to want to save my settings -after- I launch KOTOR2. It's very frustrating, and on top of that, KOTOR2 tells me that my card does not meet the "reccomended" settings, however the "reccomended" settings say reccomended is a ATI Radeon 9200 or higher. I've been having that problem since KOTOR1 but KOTOR1 never had any brightness issues.

CapedCrusader
03-27-2005, 03:39 PM
I have this same problem with an Nvidia card. Its kind of frustating having to open up the display properties everytime I exit the game.
Adjusting the ini file doesn't help because then the game is too dark.

Flamehart
03-28-2005, 08:20 PM
I think its a monitor problem but there's nothing I can do about it because the wheel on the bottom of my Dell monitor is broken, and I'm too cheap to go buy a new monitor. 19" is too expensive nowadays :-P