PDA

View Full Version : Bug (Showstopper): Cant Finish Freedon Nadd Tomb


Aqua
02-22-2005, 01:20 PM
I fixed the issue myself see the link below with the FIX
I made.

Obsidion forum bug info (http://forums.obsidianent.com/index.php?showtopic=30630&st=0&p=281562&)

Below was the problem I had and fixed myself

If anyone can tell me how to bypass this
"BS" in the Freedon Nadd Tomb section
of the Kotor 2 game, I would GREATLY
appreciate it.

Here are the Details.


Software
========
PC version Kotor 2

Hardware
=========
INtel Pentium 4 Cpu 3.6 Ghz
Ati Radeon X800 XT Graphics Card
SB Audigy 2 Sound Card
4 Gig Motherboard ram
4 Terabytes Hd Storage

Issue:
========
I Cant Complete the Freedon Nadd Tomb to go onto
the second phase to onderon to beat and kill kavar.

I Cant Leave the Tomb OR Kill the Dark Jedi Master.

Background
===========

I am "TRYING" to complete the second visit to dux
where your party is split up into 2 groups.

Each time I have tried this section, My choice for
the group on Duxn was

Visas as the Group Leader Main character (Level 50)
Mandalore as second choice (Level 50)
Handmaiden as third choice (My PC is Male) (Level 50)

I played the game entirely Darkside. I Never ever got
any lightside points.

I enter the Freedon Nadd Tomb room
(aka 411dxn.are file )

I easily defeat the 3 dark Jedi but the last guy WONT
die and I cant kill him. I cant enter conversation with
him either.

He has the special Lighting FX still functioning and
he stil has a small amount of Hit poins left.

I have all the items from this room IE Freedon Nadds
Saber and the 2 handed dark saber.

I try to Leave the Area and I get the message
posted to the screen
"I cannot leave the battle at this time."

I want to continue the game BUT this is a SHOW
stopper BUG and I dont know what to do. I have
tried work arounds such as putting Blank compiled
ncs files in the overide directory
( the "k_411_hb.ncs" and the "k_411_enter.ncs" files )
but this did not work. I tried modifing the "Are"
file by removing the onenter and onheartbeat scripts
and putting that new file in the override directory
but no luck.

As far as ExecuteScript function is concerned I dont
know what to do.

I need Game flags set so I can
1) Leave area properly
2) start second phase

The scripts I "feel" that MAY and I stress the
word MAY be causing the problem are:

a_leave_411.ncs
a_unlock_door.ncs
k_411_enter.ncs
k_411_hb.ncs
tr_leave_411.ncs
tr_ritual_sc_2.ncs

I even know from the NOTES section in the
411dxn.Are file the following Field Data:

Exit_Door
40 - Play dialogue when you first enter
45 - End fight with Ritual Guys
46 - They all dead now
60 - For the Cutscene with the Door Opening

My issue is with the TAG "EXIT_Door" and
FORCING it to work even though the Last
Ritual Jedi is still Alive.


WHAT I want.
============
A way to continue the game.

I dont know if teleporting will work. Dont
have the script for it and I dont know if
the game flags will be set properly to allow
me to continue IF I do use teleport.

Using ExecuteScript function - ie
Use "~" and type ingame on screen
ExecuteScript("a_leave_411", OBJECT_SELF);
to me is kinda useless at the moment
unless I have a script the will "WHACK"
or nuke that Last Ritual Jedi with the
Lighting effect still active.

Can anyone help me with this so I can
contiune the game. This is one showstopper bug.

Is there a cheat I can do to Kill the
last Ritual Jedi Or FORCE dialogue with him ????

Or is there a Script to bypass the
"I cannot leave the battle at this time."
Message.

I can even send you a save game zipped if
you want to test this for yourself.

I have 3 screen shots but I didnt include
them here because I was not sure how to
upload them to this html page.

Two screen shots shot the the final
Dark Jedi MAster (ritual) standing with
a very small amount of hit points and
lighting effect flowing either to some
point in the corridor entrance or
over the tomb area.

Whatever the solution that is offered,
your help will greatly be appreciated.

Entity210

Drazin
02-22-2005, 05:24 PM
I feel for ya.
I wish i could offer you some piece of advice that would help you, but I am completly clueless on what the root problem is. I am sure you tried to reload a previous save multiple times. Do you have any mods installed? That could be causing a problem.

Aqua
02-22-2005, 11:46 PM
no mods other than changed racing layouts
for easy racing.

I posted this at obsidion as well and someone said
the last guy standing was supposed to die BEFORE the fight with 3 dark jedi. He said a script was NOT
firing correctly. He said to try from a previous reload
but I have done that many times with different groupings of npcs as well thinking that it was one of the NPCs in the group causing the misfire in the script.
No good.

[
I included the screenshots at obsidion
so he could see what was going on

http://forums.obsidianent.com/index.php?showtopic=30630&st=0&p=280469&

]

I really want to FINISH the game but I cant.
UNTIL that GUY DIES. I even sent a message to darth333 in the hopes that his armband teleporter
Might and I stress Might work. I have not got a message back from him so I keep trining.

If I knew which script or trigger was NOT working
correctly I would somehow try to execute or run it manually from the Cheat prompt "~" using
Executesript.

Cant do that until I know what the booboo is.
Its not easy since I dont hace the source nss
files to look at. I have tried to decompile them
but the syntax is more assembler like and hard
for me to tell which script is at fault.

This issue is EXTREMELY annoying to say the least.
I really would like to finish the game just once.

Entity210

Drazin
02-23-2005, 09:30 AM
Darth333 is away on business for the week.
I doubt the teleporter will help, because as you say, its a script misfire and you cant get past it until it sets off a global that allows you to move on.

That guy is indeed supposed to die right away, but if he isnt, all I can think of that could be causing the problem is having a Mod installed. K2 seems to get really glitchy when it has mods installed. I would removed everything from your k2 directory that didnt come off the K2 discs and try again.

Once he dies and you kill the Sith lords, Xarga will run up and tell you how cool you are and that the other group.... Then you leave Dxun to join your other group.

Aqua
02-23-2005, 11:01 PM
I fixed the problem

please see the web link below.

This link ALSO has the fix I made to correct the issue.

Obsidion Forum Bug Info (http://forums.obsidianent.com/index.php?showtopic=30630&st=0&p=281562&)

Thank to all who tried to help me with this issue.