View Full Version : Support for PC Demo? (crashin'!)

04-11-2005, 07:34 PM
Hi there. I was wondering if there was a forum besides this one where I could get support for the PC demo that just came out... I didn't see a forum on the official Psychonauts or Majesco sites.

Specifically, the problem I'm having is that the demo crashes just after the intro cinema. I see the screen with the cute birdies flying about, and soon after an error message appears and the game closes. Looks like a fairly standard Win32 exception type thing.

System specs:
1.2GHz Athlon
Geforce4 4200 (66.93 drivers)
SoundBlaster Live
Win2K SP4

04-11-2005, 07:54 PM
Hmm, just updated my drivers to the latest official version (71.84). No dice.

Here are the exact error messages I'm getting:


Sorry if this isn't the right forum to be posting this in, if anyone knows of a better one, or a place the developers read, lemme know.

Arg! Just want to play Psychonauts!

04-11-2005, 08:16 PM
It worked just fine on mine except some lag in the speech for me, and Half-Life 2 plays great on my computer. Good luck sorting this mess out.

04-11-2005, 08:20 PM
I think several official-y type people read this forum, actually. I wish I had an answer for you, but I haven't even started downloading the demo (and my computer will most likely not run it). Hopefully someone can post something helpful soon.

04-11-2005, 09:08 PM
I don't have an answer right this minute, but I may be able to help tomorrow. Do me a favor though, check out http://majescoentertainment.com/vbulletin/

04-11-2005, 09:53 PM
I'm getting a similar crash as well. My first error message is the exact same as your crash1.png, and the second is another of those messages with 0xc0000005 instead of 0x000001d.

My specs:
Athlon 1.4
Geforce 4 4400 (61.77)
Win XP SP2
some onboard audio

04-12-2005, 04:04 PM
loboVT: Hmm, our systems are similar in a few ways. Those 0x000 numbers are just memory addresses, so it makes sense that they vary across different machines.

Prosky: I checked out the Majesco forums, and didn't see any mention of Psychonauts, or a forum for it etc. I'll keep my eye on the site though.

04-12-2005, 05:53 PM
I had the same prob, setting the game into windows 95 compatability mode let me get into the game properly.. Now im off to play it.
Hope it works for u guys

04-12-2005, 05:57 PM
Some antivirus programs interfere with the demo. Disable any active
antivirus software and run the demo again. If that doesn't do it, let me know and we'll try to figure something else out. And we're hoping to have the Psyconauts forum up within the next day or two, so I'll keep you posted on that. It's more for tech stuff. I totally dig this site for talking about the game and other cool stuff.

04-12-2005, 06:30 PM
No cigar. I don't have any memory-resident antivirus stuff running. I also tried running in Win95 compatibility mode, disabling some services (Apache, Filezilla)... nothing. I tried installing in the default directory (previously I'd installed into c:\PsychonautsDemo), nada.

I really appreciate the help though! As soon as I know for sure I can run the full version on my PC, I'm going to buy the hell out of it.

04-12-2005, 06:48 PM
Can you give me your dxdiag? It would help us sort this issue out.

04-12-2005, 07:38 PM
Okay, here ya go: DxDiag.txt (http://webpages.charter.net/jpmindfile/chud/DxDiag.txt)

04-13-2005, 12:34 AM
I as well crash at the loading screen. Considering your system specs, those of the other fellow having this problem, and my own, I very strongly suspect this is an issue with our old Athlon Thunderbirds and their lack of SSE instruction support. This is the case for most (all?) old Athlons in the 1.0-1.4 Ghz range; they simply have no support for this instruction set and thus any game that uses them in some manner crashes.

I say this because I have seen similar crashing problems in many recent games & their demos, including the newest Splinter Cell, Full Spectrum Warrior, and Brothers in Arms. In each case, the problem has, to the best of my knowledge, been traced to Athlon Thunderbirds and their lack of SSE support, and I suspect it is an issue that will only pop up more and more for us CPU dinosaurs in new releases.

It's hard to say if this is a problem that can be fixed on the developer's side at this point. Brothers in Arms was able to quickly patch up so that those with Thunderbirds no longer have any issues, but that was because SSE usage was confined only to a small element of the physics engine. If the use of this instruction set is extensive in the Psychonauts code, such a solution may not be possible. It's a bit unfortunate for us I suppose, but eventually progress must be made and there can be no fault directed at DoubleFine for not taking into account a quirk in an old series of processors that have pretty well past the point of long in the tooth for a while now.

But who knows, perhaps this is in fact another issue entirely and all of the above is irrelevant. Maybe there's someone out there with an Athlon Thunderbird who is not having any problems? My basic specs, for reference:

Athlon 1.4 GHz
Geforce 4 Ti 4200
512 MB RAM
Soundblaster Live

04-13-2005, 11:00 AM
I would also say it looks to be an SSE problem. I have an AMD Thunderbird 1.333, and get the same errors.

There's an Adobe document that describes errors when running Adobe Premiere, and has the same error code (0xc000001d).

I've been searching around all morning for some sort of software emulation of those instructions. But that would be quite disgusting. It would be nice, if the engine doesn't rely on them too heavily, to have alternate routines for those of us with Thunderbirds. But I would totally understand if there was no patch. We are using rather old processors.

My specs, for reference:
Athlon Thunderbird 1.333 GHz
Radeon All-In-Wonder 9600
512 MB RAM
Win XP SP2
Onboard (nForce2) audio

04-13-2005, 09:25 PM
Hmm, I think you may have found the common thread, MeatBeef. Drat.

In most cases, though, isn't SSE support a compiler-level thing? Can't you just disable it when building through Visual Studio? They might have simply left it on from the Xbox builds... which means they could issue a patch or a new binary.

Besides, I'd be quite surprised if the coders at DoubleFine were hardcore enough (or desperate enough for performance improvements) to have done custom assembly routines for rendering and physics etc.

(Not to impugn the skill of the coders in any way, of course, it's just that these days there's so little benefit in doing so, especially for the Xbox's PC-equivalent architecture.)

04-13-2005, 09:38 PM
Yeah, I'm getting an error in the same place, though the game window stays in the foreground so I can't see what exactly the message is. I don't have a Thunderbird though, I have an Athlon. Admittedly, it's only 900 MHz, but I beat the RAM and gfx card requirements by a good deal, so I wouldn't imagine it's a slight lack of processor speed that's causing the crash.

I sure hope a fix or workaround is found for this soon, but in the meantime I can at least watch the intro movie over and over. :)

04-13-2005, 09:40 PM
Hi everyone,
I'm currently experiencing a strange problem with the Psychonauts demo. Up until now, it has been running perfectly. Now however, when I try to start the game, I get the following message:

"License data is invalid!
Please Contact Customer Support for further instructions."

Anyone else experience this?

04-13-2005, 10:32 PM
MonkeyforaHead, FYI, "Thunderbird" is a specific version of the Athlon. AMD doesn't always advertise the different core names (such as Thunderbird, Thoroughbred, Barton, and a gazillion others). I'm not sure which core the 900 MHz Athlons run at, but if you've got a 900 MHz Athlon, it's almost certain that it doesn't support SSE.

While there is a compiler option to enable SSE optimizations, there are other ways they can get in - for instance, if Double Fine was using someone else's 3D engine that had some sort of assembly-optimized portions that used SSE. We can cross our fingers that they will release a build without it, if it is in fact the problem.

04-14-2005, 02:37 AM
My Barton seems to handle it quite well

04-14-2005, 12:21 PM
Majesco has set up a forum for tech support, check it out:

There is also a FAQ at:

04-15-2005, 04:24 PM
Looks like it's definitely an issue with SSE support (I think it's SSE2 that Athlons prior to the Athlon XP lack, but anyway...). I previously got the same error message, but now I've upgraded to an Athlon XP and it works.

Only 4 days to go to the Xbox version, guys! At least, if you have an Xbox. And can source the game from the US. If not, then aging Athlon XPs are fairly cheap now, at least!

04-22-2005, 10:05 AM
Hey, y'all, I don't know if everyone's been following things elsewhere, but they've released patches for the demo and the full version of the game. They're linked here:

04-24-2005, 04:10 PM
Just wanted to thank you guys for looking into this issue and fixing it so promptly, and providing a patch for the demo too, no less! I was able to play the demo without problems, and put in an order for the full PC version shortly thereafter. YAY!