PDA

View Full Version : Graphical effects not working


lukeiamyourdad
04-20-2005, 08:13 PM
I've had this problem since the second I got the game but didn't bother to try and fix it...until now...

Anyway, effects such as the blur when using Force Wave and Speed, the red of Fury or even Force Sight's effects are simply not working.

I'm pretty positive this is due to my video card(ATi Radeon 9000 PRO with Catalyst 5.4).

Anyone got any idea about this?

Any kind of help is appreciated.

ChAiNz.2da
04-20-2005, 08:18 PM
Do you have Frame Buffer Effects enabled?

Should be a clickable entry in your Advanced Video Options menu...

or you can try to enable it in your swkotor2.ini file by making sure you have

Frame Buffer=1

under the [Graphics Options] header

lukeiamyourdad
04-20-2005, 08:26 PM
I changed it to Frame Buffer=1 but ingame, the option is still greyed out.

Thanks for the reply.

lukeiamyourdad
04-20-2005, 08:30 PM
I just noted something weird. After changing the Frame Buffer=0 to =1 and going in-game to try it, I get out, open the .ini file and it shows Frame Buffer=0.

It's odd since I did save it and changing other options do not do this.

lukeiamyourdad
04-20-2005, 08:37 PM
After making a research about it, I found out my card doesn't support Frame Buffer...

Yet, it works on the X Box x_X

I'm partly insulted.

Thanks anyway Chainz :)

ChAiNz.2da
04-20-2005, 08:39 PM
Have you perchance used the ATI 'hack' ;)

"Disable Vertex Buffer Objects=1"

If so, I'm wondering if that may interfere with the frame buffer effects...

Hey stingerhs, we need ya' here bro! :D

I use nVidia cards, so I'm basically just 'tech supporting' from previous knowledge

------------------

Another trick you can try is to use TSL's "retro" bug...

Start up TSL and click configure... choose the "Recommended Settings" then apply, close out of the game..

make your changes to the .ini file and save...

Startup TSL again, go to configure then re-apply the settings you normally use...

This has been done in the past and it seems to "trick" the game into using your custom settings whenever they become fickle :)

EDIT: Just previewed my post and saw yours... bummer... :(

ahh well, I'll leave these tips in case it may help someone else with a similiar prob..

stingerhs
04-20-2005, 09:26 PM
when using "DisableVertexBufferObjects=1", all i've noticed is a boost to my fps. of course, i use the DNA OpenGL driver (based on the Catalyst 4.7 OpenGL driver) in my swkotor2 directory as well which enables all of the Frame Buffer Effects to be activated with no performance loss or artifacts on the screen.

w/o the DNA driver, glow is turned off, but otherwise, i get all the Frame Buffer Effects.

hope that helps. :)

lukeiamyourdad
04-20-2005, 09:31 PM
Thanks but I don't think it would change anything. My card is getting pretty old and I'm starting to feel it :(

Thanks a lot stingerhs

wingzro
04-21-2005, 12:46 AM
if the option is greyed out, then likely it is not supported by your vid card, so it won't matter if you change the .ini file or whatever. I've got a geforce4mx, so a lot of visuals I miss out on. best thing to do in order to get the effects is just to upgrade the card.

DarthVandar205
04-21-2005, 08:24 PM
Yeah I have a Geforce4MX card and I cant use the frame buffer effects either, theyre greyed out and it does the thing where you change it in the .ini go into the game, its still the same and you go back and its 0 again. I think you just need to get a new card.

The thing im wondering about is on the Ebon hawk, all the lights are dark and kinda dim whereas in Kotor 1 theyre all bright. In the load screen for KOTOR11 ebon hawk all the lights that are on are bright but yet when you get on the ship theyre all dark like they on but theyre dim. Is that supposed to happen because theyre supposed to have a broken dirty look or is that some graphical issue?