PDA

View Full Version : upon exiting tsl, extreme desktop brightness!


Hellfire Jedi
04-30-2005, 09:54 PM
whenever i quit out of TSL, my desktop gets very bright.

whats the fix for this? :O

stingerhs
04-30-2005, 11:12 PM
i know a couple of people have had this problem before, but i'm not sure if a solution was ever found. :(

and to be honest, i'm also not sure if the patch addresses the issue or not. just in case, make sure the game is patched.

Hellfire Jedi
04-30-2005, 11:16 PM
i double checked earlier, its patched.

stingerhs
04-30-2005, 11:22 PM
well, like i said, we haven't been able to come up with a solution on our own.

you could see if it's just some weird interaction with your video drivers. check to see if the brightness settings are being changed in your driver settings when it happens again. if the settings are changed, then check and see if you can lock those settings in some way.

i'm not too sure if that will help, but i still hope it does. :)

ChAiNz.2da
04-30-2005, 11:30 PM
It's definitely something with the video card but it's the game that's causing it. It happens to me on 'rare' occasion where my video drivers don't refresh after exiting the game.

If you notice when you start the game, your desktop will brighten up before the launch screen. I'm inclined to believe it's because of the game's brightness (gamma) settings... Upon exiting, those settings are supposed to be relinquished, by nature of your video card (however this doesn't always work). Much like Microsoft's OS that doesn't want to give up memory it's no longer using (causing users to frequently reboot to recover)... :rolleyes:

If you have an Nvidia Card, create a profile with your "natural" desktop settings. Upon exiting the game, just reload your profile and it should refresh your screen.. I'm unclear however, if you can do something similiar with an ATI card (anyone?)...

stingerhs
04-30-2005, 11:47 PM
Originally posted by ChAiNz.2da
If you have an Nvidia Card, create a profile with your "natural" desktop settings. Upon exiting the game, just reload your profile and it should refresh your screen.. I'm unclear however, if you can do something similiar with an ATI card (anyone?)... well, i can tell you that you can't do that with the Omega Drivers, since that's what i'm using at the moment. however, i can't tell you if you can do that with the Catalyst Drivers. :(

Bob Lion54
05-03-2005, 02:42 PM
I've had it happen twice. Both times I fixed it by reloading the game and exiting again. I'm not sure if this will help sinse your post sounds like it is a constant problem, though. If It only happens ocasionally you might try that.

I'm using an Nvidia card, and I don't know about the others.

tk102
05-03-2005, 04:25 PM
I've had it happen twice. Both times I fixed it by reloading the game and exiting again.

Yes this always fixes it for me. My game crashes during area load about every 3rd area, so experience a lot of that brightness-after-crash. (I'm too proud to post this as a problem though.)

I turned up my in-game brightness because the Ebon Hawk was sooo dark on my LCD. I expect this affects the amount of brightness I experience later.

Video card: ATI Radeon 9000 :rolleyes:

Darth333
05-03-2005, 07:07 PM
Originally posted by tk102
(I'm too proud to post this as a problem though.)
:tsk: that's bad...real bad :D

I had this problem too and I use the same solution...but I had only one crash in 55 hours :D (ATI Radeon 9800 pro)

stingerhs
05-03-2005, 07:56 PM
^^^^
hmm, curious. whenever the game crashes on me, i don't have any problems except for that bruise on my head from pounding the keyboard too many times. :rolleyes:

DarthVandar205
05-04-2005, 06:33 PM
Yeah the game will sometimes leave the screen as bright as it is in the game if it crashes suddenly or sometimes if the game is turned off it wont refresh to the regular settings of the desktop but you can usually resolve this by either restarting or going to the settings and adjusting them.

stingerhs
05-04-2005, 10:55 PM
well, i tried and tried to see if i couldn't duplicate the problem myself (including running a ton of programs in the backround to take up a bunch of RAM, and heavily underclocking my video card) and finally duplicated the same problem, along with absolutely atrocious framerates.

going on a hunch, i utilized a unique feature on the Omega drivers and reloaded my video card BIOS. and it worked! my desktop was restored to normal.

of course, this fix will only work with the Omega drivers. OEM drivers don't have this feature.

anyways, i hope that at least helps out somebody out there. :)