PDA

View Full Version : Juhani Side-Quest Bug


RobQel-Droma
10-25-2005, 07:18 PM
I have been playing KotOR I, and for the first time I have gotten Juhani's quest to trigger. The first meeting, I was on Korriban. I got the message that said "This man seems to be looking for someone, maybe one of your party..." blah blah. I couldn't see him though, but I put Juhani in my party and started off. I found him down the corridor. When I talked to him, it warped me back to the Ebon Hawk, like he just came up to me. After that, everything went fine.

Now, onto the second part. Finally, I found him again, on Manaan. This time, it gives me the same message, except he is right outside the Ebon Hawk, with two Selkath thugs. I switch Juhani in my party, but he won't speak to me! He just stands there, and I can't get into a conversation with him. I left the planet and came back, I went into the Ebon Hawk and came back, I went around further into Ahto and came back, all the times with Juhani in my party, but he won't do anything!

The Doctor
10-25-2005, 09:35 PM
Sounds like you need to use KSE to change the jornal entry back a step (I think that works. Haven't tested that theory yet). If that doesn't work, you'll have to either re-load to a point before you meet Xor or ignore her quest until next time. Sorry.

Achilles
10-25-2005, 10:18 PM
Juhani's side quest is extremely bugged. You can look around the bioware forums for suggestions on how to fix it, however not all of them work 100% of the time. One thing is for sure: don't trigger it until after you've been to the Leviathan.

Darth333
10-26-2005, 01:15 AM
here's a small fix I made a while ago:

Note that I have not tested all the possibilities though but from the feedback I got it seems to do the job. You can give it a try if you want.

RobQel-Droma
10-26-2005, 10:24 AM
Thank you very much! I hope this works, on this playthrough I am trying to do everything, including everybody's sidequests. I already got Bastila's, Carth's, Canderous's, Zaalbar's, Jolee's (well, I know they don't really have sidequests, but somebody will stop Jolee and tell him about Sunry, and so I classify both of them as having sidequests), and I am trying to get Mission's.

Edit: It didn't work, Darth333. I tried using KSE also, but he is still stuck there. I guess I will just give up.

The Doctor
10-26-2005, 04:37 PM
I don't know why, but I never had this bug. The quest always worked fine for me. Weird.

RobQel-Droma
10-26-2005, 05:35 PM
Thankfully I didn't do it until after the Leviathan; Doesn't it mess up Mika Dorin's "premium items" or something like that, where you can't buy them anymore?

Man, this is pretty much my first playthrough where I have had problems with the game. First, in the Vulkar base, I had Zaalbar in solo mode, and when I attacked that scared Vulkar in the one room, it made my character run over there and then I couldn't skip the conversation or talk to him. Then, I have this quest. Not to mention that when it showed you the cutscene of Bastila being tortured, in this game, she was in her underwear; She usually is wearing her clothes, and she was wearing them when she went to fight Malak. As you said- Wierd.

RedHawke
10-26-2005, 11:52 PM
Thankfully I didn't do it until after the Leviathan; Doesn't it mess up Mika Dorin's "premium items" or something like that, where you can't buy them anymore?
Yes it indeed does...

And I believe for the fix Darth333 made to work you have to have had a save before Xor spawned the first time...

RobQel-Droma
10-27-2005, 11:37 AM
Oh well. He only has a little dinky pistol and two thugs with the same, so I might as well skip it. He isn't going to be any challenge. I guess I will focus on getting Mission's sidequest done.

CSI
12-08-2006, 01:23 AM
I played K1 two times. First time it's fine. But second time Xor never appears...I know it's a bug...

Prime
12-10-2006, 07:07 PM
Please do not resurrect old threads. Thanks you.