PDA

View Full Version : Problem with new Robe


RobQel-Droma
10-30-2005, 02:11 PM
Ok, I just created this new robe, and I am having problems with it. It shows up in my inventory, I used KSE to add it, and it has the right bonuses and everything, but it doesn't look any different. It is supposed to be blue with grey pants and boots, but it just looks like any other robe. Can anyone help me with this?

Clone__Commando
10-30-2005, 02:14 PM
the only thing i could think of is that you've changed the robe for a female and want it for a male or something like that. not sure though

RobQel-Droma
10-30-2005, 02:40 PM
I made a female and male file though. And now, I just beat Bastila on the Star Forge, and she was wearing the brown robe, and then after I defeated Malak, she was wearing the robe I made, all colored just like I had it.

Jackel
10-30-2005, 08:01 PM
did you change the texture varience number in the uti to your new texture number?

(I am assuming you are using a new number of course)

RobQel-Droma
10-30-2005, 10:03 PM
The files I had were:

PFBI02
PMBI02 (I think)
g_a_jedirobe02.uti
and then whatever the icon is, which didn't work either, something like gi_jedirobe001 or something.

Jackel
10-30-2005, 10:17 PM
Hmm seeing you just recoloured the robe texture it should have worked right away. Same as the icon.

I would load up a save, add a new version of the 02 robe in to your game and see what it looks like to make sure it has over written the old design. It should come up as the new design right away.

RobQel-Droma
10-31-2005, 11:11 AM
Well, I will go back over it and make sure I didn't do anything wrong, then I will do what you suggested. But why would Bastila be wearing a brown Jedi robe on the Star Forge when I fought her, and then be wearing the robe I made all colored and everything when your character walks out of the elevator?

RobQel-Droma
10-31-2005, 03:02 PM
Well, I went back over it, and made some changes, because I thought some things were wrong. Are the file names supposed to be this?:

PFBI02.tpc
PMBI02.tpc
g_a_jedirobe02.uti
ia_jedirobe002.uti (I think it is uti, I can't remember)

I loaded a game but it was no different, and Bastila is wearing it at the end like I said, but I put the robe into a earlier game and I am hoping that it will work, I haven't tried it yet. By the way, there are no Exar Kun's robes in the game, are there? Because I downloaded something and all of a sudden I found them after Korriban, and now when I was making changes to the robe I am making, the icon of the Kun robes dissappears and just becomes this white square.

deathdisco
10-31-2005, 03:33 PM
Check this line in the uti file:
TextureVar [BYTE] = 2

Prime
10-31-2005, 04:28 PM
Check this line in the uti file:
TextureVar [BYTE] = 2Yes, this is the important number. If you are looking to replace an existing robe, this number should be the same, and the texture number needs to align with this one.

General Kenobi
10-31-2005, 04:48 PM
I'm unclear as to your problem. If your doing a graphic edit and a uti edit all you need do is extract the male or female version (doesn't matter) of the robes .tga file and the uti file.

If your simply replacing the in game robe with the "look" only and not special stats and the like the tga's are all you need.

If your replacing or adding "stats" to the robe you'll need the uti as well to edit the properties.

When you extracted the originals (are you SURE they are the right tga's? not another robes?) it names them for you. If you want to make sure they will work just DONT "rename" or "name" them at all. Simply open it up, edit the graphic file, flatten image and save it. It should ask you to replace your copy you extracted. Also make sure to save it as a 32-bit tga only and no other. Problems can occur if you do.

If all else fails just extract the originals again and open up your edit tga's in a window next to the original and drag and drop your flattened file onto the "new" original you extracted, flatten and save it.

Make sure if you use the female change the F to an M and save a copy for the male or vice versa.

As for the sometimes it shows up on Bastila sometimes it doesn't; maybe it's sorta like Bao-Dur's "flub" in his edits if you have any installed for TSL. Bao can be edited to another character BUT when you crash on Telos surface in the polar region he's out cold and he reverts to his original look. Odd but it happens and sorta sounds like your problem. ;)

Hope that helps, :thumbsup:

:ben:
General Kenobi

Mono_Giganto
10-31-2005, 05:07 PM
Pretty sure the "incomplete change" there has to do with multiple UTC's being used for Bao-Dur/Bastila. One in the party, and one or several when they're just NPCs. So when you edit something, it may just change for that one UTC, but when the character is using a different UTC in game it won't show.

RobQel-Droma
10-31-2005, 05:39 PM
So I suppose that means that I shouldn't worry about it? Because for some reason now, Bastila keeps showing up in her underwear when she should be in her clothes. I wouldn't know whether this is because of what I am trying to do, or because of something I tried to do before. Not only that, but the Exar Kun robes are now just plain bright white.

I guess I will try to do what you suggested.

General Kenobi
10-31-2005, 05:46 PM
I wouldn't give up. ;) I'd try to find the other .uti's if there in there. I've only seen one for say Bao but doesn't mean there isn't more than one. Just the only one I've messed with. Same might be true of Bastila in KOTOR I.

I'd keep it up till you figure it out, BUT that's just how my lil' head operates. :)

Do you have Holowan Plugin installed? I'm not saying its the problem BUT it does radically alter most of the "clothes" in the game. More to the point it points default clothes, robes, etc. to newer and in most all cases cooler versions or looks.

I'd check in your main override folder or in your sub folders inside override (if any) to see if you have "conflicts." You could have tried to edit it 2 months ago and forgot it was in there sort of thing. Prob. not your issue but worth a check to make sure.

:ben:
General Kenobi