PDA

View Full Version : Legal Install Won't Launch "Required Security Module..." error


Darth Evader
11-05-2005, 12:49 PM
I bought the CD-ROM version of Battlefront II last night at Media Play. The game installed fine, but when I try to launch it I get an error saying "A required security module can not be activated. This program can not be executed."

I have the original Disc 1 CD in the installation drive and I am still getting this error. I do not have any drive emulation software installed on my PC.

Does anyone know of a way that I can get this to work? Phone tech support isn't open on the weekend otherwise I would call Lucasarts.

master_skywalke
11-05-2005, 12:57 PM
1) locate the battlefrontII.exe then right click mousebutton on it
2) select properties and click compatibility Tab
3) Tick "run this program in compatibilty mode for: and select windows 2000
4) click apply and ok
5) run game and enjoy :D

Darth Evader
11-05-2005, 01:01 PM
That worked. Has anyone actually looked into the reason why we have to turn on Windows 2000 compatability mode? What is wrong with my Windows XP that prevents it from loading?

master_skywalke
11-05-2005, 02:16 PM
That worked. Has anyone actually looked into the reason why we have to turn on Windows 2000 compatability mode? What is wrong with my Windows XP that prevents it from loading?
It only seems to happen with Intel P4 Processors over 3 Ghz. I never had that problem with my AMD 64 3400+.

Darth Evader
11-05-2005, 02:20 PM
Looks like I may be the first exception because I have an AMD Athlon XP 3200+ Barton based PC.

-Asus A7N8X-E Deluxe motherboard
-Athlon XP 3200+ Barton
-1 GB Corsair 3200 RAM
-160 GB SATA hard drive

Poly Salama
11-07-2005, 02:14 PM
doesn't work with me. i have done the thing with compatibility but still the error shows up...i have:
-p4 lga775 3,4 GHz processor
-nvidia 7800 gtx card
-1 Gb corsair 533MHz ram
-gigabyte 955x royal motherboard
-250 Gb WD sata hdd

does anybody have a clue what's wrong?

zerted
11-07-2005, 06:53 PM
Users, this is a software error not hardware. It has nothing to do with your computer hardware so stop posting it.
My best guess for the cause is the way Windows does memory protection to prevent buffer overflows (look it up online) or how SWBF2 access some system files. Depending on your Windows patch versions, these are handled differently. SWBF2 isn't coded correctly (according to Microsoft's messed up standards, but thats another issue). SWBF2 tries to do something thats aganist Windows' new security measures, so Windows refuses and terminats the program. When you tell Windows to run a program in a compatability mode, you are telling it that the program, SWBF2, isn't coded for these new security checks (among other things). Windows will then not preform these checks on SWBF2 and the game will run.

Poly Salama
11-08-2005, 06:24 AM
hey
i've fixed the problem. i just uninstalled antiblaxx and hide the emulated drives with sr7

Bad.Shooter
11-28-2005, 07:38 AM
Hi, i have the same problem of the required security Module, so i tried the Launch Analisys thing to see what's going on.
The problem, noww, is that when i try the Launch Analisys, it return to me an error message saying:
binkw32.dll not found.

So, what's the story? Is the installer defective while instlling ALL the component needed?

EDIT: beat me, i tried to Launch the Analisys on the exe in my dvd drive instead his proper installed folder... ^^'
Just sent the log via mail.

zerted
11-28-2005, 12:56 PM
For the security module pproblem, lanch the game in Windows 2000 combatility mode. If you have any virtural drives, you should install sr7, hide the drives, then close sr7 before running the game.

Binkw32.dll should be in your GameData folder. Check to make sure it is. If it is missing, reinstall the game. If its not there after you reinstall, complain to tech support.

gundam111
11-14-2006, 12:55 AM
hi, I have a problem, I try to launch the game, but it say required secuity module