PDA

View Full Version : Very probable mod issue *possible spoilers*


MyPonyJim
11-09-2005, 01:04 AM
I'm not entirely sure where this question should be posted (I some how manage to pick the wrong spot quite often) - so if that's the case, all I need to know is where best to put it and I'll gladly move it there.

Here's the issue (whether it needs to be moved or not):

I'm on the Star Forge and I've reached the room where you run into Malak. He kills the two jedi with him, then locks you into the big room where all the Star Forge robots attack you until you reprogram their computers. Unfortunately...this whole scene isn't working right. I enter the large room and head for the door which Malak is behind. Malak dialogue begins before I even open the door and when I DO open the door, there Malak is with the two very live jedi - totally untriggered and passive. They just stand there. They can't be triggered and I can't get passed them to the elevator. I've replayed the level and reloaded the game and it stays the same.

Here's the thing: I do have a few mods installed to KOTOR I and one of them is most likely causing the problem I'm having. What I'm wondering is...is there a way to trigger the plot point that's not working right with the console, maybe? Or a way to bypass it? Or am I pretty much just left with taking out the mods until the problem goes away?

Thanks in advance...even if I've flubbed up my posting location again. ^_^

-MPJ

Darth333
11-09-2005, 01:08 AM
What *.utc files do you have in your override folder? Sounds like an issue where the author edited a non-unique .utc file.

MyPonyJim
11-09-2005, 01:14 AM
Hm. There's "p_bastila.utc" and "unk44_evilbast.utc".

Both were added by the Bastila's Revelation Robes mod.

Darth333
11-09-2005, 01:19 AM
that's all? Then the problem is somewhere else.

Could you tell us which mods you have installed?

MyPonyJim
11-09-2005, 01:25 AM
I have:

~Bastiala's Revelation Robes
~Feminine Revan mod that alters Revan's robes to look a little more ladylike if you're playing a female
~2 Altered Endings (Turn Malak LS - Turn Carth DS) <-- given that this one has the most scripting, my guess is that this is the likeliest culprit (though I'll be sad if it is 'cause I really liked the idea).

And that's all of them.

Kristy Kistic
11-09-2005, 02:33 AM
Remove k_sta_darthmalak.dlg from the override folder. This will probably fix the issue. The scene I edited was contained in 2 different dialog files and although my game never called this dialog file I edited it anyway - since its contained in both dialogs I thought it may be possible to get called from this one under certain conditions. (Whatever those might be.)

Since the game never called this dialog for me, I never was able to test it. I just placed the same exact things from the other file (sta_firstjedi_co.dlg) into this one.

I just tested this area you refer to and it began the dialog from later on (the one I edited.) Not sure why at the moment, but removing the dialog file solved the issue for me and it did work as expected.

IF later on the option to turn Malak doesn't appear, then it could be that this particular dialog file is getting called.

Sorry about that :)

MyPonyJim
11-09-2005, 03:09 AM
That did the trick! And now I have my very own Evil Carth. ^_^

Thanks for that, Kristy!

And thanks to Darth333 for the troubleshooting.

Kristy Kistic
11-09-2005, 03:15 AM
I'm glad it worked and I'm glad you pointed out a bug I was unaware of, so thanks to you, too! :)