PDA

View Full Version : XWA runs SLOOOOOOOOOOOW


00nbluez
06-10-2001, 10:34 PM
I have a P4 1.4 GHz, 32mb GeForce2 GTS, and 128Mb of RAM. I close as many applications as I can before running XWA and even run it at 640x480 with all the options off, but the game is still slow!!! I can't believe this- is there a problem with XWA and the GeForce2 GTS?

Please help!!! Thanks.

Rogue15
06-12-2001, 09:09 PM
have you tried switching from software mode to hardware mode in options when you put the cd in? I think that's what i did and i was blown away by the superb graphics, which are far better than x-wing and tie fighter.

Fondas
06-13-2001, 04:58 AM
even in software mode , it should run smoothly...

anyway, try to switch to hardware mode, your option should read "primary display driver"

Rogue15
06-13-2001, 03:08 PM
yeah that's what i was meaning to say. you should also try putting the starfield density to low, and messing around with the sound settings.

00nbluez
06-14-2001, 07:02 PM
Yeah, it's on Primary Display Driver and also the option for 3d acceleration is turned on... Even if I turn off all the options it gets really slow after a few missions, even if the mission itself doesn't have that many objects in it. I guess it's time for more RAM.

Uriel Shadowstiehl
06-14-2001, 07:46 PM
RAM most likely will not solve your problem - I'm currently using 128MB with an Athlon 550MHz and a 32MB GeForce2 MX graphics card and I experience no slowdowns.

If you are using antivirus software, Norton Utilities, McAfee Nuts & Bolts, or any other "system optimizing software" they may be interfering with how your computer handles its resources, and should be disabled (in the case of the antivirus) or uninstalled (in the case of system optimizing software). You can follow the following steps to make sure there are no additional programs running that are unnecessary:

1) press start, run and type in MSCONFIG at the prompt, then click on the Ok button.

2) You should get a window that says MSCONFIG pop up. Under the first tab (General) pick "Selective Startup" from the list of three choices. This should give you some additional check mark boxes below this option. If the boxes next to config.sys and autoexec.bat have check marks in them, remove the check marks (note that this will stop any software that loads on bootup from loading. A system with your performance should not need any memory managers or other utilities to be loaded at this time).

3) Click on the last tab marked "Startup". If you are running Windows 98, the only programs that are necessary to have check marks next to them on a desktop system are ScanRegistry and SystemTray. Everything else can be unchecked. If you are running Windows Millenium there are a few other programs that load that may be necessary for your system to run normally - it may require some trial and error to determine which ones these are.

4) Press the OK button at the bottom of the utility and let your computer restart. If for some reason your system will only boot in safe mode, run MSCONFIG again and turn everything back on (pick Normal Startup from the list of three choices). If your system starts normally you should be able to press CTRL-ALT-DEL and only see SYSTRAY and EXPLORER running (and/or any other programs you decided to leave running). If there are other programs running that you did not opt to leave in place they may automatically restore themselves in the MSCONFIG utility - in which case the only way to prevent them from loading is to uninstall them.

5) Open your control panel, and double-click on the icon labeled System. You should get a window pop up that is labeled System Properties. Click on the tab marked "Device Manager", and then click on the + next to Disk Drives. Highlight your hard drive and click on Properties, and then select the "Settings" tab. Make sure there is a check mark in the box next to DMA in this window, the press the OK button. Do the same as the above for your CDROM drive. Finally select the last tab in the System Properties window labeled "Performance" and click on the "File System" button. Change "Typical Role of this Computer" to Network Server, then click ok to close the File System Properties window, and OK again to close the System Properties window. Let your computer restart. The above changes will help your system run the hard drives & CD-ROM more efficiently and therefore improve performance somewhat.

6) Download and install the latest drivers for everything in your computer including mainboard, video card, sound card and possibly even modem or network adapter. In addition use the Windows Update utility to update Windows with any available fixes or DirectX related upgrades.

If you follow the above steps, and still have problems with performance, it is most likely being caused by something physically wrong with your computer, because you should be able to have everything running at its optimal settings with few if any performance issues. Good luck.


------------------
Uriel Shadowstiehl

clintruin
06-15-2001, 04:59 AM
I'm in the same boat. Duron 750, 256mb of PC133 ram, Win2k SP2, Geforce2mx with 32mb. The game is appallingly slow in 3d mode. I've tried 6.xx, 7.xx and the new 12.41 drivers, and the problem still remains. I've just about given up at this point after playing with every tweaking option I can think of, both in the driver controls and the 3d options inside the game.

I've also gone through exactly the same process on my other machine which is a Duron 650 with 192mb of ram and a PCI TNT1 card, also Win2k SP2. The game is the same incredibly slow speed on both machines. After playing with software mode briefly I getting the impression that it's a wee bit faster _without_ using 3d acceleration.

To elaborate a little further just in case our defintions of 'fast' differ: if the starfield is moving in 1-2cm jumps whenever I'm moving the ship around, that's 'not fast'. If the game literally goes down to 2fps when I look at a large in-game object for the first time [looking behind me in the virtual cockpit, for example], that is also 'not fast'. This situation is not improved by kicking down the resolution or detail options. Other D3D games like Unreal Tournament, Ground Control, etc, work just fine.

Does anyone have this game running smoothly in 2k with Nvidia hardware? The warning in the readme file about using detonator series drivers [hint: there ain't any other kind for Windows 2000] is something that I take as a bit of a bad sign.

If you do have it running well, please check the driver revision you're running and the options you have enabled in the nvidia control applet so I can try to replicate it here. If you could email me at iprefer@hotmail.com that would be wonderful too.

Thanks.

clintruin
06-15-2001, 05:21 AM
Just for more info: I'm running DX8a and have the 2.02 patch installed.

clintruin
06-20-2001, 08:15 AM
OK, now I'm just a little pissed.

Today I installed Win98SE on my other machine [duron 650] and took home a friends old 3DFX Banshee card just to see if XWA would still behave badly. I figured it would be worth a shot just to see if it would make any difference, clean system, different graphics card that's probably closer to what they were testing on at the time, etc, etc..

I am starting to think that perhaps something has gone badly wrong in Totally's attempts to recycle an engine that was already groaning under their little 3d-card support hack for XVsT. This thing is still far from fast - maybe a slight improvement [!] but there is literally only a few frames in it between the GF2MX and the older Banshee card. I can seriously turn 4X anti aliasing on on my GF2MX box at 1024x768@16 and it's really no slower than it is without any AA. It's looking like something is simply screwed at a fairly basic level in XWA. I don't know what it might be - maybe they cap FPS to a certain limit to avoid cheating in multiplayer, maybe they just don't cache anything effectively at all on the graphics card, whatever. It's really not my job as someone who just paid Lucas/Totally a wad of cash for the game to debug it.

I'm just wondering if there's some particular reason that a box that can run Q3A in 1024x768@32bit quite happily would be choking on an old game at 640x480 that's using palletised 8-bit textures. This is on a machine that has literally 4 times the recommended RAM for maximum details and a 3D card more powerful than anything that was on the drawing board at the time of XWA's release. Out of it being my fault or Totally's fault, I'm just about willing to point the finger at them now.

So anyhow. Now that it looks like the game does have some kind of problem running well on a recent machine - given the other posts on this board as well as my own little play with reinstalling an entire machine from scratch just to see if it would make any difference - what do you think the chances might be of seeing a fix for this released at some point? None? Next to none? Should I just sit in the corner and eat a **** sandwich instead?

Funny thing is that during reinstalling my entire ******* machine just to play with XWA I got all retro and dug out GLQuake and played it on the MX/2k box. One of the first 3D accellerated games ever and the thing now runs at around 54 billion FPS on a recent machine if you do a timedemo. Some developers are capable of getting it right first time I guess....

00nbluez
06-23-2001, 05:28 AM
clintruin: WOW that's a lot of work to go through to try to get XWA to run smoothly... I'm sorry to hear that you weren't very successful though. I was the original poster, and I haven't been able to find a fix either. I haven't tried Uriel Shadowstiehl's suggestions, but I will... Thanks Uriel for your detailed reply!!! http://www.xwingalliance.com/forums/smile.gif

I was able to beat the game despite the less than satisfying frame rate, so I'm not that desperate anymore http://www.xwingalliance.com/forums/biggrin.gif

garyah99
06-27-2001, 04:40 PM
My only problems with frame rate was when I had MIP mapping turned on. Otherwise, I have a AMD K6-2 450m Voodoo3, and 128 megs rAM and it runs quite well.