PDA

View Full Version : a build bug and play bug


Vruki Salet
12-14-2005, 01:13 PM
First, the CVS tree won't build. I got it about 8-10 hours ago and tried to build it in visual studio, with DEBUG. The error is:

unresolved external symbol _CG_LoadHolsterData referenced in function _CG_LoadClientInfo

I lamely tried to fix it but I don't know enough, even though I found the reference. Of course commenting out the line "CG_LoadHolsterData(ci);" in
CG_LoadClientInfo in cg_players.c fixes it but I guess that would wreck holstering...though I wouldn't know yet cuz...

When I load up ojp_enhanced_002b8 I can't get any saber. Just melee. That goes for the precompiled one I dowloaded and the my own compile after I commented out that line I mentioned above.

Any ideas? Need more info?

edit - MORE INFO:

The linker errors are LNK2019 and LNK1120.

razorace
12-14-2005, 03:18 PM
Hi, sorry about that. I just didn't update the project file after adding the new holster code files.

Its updated now. Update your code and try again.

Vruki Salet
12-14-2005, 05:46 PM
OK it builds now. I'll check it later for the saber issue. Thanks.

razorace
12-14-2005, 06:01 PM
what do you mean by saber issue?

Vruki Salet
12-15-2005, 06:15 AM
They didn't show up. Now they do but I think the fix was there was something wrong with my server.cfg file. Maybe it was too minimal, as it hardly had anything in it not even a gametype. Oops. Now it's OK.

Now how do I get me to holster my saber and guns?

razorace
12-15-2005, 12:47 PM
didn't show up? You mean when you holster it or what? It's probably because the sabers are normally holstered on the front of your player's thighs. You can't really see that from the back of your player.

Vruki Salet
12-16-2005, 05:44 AM
I meant it didn't show as in I had no WP_SABER at all, just WP_MELEE, whether I tried to give me a saber from the UI or the console. It works now. The only difference I can think of is now my server.cfg defines a gametype and sets disabled weapons to 0 and sets a few other misc cvars. Before the cfg was blank except for loading the map.

As far as the sabers holstering on the hip, thanks for the tip. I'll turn around and look again.

razorace
12-16-2005, 06:36 AM
hmmm, I'm not sure about that one. I haven't used Enhanced in a while since making all those Basic code changes. It's possible that some of the changes have had weird effects in the Enhanced code.