PDA

View Full Version : TSL: This isn't fair!


StaffSaberist
12-20-2005, 09:21 PM
I hope this stupid thing works this time, this is attempt #3 to post this...

I have always had problems in KotOR I's Dantooine after upgrading my video card from 64 MB to 256 MB. I got so tired of all my games running sluggish that I have actually put together a very nice system. A fantastic rig. And yet... I still have unplayability, only on Dantooine. (I also ran into a little trouble in the Jekk'Jekk Tarr, but it wasn't severe.) I know about the Disable frame vertex thing in the swkotor2.ini, but you'd think I would not need to.

Here are the specs for my $1,000 machine:

OS: Windows XP Service Pack 2
CPU: AMD Athlon 64 processor 3700+, MMX, 3DNow, ~2.2 GHz.

(I should mention that Athlons like this are quite efficient, and this particular CPU can match an Intel CPU with ~3 GHz.)

Memory: 1024 MB RAM
DirectX version: 9.0c
Video card: nVidia GeForce 6600 with 256 MB vRAM

(I realize that Ati Radeons are more popular with the gaming community. However, they cite serious problems with nVidia that I have never had. Curious.)

I play with these settings:

Resolution: 1024 X 768
Texture: High
Shadows: Off
Grass: Off
Anisitropy: Off (never saw a real difference)
Anti-Aliasing: Off (again, never saw a difference. May as well save framerate)

And I have very smooth gameplay - except for that pain in the arse, Dantooine. Adding that line to swkotor2.ini does help in Dantooine, but causes issues elsewhere.

I remember last time I complained about this. A user told me that he left the line in swkotor2.ini all game. But, for me it has an interesting effect: It appears to strike a median framerate and apply it throughout the entire game. Good for Dantooine, bad for anywhere else. It is quite irritating to put the line in every time I visit Dantooine, and take it out when I leave. But it seems that my computer is playing cruel tricks on me by doing that median framerate thing. I swear I'm not making this up.

This is insane. I spent a lot of money on this machine, and not just for KotOR. It will be excellent for a lot of games in the future. And yet, Dantooine still gives me problems out the ion engine. (Crud, listening to Atton too long. ;))

[Awareness] This leaves me with an interesting question: What makes this planet unique to have a bad framerate? The layout of the walls and hills is very similar to Telos' surface, so that can't be it. It can't be the grasses, for the same reason. And it certainly cannot be the trees. Flora is seen throughout the game and causes no problems. I don't think it's the amount of polygons per area, either: There are wide open spaces like that elsewhere. It is most perplexing. What has to be rendered there to do this to even my system, which is the envy of more than a few people in the neighborhood?

I suppose the question is fairly obvious by now, but... what can I do to make a permanent fix to this problem without causing problems or other inconveniences?

Emperor Devon
12-20-2005, 09:30 PM
Odd. Did you spell "Disable Vertex Buffer Objects=1" correctly? Also, you're not supposed to include the quotes.

On a side note, did you enable antisitropy and anti-aliasing together? I've found that there's not much of a difference unless you enable them both. It can make the graphics look much better.

StaffSaberist
12-20-2005, 10:25 PM
Odd. Did you spell "Disable Vertex Buffer Objects=1" correctly? Also, you're not supposed to include the quotes.

Yes, spelled correctly without the quotes. I Copied and pasted directly into the .ini file.

On a side note, did you enable antisitropy and anti-aliasing together? I've found that there's not much of a difference unless you enable them both. It can make the graphics look much better.

I'm not sure. I'll try it - but not on Dantooine! That's not very accurate as far as checking framerate goes, as I've discovered.

Darth333
12-21-2005, 02:44 AM
Did you updated your drivers?

StaffSaberist
12-21-2005, 09:57 AM
First thing I do when I get a video card. :)

StaffSaberist
12-21-2005, 07:23 PM
Update: I went to nVidia's site and got drivers again. The planet has good, actually excellent, framerate for a few steps. Then... KAPUT! It acts like my card is a 10 MB board. :(

SpaceAlex
12-21-2005, 11:12 PM
The only drivers that would make Dantooine playable were the 67.03 (6800 Ultra here), until i tried the 85.95. If you try the 67.03 (get them from www.guru3d.com), the game might run without any problems. Right now i'm using the 85.95 with the "Disable Vertex Buffer Objects=1", and the game's running excellent.

Oh, and who says Radeons are more popular? :p

StaffSaberist
12-21-2005, 11:34 PM
I've been trying to find it, but I have too long a list to look at. Where exactly did you get 67.03 on there?

And BTW... would those ATI Radeon fixes cause problems with an nVidia?

RevanA4
12-22-2005, 04:14 PM
I've been trying to find it, but I have too long a list to look at. Where exactly did you get 67.03 on there?

And BTW... would those ATI Radeon fixes cause problems with an nVidia?


hmm I have a 256 geforce 6200 that works fine with the latest drivers btw do you happen to have v-sync off?

I turned it off and bam problems straight away

StaffSaberist
12-22-2005, 04:40 PM
As a matter of fact, I did. But I switched it on. I had gotten past Dantooine in my game, but I had a save in front of the crystal caves. I am agitated to report that I still have problems, in fact it got even SLOWER.

I still am looking for 67.03 - actually 85.95 - but can't seem to locate it. =/ I found 82.12, and I'll try that out. With my current driver:

Framerate on other planets:

1 2 3 4 5
Very Good

On Dantooine:

1 2 3 4 5
Very Poor

On Dantooine (Frame Disable thing):

1 2 3 4 5
Average

Det. Bart Lasiter
12-22-2005, 05:29 PM
Well, it should be "DisableVertexBufferObjects=1", with no spaces. So try that, the 85.95 drivers, and maybe some overclocking, but some slowdown is unavoidable :(

StaffSaberist
12-22-2005, 09:07 PM
But it doesn't work without spaces. Tested it on Khoonda Plains. =/

SpaceAlex
12-23-2005, 05:53 PM
Here's the list of all the drivers avaible: http://downloads.guru3d.com/download.php?id=10

And here's a link pointing directly to 67.03: http://downloads.guru3d.com/download.php?det=920. Note that although this driver is good, it WILL make other games run slower than the latest drivers, although not much. I still don't understand how the "disable frame buffer" fix doesn't work for you. Try to use only small letters, maybe?

StaffSaberist
12-23-2005, 07:25 PM
It does work with the spaces, enough that it is playable. But the problem I have is that while it helps pn Dantooine, it hinders on everything else. D/l complete. Now I install.

And I don't have games larger than this. I think I'll be fine.

StaffSaberist
12-24-2005, 11:28 AM
YEEEESSSSSS!!!!!! It isn't perfect, but it works... and Disable Vertex Buffer Objects=0.

It made Dantooine playable with:

1024 X 768 res
High Textures
Anti-Alias and Anisitropy at 4X (I like shiny!)
Frame Buffer Efffects ON
Shadows and Grass OFF but I will play with it later.
V-Sync is ON

It was a real headache to get it installed, but it works!

Det. Bart Lasiter
12-24-2005, 11:06 PM
^^^^
Hmmmm, it's with no spaces in the swkotor.ini that is given with the 1.03 game patch. Odd.

StaffSaberist
12-25-2005, 12:45 AM
Well, I'm not complaining. And it's off anyhow. I am OK so long as I don't look directly at Khoonda. If I don't the framerate is excellent. :)