PDA

View Full Version : Weird mouse problem


Smoot
01-08-2006, 12:44 PM
I recently installed SWBF2 on my PC (Dell Dimension 8400, P4 3.2 GHz w/ HT enabled, 1GB PC-4200 DDR2 RAM, 160 GB HD with 50 GB free, ATI Radeon X700 Pro 256 MB video card with Catalyst 5.11 drivers installed, etc.), and at first, things were working fine. However, a day or two after installation, I noticed that my mouse (a Logitech iFeel Mouseman with Mouseware drivers 9.79.1 installed fresh from Logitech.com) was hyper-responsive, and if I hovered the mouse cursor over any of the buttons in the game, it would automatically select whatever I held it over. I have uninstalled and reinstalled this game 3 times now from scratch, uninstalled Logitech Mouseman drivers, down-clocked my ATI card, but all to no avail. The hyperactive mouse problem now occurs immediately, all the time. Also, by "default", some of the keyboard/mouse buttons become "unmapped" mainly those dealing with turning left/right and strafing left/right. I click the "reset to defaults", but it doesn't work. In the CONTROL options in the game, mouse sensitivity is set at its default level (50 I think), but I still have the same problems with the game if I turn it down.

This really is an annoying problem, that I don't have with any other games (and not SWBF1, which ran fine), and my mouse settings are all default settings. I have not tried another mouse, but without the Logitech-specific drivers installed, it should behave as an ordinary mouse, correct? Any thoughts why this could be happening? I sent my problem to Lucasarts, but I'd be shocked to either hear from them or have them solve the problem.

I'm really perplexed by the whole problem, and it really is ruining what looks to be a decent game. I can carefully get in and play the game, just anytime I pause it with ESC or mouse click any options, it's a royal pain with the mouse hypersensitivity.


Thanks for any help/advice in advance.

zerted
01-08-2006, 05:46 PM
Default, there is nothing mapped to turn left/right. Without the other drivers, your mouse should be like any other mouse. This is only happening in SWBF2 and not Windows or other programs correct?

Smoot
01-08-2006, 07:38 PM
That's correct. No other game or program has any issues whatsoever.

I installed a regular ole 3-button scroll mouse today connected to the PS2 port, yet despite this effort, the game still behaved the same way with the old-style mouse. To troubleshoot further, I moved my SB Audigy 2 card to the last PCI slot in my Dell, further away from my ATI X700 PRO PCI-E card, just in case the slight chance there was any interference. Unfortunately, the problem is consistent and still there.

I also found another screw-up in the button mappings with all of these "mouse issues." When getting in a turret, I can't use the mouse to move it at all. This wasn't happening when I first installed the game, but it is now. I can still play the game, and use most of the functionality, but issue like the turret and hypersensitive mouse make me wonder WTF?

I really am at a loss. I keep wondering if any other background programs are causing the problem. I run Symantec Corp. Antivirus and Zonealarm Pro Security Suite, in addition to having two UPS programs in the background. Because I have also found that if I increase the volume when in the game using my Microsoft Digital Media Pro keyboard, I can lock the game up, I'm wondering if there are any USB issues compounding the problem.

It royally pisses me off that this game, and this game alone, has issues. Looks like a rushed product to me.

zerted
01-09-2006, 01:06 PM
IF you spawed mice, then something else is causing the problem. I noticed you have HT enabled. SWBF2 has problems with dual core processors and to a lesser extent, HT processors. Try disableing HT or setting the game to use only one processor. If that doesn't work, try updating all your drivers and reinstalling any current ones.

Smoot
01-11-2006, 10:11 PM
Well, I disabled HT, rebooted, and the game is still messed up w/ the mouse issue. All my drivers (video, mouse, keyboard, sound, mobo, etc.) are the latest and greatest.

zerted
01-12-2006, 01:43 AM
LucasArts tech support has a few things with mouse problems. Check out their site ( http://yodashelpdesk.lucasarts.com/os.asp?sid=014332060112129021124069&pid=1459&pnm=Star+Wars+Battlefront%A9+II ) then file a report if nothing there works. Keep a lookout for the upcoming patch. I can't think of anything else which might be causing the problem. Don't forget to post if you fix the problem. Good luck.

Smoot
01-12-2006, 03:39 PM
Thanks, zerted, for your repeated attempts to help me through this one. I appreciate it.

Why reeks is that I submitted a case to Lucasarts Tech Support on Saturday, and I've heard nothing back from them (or Pandemic). It is gets corrected, I'll post back.

Smoot
01-15-2006, 01:43 PM
Well I MAY have fixed my problem, though in a way I never imagined. Just for fun, I found the NO CD patch for the battlefrontII.exe and the launcher exe, and after applying them (and backing up my old EXE files), the game works perfectly. This is odd, given that I'm installing off the original 4 CD's, and everytime that I've uninstalled I've cleaned the hard drives and the registry.

Oh well, solutions sometimes happen in the strangest of ways. It's also nice not to have to put the darn CD in all the time and have my wife or kids risk tearing it up. See, Lucas Arts, not everyone out there is a pirate!

Smoot
01-15-2006, 03:31 PM
Jeesh, looks like I posted too soon. After two days of playing the game the way it is supposed to be using the NO CD patch, it started acting up again today, unprovoked, with the mouse hypersensitivity returning. I think my system is haunted.

I'll wait for the SWBFII patch to come out in hope that it either directly or indirectly fixes the problem.

wxboss
01-22-2006, 06:29 AM
I wouldn't worry too much Smoot about it being your system. I've had many strange issues with this game, one of them being that it completely disabled my mouse at one point and another time it disabled my keyboard. Both times I went into Device Manager and found the drivers completely missing. Only a system reboot fixed the problem.

I, too, have all the latest drivers and have tried every solution offered and I still get game crashes that lock up my pc.

I hope this patch fixes all this stuff.

Smoot
01-23-2006, 12:31 PM
Well, I solved my problem through a LOT of trial and error troubleshooting. Seems that my Energizer battery backup program, when resident in memory, is causing the hypersensitivity. If I disable the program, the game runs fine. If it's loaded, major problems.

So, I just disable the Energizer program when I want to play SWBF2. It's still annoying, and a bug, that this is the only game or program that has this problem. Hopefully, a patch might fix this issue . . . indirectly, I'm sure.