PDA

View Full Version : Need help with non-firing turrets for my ship


TK421
09-27-2000, 04:32 PM
Can someone help me out with this problem, it's really starting to piss me off.

I added the upper weapons array to my new Miranda model (see pic), and while I was at it decided to add the turrets to simulate the phaser banks. The idea was to have three turrets topside and three underneath, with little pieces of the main hull shaped like a hood to limit their field of fire so the ship wouldn't be too powerful but still have full weapons coverage (only 1 gun can fire to port, 2 to forward, etc), as without this at least 3 guns top or bottom would be able to fire on a target.

As a test I equipped my crappy Stargazer model with three turrets (just plain cubed meshes) that sat above the hull (not touching) to see if I could get multiple turrets working - no problem once I figured out the settings in MxvtED, worked fine and won a battle against 3 Ace-quality Bird of Prey's without a scratch.

So I say, it works fine. And proceeded to create 6 extremely small (you have to REALLY zoom in to see them) mesh's above and underneath the saucer section of my new Miranda to act as Phaser turrets.

The damn things wont fire at anything! Not from any range or angle of attack. I've since removed the hoods that limit the field of fire (thinking they were the problem) but still not working. I've got the working Stargazer in Slot #34 and the new Miranda in #35 to see them work side by side, with the exact same settings in MxvtED but still the Miranda will not fire it's turret lasers under any circumstances.

My Miranda-class ship is ready for download, once I get this problem fixed.

I've re-read all the ACE Guides and snippets of info I can find, but none of it really helps.

http://www.ozemail.com.au/~richtersg/pics/mirandanew.jpg

------------------
"No no son, you gotta hit 'em in the head so they stay down, like this! *WHACK*"
TK's OPT Factory (http://www.ozemail.com/~richtersg/)

[This message has been edited by TK421 (edited September 27, 2000).]