PDA

View Full Version : droids can't steal any new technology


TheosTheon
02-23-2006, 07:01 PM
before entering the mission on kashyyk, i stole all available tech with r2d2 & c3po. now that i finished the mission, i heard the notice, that new tech should be available(and would be nice to have).
however the "steal" slot doesn't appear anymore for the the droids.
Now I'm right before that mission to escort cpt. antilles.

There are no other units in my droid-fleet(swapped around with them, they also are still stealthed).
I tried killing the droids.
I tried loaded a safegame prior to kashyyk.

Is this a known issue(i searched the forums & msn/google, couldn't find anything tho), and/or is there any fix available? (i have the german collectors edition, it did automaticly update to 1.2.37908)

vanen22
02-23-2006, 07:03 PM
I ran into that problem also I just ignored it

TheosTheon
02-23-2006, 07:06 PM
will it work again later in the game? or never?
i DO want tech 4 stuff...

vanen22
02-23-2006, 07:27 PM
it started working for me again in later missions, It appeared has though when it said new tech avail it was a lie :P

walpurgisng
02-24-2006, 01:52 AM
I believe when u steal tech, u have to select the new tech that you want stolen right away. If you dont, it gets screwed up.

TheosTheon
02-24-2006, 11:44 AM
if you don't steal right away, you would have to resend your droids.

in my case, i depleted the tech, had everything at level 3, would want level 4 now...