PDA

View Full Version : Need some help opening a 2da


shadowriath
03-03-2006, 06:25 AM
slenderbodyf_v11's (Slender body for female v.1.1) appearance.2DA. I have tried redownloading zip file for it and still is unable to be opened. I have even tried opening it with other 2da viewers/editors still unable to be opened. One of the editors I tried was the add-on made for Excel which would not care how large the file was or it's boundry limits....it came up with an error "Bad header".

Due to my issues of careing C++ run time errors while playing if I have the KoToR tool installed I just install it to look/work on a 2da then uninstall it. Unless someone can help me out with that issue.

stoffe
03-03-2006, 07:26 AM
slenderbodyf_v11's (Slender body for female v.1.1) appearance.2DA.

For some reason, the 2DA file included in this Mod is in the old plain text 2DA V2.0 format (used by NWN but still supported, though unused, by KotOR), rather than the new binary 2DA V2.b format that KotOR uses.

While using plain text 2DA files work, they are somewhat slower (and much larger) than their binary counterpart, so I wouldn't recommend it. The format isn't used by the KotOR games for a reason after all. :)

And, as you noticed, the KotOR/TSL modding tools only support the binary format, which may make your file incompatible with some mod installers if you try to install other mods later.

Anyway, if you wish to keep this appearance.2da file as it is an only edit it, any text editor should do the trick.

shadowriath
03-03-2006, 09:02 AM
Lol, no it's not mine. And not useing it at the moment. Was just trying to merge two mods. I do have the NWN 2da editor...can open it with that and merge manualy enter the info into a Kotor2 2da editor.

tk102
03-03-2006, 03:33 PM
As stoffe -mkb- mentioned, some of the the KotOR modding tools (read: mine) don't directly support the v2.0 format. At the time I was developing the Excel 2DA Add-In, I figured v2.0 2DA files could just be read as a text file by Excel (or even Notepad) without the need for my Add-In, so why support them. :)

KSE is another one that has this problem :o