PDA

View Full Version : Can't start LAN game


init6
04-03-2006, 11:45 AM
I'm trying to set up a LAN game between two computers on the same network switch, but when I go to HOST GAME the start game button is greyed out. I can't see the other player in the lobby and under network settings in options, the Internet Address is set to UNKNOWN but the Host address shows my (internal) IP address. I've tried switching off UPnP and my Windows firewall, but nothing makes any difference.

Any ideas?

thanks

kimballkinnison
04-03-2006, 12:03 PM
You need to have selected host game and be on the setup screen before you will appear in the lobby for another machine on the LAN....the other PC should then be able to select the game and join, then the start game button should light up on the host machine.

Mind you there's a chance you'll have issues with loading saved games, but that's a whole different kettle of fish....

init6
04-03-2006, 12:16 PM
That's my problem. When I'm on the host game setup screen then I can't press START GAME to start the game :(

kimballkinnison
04-04-2006, 05:29 AM
And you're sure that the other machine has selected the game and joined? Sorry to be pedantic but this is the same problem we had, the start button was greyed out until the other player had selcted join match then clicked on accept.

init6
04-04-2006, 10:55 AM
Be as pedantic as you like :)

I can't see anyone else in the lobby or any games available to join.

What protocols are needed for LAN games? Is IP enough or do I need IPX or UPnP too?

cheers

isepiq
04-06-2006, 11:37 PM
I am having the same problem:
1. I set up one computer as Host Game
2. I set the other to the lobby
3. The Host never shows up in Lobby???
My kids play other games as LAN with these two computers, but for the life of me I cannot figure out why this one is not working???

Router: D-Link DGL-4300 Gamers Lounge
Network: Hard wired

The start button stays grayed out like the above person's does. :rddance:

popcorn2008
04-07-2006, 11:30 AM
Alright let me see if I can help you guys out.

First of all in the lobby itself do you see all the players (excluding yourself) in the players list? If so try typing a chat message in the box and push enter. Does the message show up on all computers? Do the same from each computer. If one of the computers does not show the message then there is definetely a problem on that computer.

Can you post some screenshots of the lobby with everyone in it? LAN problems can be extremely frustrating so just hang tight and I'll try to help you guys out.

isepiq
04-17-2006, 12:39 AM
Ok, fixed mine. When I completely disabled my software firewall, it worked. So I made an Advanced Rule making the static ip addresses on my two kids computers so they had full access all the time with all protocols. This also fixed several other games where we no longer have to use direct connect, and a couple of other games that we could never get to network.
We do have xp's ipx/netbios installed also by the by.
Hope this can be of help to someone else? :)

red25
05-16-2006, 07:54 PM
I am having a similar problem, only on all games when i try to play LAN.


When both computers are in the lobby, the one with the firewall off, can see the other computer. The computer with the firewall on(this cannot be changed, group settings) cannot see the other computer, even when it hosts a game.

When the Computer without the firewall tries to join a game that the other computer hosts, it is unable to connect. Please help me!


Is there any way around this problem other than shutting off the firewall on the other computer??(it has an exception for all the games trying to be played)

isepiq
05-22-2006, 10:03 PM
In ALL firewalls you need to do all that applies to your computers:

1. If you have a router: Make a special rule to always allow the ip address of your router. This is usally 192.168.0.1 OR 192.168.1.1 depending on the brand of router.
2. Make static IP Addresses (Google if you need to know how) for ALL of your computers. Make a special rule to always ALLOW these IP Addresses.
3. If you have a router: PORT FORWARD the static Ip Addresses for each computer (there is a site named port forward for info on this, use Google).
4. Enable UnplugNplay for Windows. ALSO, if you have a router: check to see if your router has an UnplugNplay option & ENABLE it. Check your firewall for UnplugNplay & make sure it is NOT blocked.

If you do not know the IP Addresses for all computers, UplugNplay may take care of this problem. It helped us.

Hope this can help others. It worked for us. :shads3: