PDA

View Full Version : My Jedi Academy Won't Work!


SomeoneIknow
04-16-2006, 08:53 PM
For some reason, whenever I start Jedi Academy (or Jedi Outcast for the matter), the program slaps me with an error message. It says that it "cannot open GL source" or something to that effect. SO in closing, HELP!

Tinny
04-16-2006, 09:47 PM
Hmm, maybe you have to update vid drivers. I'd try that after updating it with the latest JA patch if you haven't already though which can be found at the bottom of:

http://support.lucasarts.com/patches/jediacademy.htm

SomeoneIknow
04-17-2006, 02:56 AM
Apparently, I already have the patch. It says that I don't need it. Alas I am assailed with the question:"What do I do?"

SomeoneIknow
04-17-2006, 01:03 PM
Here is exactly what the error message says...

GLW_StartOpenGL() - could not load OpenGL subsystem

KyleOfHarpenden
04-17-2006, 02:42 PM
ur missing some game files, OpenGL is what opens the game if u got a m8 ask him 2 send u the files in that folder

SomeoneIknow
04-17-2006, 08:07 PM
How would I get those files? Why am I missing those files in the first place? For two years, those games worked fine until I recently reinstalled windows and tried to reinstall these games.

DarthMuffin
04-18-2006, 04:44 PM
The first thing I would do is try to reinstall the game.

And I remember having a similar error back in JO. I think I corrected it by downloading the latest video card drivers. Did you try that?

dtriniman
04-18-2006, 06:21 PM
OpenGL is a gfx error the last time I checked. Here's a tip when you use a forum: check previous threads to see if any1 has brougt up the same topic so you can get the answer immediately. This is a common error.

http://www.lucasforums.com/showthread.php?t=82406

You should check your gfx card homepage to d/l the latest version drivers and/or tweak your gfx card by going to these places.

For ATI gfx card users:

http://www.tweakguides.com/ATICAT_1.html

and for Nvidia gfx card users:

http://www.tweakguides.com/NVFORCE_1.html

or you can go here:

http://www.omegadrivers.net/

KyleOfHarpenden
05-01-2006, 12:28 PM
my m8z got the same problem im trying 2 help him

neal8929
05-14-2006, 08:29 PM
I had the same problem, but all i remeber is that i searched the problem on the web and downloaded the files.

Crow_Nest
05-15-2006, 06:04 AM
This is a question that has been asked many times on the boards. And the solution is simple, get DirectX 9.0c (http://www.microsoft.com/downloads/details.aspx?familyid=9226A611-62FE-4F61-ABA1-914185249413&displaylang=en) and the latest graphic card drivers for your video card. First you need to know what graphic card are you using, you can check it by running the DirectX Diagnostic tool. Run "dxdiag" under start menu, and click the "Display" tab, there your graphic card name and company would be listed. (If you've noticed, you can see your current DirectX name and version at the front page)

ATI - download Catalyst 6.4 here (https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27)
NVIDIA - download Forceware 84.21 here (http://www.nvidia.com/object/winxp_2k_84.21.html)

Other sites such as www.guru3d.com offers a wider selection of drivers, but I recommend using them if you're an advance user as you'll be able to find beta drivers and some other tweaking softwares that could cause problems to your PC. For starters, just download the latest drivers from ATI or NVIDIA. Check your graphic card to find out which one you are using, if you're not using either one (Intel Extreme or Voodoo 3D FX) then thats too bad. If you're running ATI or NVIDIA and still experience the error even after updating the drivers, it means your graphic card simply does not support OpenGL 1.4 or higher. (Note that Jedi Academy requires OpenGL 1.4, although theres a forum member who claimed he could run JA on his OpenGL 1.3 card)