PDA

View Full Version : Global variables and G0T0's ship - help please?


gund
05-16-2006, 09:44 PM
Edit tk102: This was split from the KSE thread and moved to Holowan

first off, the editor is great, good job.

im having some major issues with the goto's ship level. In a nutshell, i HAVE acquired the shutdown code, have switched all the primary power items to secondary, then i did the 'shutdown power distribution' and got mobbed on the way to the docking hatch by all the bounty hunters. When i get to the door, it says its locked, even tho it was successfully unlocked. Now when i go back to the bridge console, it will NOT let me use the shutdown command. I have tried playing with some of the global variables, and numericals, but no progress, even after resetting the 3 power items to the primary via the global numericals, and then going back into the game and switching them over, to secondary and trying. still nothing...

basically, what i was wondering is if there is anymore detailed info about the different global variables and the numericals that i could find somewhere? ive tried playing with a few to fix the problem, but no luck.

just looking to get this fixed, its rather annoying. btw, if it helps anyone, i *think* the global variables, and numericals for that part of the game fit in the 351NAR_* part,

thanks in advance for any future advice

Darkkender
05-17-2006, 12:05 PM
Unfortunately you would need to tear into the various scripts for that module so that you can determine which variables are set. KSE allows you to change at your hearts content but. However none of us would really be able to say what you need to change off the cuff. I would also say that this particular question is not really a KSE question as much as it is a generic Holowan labs question.

Grindel
05-17-2006, 06:28 PM
Well I don't know how you correct the problem with rewriteing the scripts but I know a quick hack that will work. Downliad the Wereami arm band avalable frome verious mod sites. using the arm band will initialise a dialog that will give you a bunch of information regurding the object that are closest to your current position then at the end it will ask you if you would like to unlock the naerest door. Chose to unlock the door and it should spring open. I haven't encountered a door that this didn't work on.

gund
05-17-2006, 07:48 PM
sorry, probably should have mentioned that i tried that, it opens the door fine, but theres actually no exit on the other side, my guess would be that some script is supposed to trigger off, but it doesnt. Thanks for the try.

Grindel
05-18-2006, 10:36 AM
then you have an issue with a trigger not a door. Really you should try to extract thr original rim's from the installation cause it sounds like you have something messed up. Or something is in the override that it trashing your map. Reguardless of the source of your problem it is not a good idea to edit the exiting original installations script but rather to make a copy of the script by extracting it using the kotorTool and modifing that, then placing the modified script into the override folder.

But as for your problem. if you can hack passed the door using the armband and the trigger still dosen't warp you to the next module that I would think that the power shutdown script somehow activates the warp trigger. However back to me previous point replaceing existing file with original installations files would be the best solution rather than trieing to debug the problem.

OB1-KeNOOBIE
05-25-2006, 05:34 PM
Are you going to the right door? I'm pretty sure you have to go back to the doorway your rescuers spawn at, and not the other door on the opposite side from where you begin the map. It's a retrieval and extraction mission and not a fight your way to the other side kinda thing....I'm not insulting your intelligence but I fought my way to the wrong door during that part and was surprised when it didn't open.