PDA

View Full Version : Disconnected from OJP Basic


Paro
08-15-2006, 01:04 PM
On map restart some people(mostly all) that don't have the OJP Basic 'installed' get disconnected from the OJP Basic running server...

razorace
08-15-2006, 06:20 PM
You mean on the meatgrinder? I haven't heard of this problem before. Are you sure that most people aren't just leaving the game due to a gametype change?

Paro
08-15-2006, 07:07 PM
It was on the server we're running, and there was like 6-8 base players and ALL at once disconnected on map restart and only me and one dude remained because we had OJP Basic running. And another error that occurs is that sometimes people have problems joining without OJP Basic on a OJP Basic server, tried it on other servers too, same problem. 'Unknown event <number> soomething' is how the error looks like...

Lathain Valtiel
08-16-2006, 12:49 AM
I smell a client detection error and thus the holstering code is kicking in.

ensiform
08-16-2006, 01:06 AM
Yep, the server must be sending an event that the client version you are using does not have or basejka does not have.

Lathain Valtiel
08-16-2006, 01:38 AM
It's the holster code, without a shadow of a doubt.

This isn't too surprising, OJPs client detection is quite wonky, especially if you dare employ reconnect.

Paro
08-16-2006, 05:43 AM
So...any solutions?

razorace
08-16-2006, 08:19 PM
So, we suspect its the holster code and that it only happens on map switches?

Paro
08-16-2006, 08:47 PM
Only on map_restart, on map switches it works(atleast it seems that way).
By the way, it does not happen everytime a map_restart occurs, only sometimes which is even more confusing to me...

razorace
08-16-2006, 09:19 PM
hmmm, it's probably confusing my client detection somehow. Any clue what the error message is for the dropped clients?

Lathain Valtiel
08-17-2006, 11:54 AM
I wouldn't be stunned to hear it happens on reconnect too. OJP's client detection has borked there.

Paro
08-17-2006, 01:07 PM
The error: "Unknown Event something..."

EDIT: sry too lazy to experiment with it, I think it occurs when atleast one client has OJP

razorace
08-17-2006, 01:20 PM
Yeah, it sounds like it's a problem with my client detection system. I'll have to look into it.

razorace
08-19-2006, 05:59 AM
Well, I found some minor holes in the client detection but I'm not sure it's going to fix the problems mentioned. Let me know if the problems continue after the next Basic release.

Paro
08-19-2006, 06:45 AM
Will do.

Lathain Valtiel
08-20-2006, 12:46 AM
Well, I found some minor holes in the client detection but I'm not sure it's going to fix the problems mentioned. Let me know if the problems continue after the next Basic release.

FYI, your latest file with that fix won't compile unless we remove the pers. part.

Vruki Salet
08-20-2006, 02:03 AM
Yeah I can't seem to get a new correct g_local.h from CVS when I update. Can you post the contents of the new one here?

razorace
11-28-2006, 02:23 AM
Sorry, I guess I missed this post before. Try checking the SVN code, it will have the fix there.