PDA

View Full Version : Yet another X-Wing / Win XP compatibility issue. (Sorry :P)


inkwolf
08-23-2006, 04:51 PM
Hi there. I am having trouble running x-wing, specifically the collector series version with the upgraded X-Wing vs. Tie Fighter graphics. I was able to install the game from the CD without any issues. The launcher comes up just fine too; but when I click on the "Play X-Wing" button on the launcher, the screen goes black (I assume it's switching to 640x480 mode) I see the "hourglass" mouse icon in the center of the screen for a split second, then I get booted back to XP. There are no error messages, the X-Wing launcher isn't there anymore, and nothing seems wrong (other than the fact that I am of course not playing X-Wing :P).

I've found the X-Wing/Tie Fighter 95 compatibility fix file and I've even seen a thread about renaming the XWING95.EXE file to Z_XVT__.EXE. Unfortunately, neither of these solutions work for me. They both result in the same behavior described above. I've also tried setting the compatibility mode for XWING95.EXE to win 95 and win 98/ME, but this results in the game not being able to recognize my usb joystick (an error message pops up before the game even attempts to launch and wont let me past that point).

So I'm not quite sure what to do. Any help would be greatly appreciated.

If it helps, here's what I'm trying to run it with:

OS: Windows XP
Joystick: Logitech Attack 3 USB
Video Card: GeForce FX 5500
Direct-X version: 9.0c

Also, it may be of note that I was able to successfully install and run all of the following (these are all still currently on my system):

Tie Fighter collector CD version (from same bundle with the X-Wing I'm having trouble with)
X-Wing Collector's CD-ROM (older version with the original graphics; I got this running with VDMSound)
X-Wing vs. Tie Fighter (full version, not the Flight School version)
XvT Balance of Power expansion

Again, any help will be very appreciated. Thanks.

Wildstar
08-23-2006, 06:58 PM
I'd try creating a shortcut directly to the XWing95.exe file rather than use the launcher. It should prompt you to insert the CD at an appropriate moment. If this fails, try a reinstall of XW95.

inkwolf
08-24-2006, 03:44 PM
Thanks for the help Wildstar. Unfortunately, I've tried both of your suggestions and I'm still running into the same problem. Running XWING95.EXE directly instead of going through the launcher results in the same problem and re-installing x-wing didn't help either.

Might I be installing the compatibility fix incorrectly? Do I need to run it from the Program Files/Lucasarts/XWING95/ folder? Do I need to run it before installing x-wing? The readme for the fix mentions going into a "compatibility administrator" for installation on windows 2000. Again, I have XP on my machine, but might this be something to look into? How do I get to the "compatibility administrator"?

Again, if I set the compatibility mode for XWING95.EXE to win 95, I get an error about not having a joystick plugged in. Is there anyway to get around this error? Maybe if I try running it as win 95, it won't crash out on me.

Thanks again! I hope I can get this working eventually; I'd like to see x-wing with the improved graphics, but at least I still have the older version of x-wing running!

Wildstar
08-25-2006, 10:34 AM
Since you have TIE95, which runs on the same engine as XW95, running, I think you did everything OK. I'm beginning to suspect a corrupt disk. You might want to head over to the LucasArts support forums (http://forums.lucasarts.com) and post everything you've told me...Emkay1001 is pretty good with stuff I can't troubleshoot and I want to see what he says. (Note: If you have a login for the StarWars.com forums, that will work on the LucasArts forums as well)

inkwolf
08-25-2006, 09:08 PM
Thanks again Wildstar; I'll give the LucasArts support forum a try. I think you might be on track with the corrupt disk though. I installed the game on my wife's computer and it worked just fine after I ran the compatibility fix.

I really appreciate your help though!

Alright, I'm gonna head on over to those forums now and copy and paste this post there. :P

inkwolf
08-25-2006, 10:04 PM
Here's a link to my post if you'd like to see what people say there, Wildstar.

http://forums.lucasarts.com/thread.jspa?threadID=113462

Even though I got it working on my wife's computer I'm still hoping to get it working on my computer too.