PDA

View Full Version : Mission/Quest Problems


General Solo
09-05-2006, 02:22 PM
Before I started a new game I installed some mods into TSL and whenever their is a mission/quest that I have to do, it won't work for some reason. Like when you are on Telos and the Sullistan is being harassed by those 2 Mercenaries adn when I go up to them you should be able to enter a conversation with him but for some reason it just does nothing, same for anyother mission/quest in the game. So if anyone knows how to help me with this problem or maybe you know some mods that mess up the game like this then please tell me.

Char Ell
09-06-2006, 11:22 AM
Have you tried saving your game just before you encounter the Sullustan on Telos, removing your TSL mods, then playing through the scene to make sure it works right?

General Solo
09-06-2006, 01:28 PM
Yea I did save the game before I met the sullistan but it still isn't working. Maybe it is because of that skip paragus mod.

Darth333
09-06-2006, 01:32 PM
Which mods did you installed? Do you have .utc files in your override folder and if yes, which ones?

General Solo
09-06-2006, 11:27 PM
None of them have .utc files.

p2000
09-19-2006, 04:03 PM
I'm experiencing a similar problem. On Peragus, the Harbinger never appeared, and by the time I realised it I'd already cleaned out the dorms. I managed to find the global variable in the save that spawns the ship, so I changed it and carried on fine. On the ship itself, Sion never bothered appearing, and Kreia stayed in my party until we boarded the Ebon Hawk, at which point her hand dropped off. Now, after progressing to Telos, the Sullistan diagloue won't start either.

Reloading the Peragus save without any mods works properly, but reloading my Telos save does not. From this I'd speculate that the Harbinger docking script sets some global, without which further proximity-activated cutscenes fail to activate. Your Skip Peragus mod may not set this correctly.

I have no idea which mod I'm using could cause the error either. It's mainly new heads, new constructable-only armours, and Carth/Bastila Ages, with a few TGA-only reskins, plus Team Gizka's fixes. Nothing modified has kicked in yet, other than the modified itemcreate.2da, and I'm using a default head. There's nothing at all that alters any files from 104PER, and the first modified script is changing Carth in a holo recording in the dorms. The only utcs are the modified Carths and Bastilas, most of which I think are new additions anyway.

Edit: after removing things one by one, it appears to be a trigger newgeneric001.utt from the Ebon Hawk Kolto Tank mod that's breaking the Harbinger trigger. It's curious, as I've been nowhere near the Hawk yet.
Edit again: I see why, that name is actually used by the Harbinger trigger. The Sullistan conversation appears to use it too (it triggers 'tr_mercs'). If your mod has a file by that name remove it and see if it helps.
Final edit: the numeric 101PER_Sion_Arrives is all that is changed when the Harbinger docks (to 1), so I presume the problem is with the trigger. The Sullistan encounter doesn't work in my broken-Harbinger save, but I'll restart from before the Harbinger docks and check it works without the EH Kolto Tank newgeneric001.utt from a 'clean' save.

RedHawke
09-20-2006, 02:13 AM
Remove that EH Kolto Tank Mod as that newgeneric001.utt file is definitely causing your problems, as newgeneric001.utt is a trigger that is used in most of the other modules, it is easily seen that it isn't a unique file by simply browsing the various modules.

I hope this helps, as confirmation to what you already figured out yourself anyway. ;)

p2000
09-20-2006, 02:05 PM
Thanks, yeah it definitely was the problem, I just made the Ebon Hawk level entry script trigger the spawn script instead.